Видео: Звук есть, картинки нет

Да, это снова я((((
Выбрал наконец время, сел посмотреть кино... В Драгоне - звук есть, картинки - нет. Ставил KMPlayer - не помогает. Тоже самое. Хотя, помнится когда я последний раз смотрел видео ( недели 4 назад) - все пело и играло. kubuntu-restricted-extras - стоит. В чем прикол?

ВложениеРазмер
MPL.txt11.02 кб
SMP.txt193.35 кб
0
DarkneSS - 15 Декабрь, 2010 - 01:02
Изображение пользователя DarkneSS.

Драгон, Кмплеер это всё треш. Пробуйте Смплеер или Vlc.

0
Lexxa - 15 Декабрь, 2010 - 01:03

В Драгоне - звук есть, картинки - нет. Ставил KMPlayer - не помогает.
То есть после установки KMPlayer в Драгоне видео не появилось? Логично. :)
В терминале запускаем mplayer имя_файла и смотрим, на что ругается.

0
Skandalli - 15 Декабрь, 2010 - 01:32

SMPlayer тоже не потянул.
В mplayer через терминал всё завелось: и звук, и картинка.
А Драгон, KMPlayer и SMPlayer только звук дают.

MPlayer 1.0rc4-4.4.5 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Uni.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [XVID]  704x384  12bpp  25.000 fps  1531.0 kbps (186.9 kbyte/s)
Clip info:
Software: VirtualDubMod 1.5.10.2 (build 2540/release)
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: No such file or directory.
[VO_3DFX] Unable to open /dev/3dfx.
[vdpau] Error when calling vdp_device_create_x11: 1
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4 @ 0x13eb9a0]Invalid and inefficient vfw-avi packed B frames detected
Movie-Aspect is 1.83:1 - prescaling to correct movie aspect.
VO: [xv] 704x384 => 704x384 Planar YV12
A:  20.6 V:  20.6 A-V:  0.000 ct: -0.040 517/517 11%  0%  0.5% 3 0
Exiting... (Quit)

0
DarkneSS - 15 Декабрь, 2010 - 01:36
Изображение пользователя DarkneSS.

В нормальных плеерах открываем настройки-видео и балуемся с устройствами вывода. Рекомендую xvideo

0
Skandalli - 15 Декабрь, 2010 - 01:55

C xvideo в SMPLayer не пошло. Пошло с X11. Поставил VLC - там все понеслось "из коробки"
Спасибо за "скорую помощь";)

0
DarkneSS - 15 Декабрь, 2010 - 08:31
Изображение пользователя DarkneSS.

Что-то с дровами на видео, раз такие дела.

0
Skandalli - 15 Декабрь, 2010 - 13:48

А что с ними может быть? Карточка NVIDIA, дрова ставил через менеджер (как и всегда впрочем)
Вот тут вот что-то подобное, как мне кажется. cairo-dock стоит, но не в автозапуске. glib-java не установлен.

0
DarkneSS - 15 Декабрь, 2010 - 14:24
Изображение пользователя DarkneSS.

Сколько у вас выдаёт glxgears при простое системы и при просмотре видео?

0
salt - 15 Декабрь, 2010 - 14:02
Изображение пользователя salt.

vlc не подводит много лет

0
Skandalli - 15 Декабрь, 2010 - 14:52

Без видео:
glxgears
9355 frames in 5.0 seconds = 1870.989 FPS
10437 frames in 5.0 seconds = 2086.035 FPS
10510 frames in 5.0 seconds = 2100.995 FPS
10795 frames in 5.0 seconds = 2158.916 FPS
10471 frames in 5.0 seconds = 2092.973 FPS
10763 frames in 5.0 seconds = 2152.524 FPS
10779 frames in 5.0 seconds = 2154.311 FPS
10701 frames in 5.0 seconds = 2140.167 FPS
10932 frames in 5.0 seconds = 2186.129 FPS
10715 frames in 5.0 seconds = 2141.780 FPS
10028 frames in 5.0 seconds = 2004.303 FPS

С VLC
5803 frames in 5.0 seconds = 1160.581 FPS
6494 frames in 5.0 seconds = 1298.769 FPS
6950 frames in 5.0 seconds = 1388.673 FPS
6705 frames in 5.0 seconds = 1340.660 FPS
7033 frames in 5.0 seconds = 1406.563 FPS
4886 frames in 5.0 seconds = 977.176 FPS
5172 frames in 5.0 seconds = 1033.576 FPS
5605 frames in 5.0 seconds = 1120.689 FPS
6847 frames in 5.0 seconds = 1369.291 FPS
6727 frames in 5.0 seconds = 1344.502 FPS
6770 frames in 5.0 seconds = 1353.990 FPS
7022 frames in 5.0 seconds = 1404.379 FPS
6931 frames in 5.0 seconds = 1384.247 FPS
7089 frames in 5.0 seconds = 1417.762 FPS
7103 frames in 5.0 seconds = 1420.487 FPS
6606 frames in 5.0 seconds = 1320.802 FPS
5735 frames in 5.0 seconds = 1143.904 FPS
6370 frames in 5.0 seconds = 1273.663 FPS
5580 frames in 5.0 seconds = 1115.754 FPS
7574 frames in 5.0 seconds = 1514.511 FPS
6196 frames in 5.0 seconds = 1239.179 FPS

0
DarkneSS - 15 Декабрь, 2010 - 16:41
Изображение пользователя DarkneSS.

Фпс норм, даже не знаю, куда вам копать.

0
Skandalli - 15 Декабрь, 2010 - 17:30

А что плохого в том, что вывод в смплейере будет через x11?

+1
Lexxa - 15 Декабрь, 2010 - 17:48

Он медленнее.

У SMPLayer тоже есть логи. В Options --> View logs. На логи мплеера можно бы и глянуть.

0
DarkneSS - 15 Декабрь, 2010 - 17:57
Изображение пользователя DarkneSS.

Если вас устраивает, то ничего плохого.

0
Skandalli - 15 Декабрь, 2010 - 18:02

DarkneSDarkneSS,бредятина какая-то - сейчас полез смотреть отчеты и ради интереса выставил в настройка xvideo - заработал. Начал проверять все остальные плеера - и драгон и кмплейер все играют. За почти десять лет пользования виндой ничего такого не было(( Ничего не понимаю(
Логи прикрепил к первому сообщению.

0
DarkneSS - 15 Декабрь, 2010 - 21:12
Изображение пользователя DarkneSS.

Пардоньте, эти логи не по моей части. Есть идея, что было какое-нибудь микрообновление ядра или иксов или дров, которое снизило производительность до следующего обновления.

0
USP - 16 Декабрь, 2010 - 17:44
Изображение пользователя USP.

cairo-dock установлен? если он установлен проблема может в нем. косяк какой то

лечение для SMPlayer
sudo bash -c "cat > /usr/bin/smplayer.helper" <<EOF
export XLIB_SKIP_ARGB_VISUALS=1
exec smplayer.real "\[email protected]"
EOF

sudo chmod 755 /usr/bin/smplayer.helper
sudo mv /usr/bin/smplayer{,.real}
sudo ln -sf smplayer.helper /usr/bin/smplayer

0
rosenrot - 5 Октябрь, 2012 - 13:26
Изображение пользователя rosenrot.

до сих пор приходится это проделывать с smplayer и smplayer2...все бы хорошо, но после этого у него рамка окна становится какой то стремной

0
USP - 16 Декабрь, 2010 - 17:43
Изображение пользователя USP.

Не в тему. че за косяк с отправкой сообщений не могу отправить((

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры