как откатить обновление системы

Установила kubuntu 10.10. Настроила под себя, поставила любимые драйвера, кодеки, программы.
В связи с медленным и убогим интернетом откладывала обновление программ, но все-таки обновила. Через KPackageKit в разделе "обновление программ". Скачала, установила. После этого начались ужасные тормоза на ровном месте и треск звука.
Возможно ли как-то откатить установку всех тех пакетов?
P.S.
Треск звука так же был замечен, если на чистую систему поставить рекомендуемые драйвера Nvidia. Лечилось установкой драйверов 173 серии.

0
DarkneSS - 7 Январь, 2011 - 17:41
Изображение пользователя DarkneSS.

Единственный способ- найти пакеты с нужными версиями и установить их через dpkg. Но успех всё равно не гарантирован :-(

0
picaro - 7 Январь, 2011 - 18:06
Изображение пользователя picaro.

Самый хороший вариант (если нету бекапов) - это настроить всё заново.

0
Kombala - 7 Январь, 2011 - 18:08
Изображение пользователя Kombala.

В принципе тут скорее всего придется переустанавливать с нуля.

P.S.
не забывайте делать backup. Он всегда одинаково полезен.

0
mft - 7 Январь, 2011 - 18:26

Да, скорее всего не получится. В APT не предусмотрен откат пакетов. Можно попробовать вручную указывать версию, но если их много то это почти нереально.

Если обновления были установлены из ppa, то всё намного проще. Можно воспользоваться ppa-purge.

0
kissbb - 8 Январь, 2011 - 01:36

Установлено было около полутора сотен =(
Жаль, прийдется заново мучаться =)

0
Kombala - 8 Январь, 2011 - 01:54
Изображение пользователя Kombala.

ну вы сохраните списочек репозиториев, деб-пакеты скиньте куда-нибудь. И уже со спокойной душой переустанавливайте.

0
mft - 8 Январь, 2011 - 07:47

Лучшим решением было бы найти причину тормозов и устранить их. Посмотреть в системном мониторе какой процесс загружает процессор. И искать решение, если самостоятельно не удаётся решить проблему.

0
kissbb - 8 Январь, 2011 - 14:48

Смотрела =) В том-то все и дело, что ни сис.монитор ни top не показывают ни одного процесса, который бы загружал ЦП больше, чем не 2,5%-3%. А тормоза есть. Я пока что плохо разбираюсь в линуксе, поэтому и найти проблему для меня проблематично =(
P.S.
Переустановила, настроила - работает, как часики =)

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры