Проблема с обновлением KDE РЕШЕНО

Изображение пользователя lord_i.

Вчера при очередном обновлении порадовало следующими строками:
Получено 12,2MБ за 49с (247kБ/c)                                                                              
(Чтение базы данных ... на данный момент установлено 294283 файлов и каталогов.)
Подготовка к замене пакета kde-l10n-engb 4:4.6.0-0ubuntu1~maverick1~ppa1 (используется файл .../kde-l10n-engb_4%3a4.6.1-0ubuntu1~maverick1~ppa1_all.deb) ...
Распаковывается замена для пакета kde-l10n-engb ...
dpkg: не удалось обработать параметр /var/cache/apt/archives/kde-l10n-engb_4%3a4.6.1-0ubuntu1~maverick1~ppa1_all.deb (--unpack):
попытка перезаписать /usr/share/locale/en_GB/LC_MESSAGES/khtmlsettingsplugin.mo, который уже имеется в пакете konq-plugins-l10n 4:4.4.0-2ubuntu3~maverick1~ppa1
dpkg-deb: подпроцесс вставка завершён по сигналу (Обрыв канала)
Подготовка к замене пакета kde-l10n-ru 4:4.6.0-0ubuntu1~maverick1~ppa1 (используется файл .../kde-l10n-ru_4%3a4.6.1-0ubuntu1~maverick1~ppa1_all.deb) ...
Распаковывается замена для пакета kde-l10n-ru ...
dpkg: не удалось обработать параметр /var/cache/apt/archives/kde-l10n-ru_4%3a4.6.1-0ubuntu1~maverick1~ppa1_all.deb (--unpack):
попытка перезаписать /usr/share/locale/ru/LC_MESSAGES/rellinks.mo, который уже имеется в пакете konq-plugins-l10n 4:4.4.0-2ubuntu3~maverick1~ppa1
dpkg-deb: подпроцесс вставка завершён по сигналу (Обрыв канала)
Обрабатываются триггеры для man-db ...
При обработке следующих пакетов произошли ошибки:
/var/cache/apt/archives/kde-l10n-engb_4%3a4.6.1-0ubuntu1~maverick1~ppa1_all.deb
/var/cache/apt/archives/kde-l10n-ru_4%3a4.6.1-0ubuntu1~maverick1~ppa1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Насколько понял - битые архивы? И что с этим делать?
(архивы удалял, качалось вновь с такими-же результатами ...)

0
DarkneSS - 5 Март, 2011 - 12:17
Изображение пользователя DarkneSS.

Они не битые, а просто претендуют перезаписать файлы из других пакетов. Если очень хочется, их установить, то ставьте через dpkg, если не получится, то с параметром force или как-то так.

0
lord_i - 5 Март, 2011 - 12:47
Изображение пользователя lord_i.

Я не знаю - хочется мне или не хочется ... Обычно обновление происходило без таких эффектов ...
Насколько я понимаю - это новые языковые пакеты ... Наверное их надо обновить?

0
dm - 5 Март, 2011 - 13:54
Изображение пользователя dm.

Для решения, можно предварительно удалить пакет konq-plugins-l10n а затем дообновиться.

0
lord_i - 5 Март, 2011 - 14:25
Изображение пользователя lord_i.

Спасибо, Сам до этого дошел. :) Хотел оповестить общественность и опоздал :)
Проблема решена.

0
dyug - 5 Март, 2011 - 13:59

dpkg: не удалось обработать параметр /var/cache/apt/archives/kde-l10n-engb_4%3a4.6.1-0ubuntu1~maverick1~ppa1_all.deb (--unpack):
попытка перезаписать /usr/share/locale/en_GB/LC_MESSAGES/khtmlsettingsplugin.mo, который уже имеется в пакете konq-plugins-l10n 4:4.4.0-2ubuntu3~maverick1~ppa1

Меня смутило именно это. Сейчас проверил, у меня конк-плагинс имеет версию 4.6.1, а 4.4.0 откуда он у вас, я вот не знаю... :-(
Или апдейт идет с версии 4.4.0? Кстати, это от какой же версии дистрибутива то?

0
lord_i - 5 Март, 2011 - 14:27
Изображение пользователя lord_i.

Я тем более не знаю :) Конком не пользуюсь вообще ... Видать тянется с давних времен :)

0
dyug - 5 Март, 2011 - 17:03

я обнаружил эти пакеты.. у меня они не стоят, хотя сам конкуер стоит. и пришет по русски.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры