Раздача Интернета 3G через WiFi. Не проходять пинги [Решено]

На ноуте настроил подключение с помощью Раздаем gprs/edge/3g интернет через wi-fi
lan.sh

После запуска
iwconfig

netstat -n -r

на клиенте сеть сканируется

После подключения с помощью КНетворкМанагера

cat /etc/network/interfaces

netstat -n -r

Но с клиента не пингуется ноут, который должен раздавать инет
ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
From 192.168.0.3 icmp_seq=1 Destination Host Unreachable
From 192.168.0.3 icmp_seq=2 Destination Host Unreachable
From 192.168.0.3 icmp_seq=3 Destination Host Unreachable
^C
--- 192.168.0.1 ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 3016ms
pipe 3

Комментарии (17)

0
Жюстина - 19 Март, 2011 - 15:44
Изображение пользователя Жюстина.

ifconfig бы ещё посмотреть на обоих компутерах

У мну проще: (и без всяких скриптов вообще)

На клиенте просто через кнетворкманагер хорошо подключается.

А как так может быть что 2 интерфейса wifi0 и wlan0 с одним ссидом даже???

0
rlepish - 19 Март, 2011 - 21:11

сервер
ifconfig

клиент
до подключения
iwconfig

и после подключение через КнетворкМанагер
iwconfig

0
Жюстина - 20 Март, 2011 - 00:20
Изображение пользователя Жюстина.

Сервер не выдаёт вифи соединения, и к тому же их слишком много. Точно 3 штуки? Три устройства которые вифи?

Интерфейсы wlan1, wlan0 и wifi0 просто не работают!!!

ifconfig на много важнее чем iwconfig вообще-то...

То что две точки соединились это не значит, что они в одной сети(просто они нашли друг дружку в радио и всё! им ещё как то нужно ипи иметь обоим!!!), у "сервера" вообще нет ипи для wifi ни для одного интерфейса!!!

Дажа обьясню проще, у просто настроенного интерфейса ifconfig показывает такой параметр, ну как тут у ppp0: inet addr:46.203.36.193 такой же параметр должен быть и у вифи интерфейса!

0
rlepish - 20 Март, 2011 - 16:12

да, было 3.
не знал что мой ноут встроенную карту имеет (Intersil Corporation Prism 2.5 WaveLan chipset (rev 01)
А тут подарили Wireless PC Card Netgear WG511, вот и занялся постройкой домашней сети.
Выдернул WG511, остались устройства wifi0 и wlan0
переписал подключение на вифи0, теперь у вифи0
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0

но с клиента не пингуется

При включении

+1
dyug - 20 Март, 2011 - 19:07

У тебя одно устройство, и как я помню, в этом случае нужно настраивать влан0
ибо это интерфейс для работы, а вифи0 -это интерфейс управления.
Был у меня такой один ноут, как раз в таком виде и выдавал.

0
alexapod75 - 19 Март, 2011 - 17:28

А как тогда инет рррасшарить? Я через нетворк менеджер создал точку доступа. Пингуется

0
Жюстина - 19 Март, 2011 - 18:24
Изображение пользователя Жюстина.

Ф подшифку бегом, там есть статья о NAT... А для удобствиев всяких, по интернету поискать ещё можно про настройку dhcp3-server.

0
alexapod75 - 19 Март, 2011 - 18:49

я. конечно. понимаю знатоков. Но! Сам в линуксе совсем недолго. В Мастдае все было проще для меня. Поставил Connectyfi и не знаешь горя, а здесь все сложнее. Подсказать некому. 3 раза уже убил систему, благо резервные копии еще никто не отменял. Просьба на пальцах объяснить как это можно сделать. Со всем уважением....Сетть настроить методом тыка удалось. А вот насчет инета пока никак

0
alexapod75 - 19 Март, 2011 - 18:51

Тема подымалась тысячу раз, но решения я так и не нашел

+3
Жюстина - 20 Март, 2011 - 02:36
Изображение пользователя Жюстина.

Мда уш... щаз как разжую...

Настройка сервера

И так... Компутер, который у меня сервер, и раздаёт в wifi интернет, получает его через через интерфейс сетевой eth0

Дальше делается как описано тут

То есть проделаны команды от root:

iptables -F
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
iptables-save > /etc/iptables.up.rules

Изменён файлик /etc/sysctl.conf где указан параметр net.ipv4.ip_forward = 1 и вставлена строчка восстановления правил при переподключении в /etc/network/interfaces

После этого всего консолировать: sudo /etc/init.d/networking restart

Настрока клиента

Тут всё просто в нетворкманагере установить для wifi
адрес 192.168.10.1
маска 255.255.255.0
шлюз 192.168.10.2 - это ипи сервера!!!
днс записывается тот которым пользуется сам сервер, и не важно что он вообще может находится в другой подсети!
У меня это 192.168.1.1 (адрес модема)

У меня wifi на сервере не работало при установленном network-manager!!!

И ничего сложного, вдумываться просто надо когда читаешь, а решение всегда в линуксе под ногами валяется, просто уметь надо его видеть же! А то не нашлось решения...

0
alexapod75 - 20 Март, 2011 - 10:51

Послушай, Жюстина. В том то и дело, что под ногами не валяется. И подсказать некому.И самому некогда. Знакомому системану поставил задачу- ответ: Настрой NAT и все. Что мне нравится на форумах, все такие грамотные...Все знают и понимают, а когда с нуля начинать прижопица, то как с вами ообщаться Когда ни в голове ни в ж....Мне реально надо по строчкам. Потом буду разбираться

0
alexapod75 - 20 Март, 2011 - 10:53

Меня все устраивает и нравится в лине, кроме автокада и соответственно настроек сети

0
alexapod75 - 20 Март, 2011 - 11:04

Занимаюсь видеонаблюдением, а тут пришли серваки с линухом. Приятно, конечно, Но, инженер в отпуске, приходится самому решать задачку

0
dyug - 20 Март, 2011 - 19:10

Решение в данном случае валяется, ибо описание, как расшарить инет описано в сообщении Жюстин
На мой взгляд - вполне правильно. :-)

0
Жюстина - 20 Март, 2011 - 20:43
Изображение пользователя Жюстина.

От пасип, а то и не знала как на нытьё это ответить, а то всё разжуёшь, говоришь глотай, а в ответ: "А не хатюююююю"

+1
dyug - 20 Март, 2011 - 21:03

Меня, если честно, тоже смутило нытье на тему "Что мне нравится на форумах, все такие грамотные.. в сочетании с В том то и дело, что под ногами не валяется. И подсказать некомув виде ответа на ответ как сделать...
И самому некогда.
Где то я это уже слышал, и не раз.
А! Вспомнил, я это слышу всегда, когда говорю - почитай документацию.
"Я специалист, я документацию не читаю!"

+1
rlepish - 23 Март, 2011 - 13:34

Спасибо, Жюстина, разобрался (снес все настройки и настроил по аналогии, как у тебя, только на сервере режим выставил master) и все заработало

п.с. лечение
1) снес NetworkManager s
udo apt-get remove network-manager
2) проделаны команды от root (т.е. sudo su), а я выполнял комманды с помощью sudo

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры