что-то с установщиком [РЕШЕНО]

Изображение пользователя tigris.

привет всем, в чем может быть проблема?:
[email protected]:~$ sudo add-apt-repository ppa:bean123ch/burg
Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 55, in
sp = SoftwareProperties()
File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 90, in __init__
self.reload_sourceslist()
File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 538, in reload_sourceslist
self.distro.get_sources(self.sourceslist)
File "/usr/lib/python2.6/dist-packages/aptsources/distro.py", line 90, in get_sources
raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template

+1
alex286 - 16 Апрель, 2011 - 20:45
Изображение пользователя alex286.

sudo apt-get install -f
apt-get autoremove не "канает"?

+1
tigris - 16 Апрель, 2011 - 21:22
Изображение пользователя tigris.

я в общем-то не глупый человек, это пробовал в первую очередь

+1
Mihkel - 16 Апрель, 2011 - 20:46

А система какая? 10.10 или 11.04?

0
tigris - 16 Апрель, 2011 - 21:22
Изображение пользователя tigris.

10.10

0
DarkneSS - 16 Апрель, 2011 - 22:19
Изображение пользователя DarkneSS.

Написано же.

0
Firemies - 16 Апрель, 2011 - 22:23
Изображение пользователя Firemies.

я думаю банально временно репозиторий не доступен , у меня так было правда на 11.04

0
DarkneSS - 16 Апрель, 2011 - 22:24
Изображение пользователя DarkneSS.

Ланчпад так чудит? о_0

+1
Firemies - 16 Апрель, 2011 - 22:27
Изображение пользователя Firemies.

угу когда с альфы на бету переходил

0
Mihkel - 16 Апрель, 2011 - 22:46

А если примитивно вставить в sources.list строчку:

deb http://ppa.launchpad.net/bean123ch/burg/ubuntu maverick main

и apt-get update?
Тогда будет видно, доступен реп или нет.

0
tigris - 16 Апрель, 2011 - 22:53
Изображение пользователя tigris.

раз:

и вот еще что:
хотя kate запустился
0
Firemies - 16 Апрель, 2011 - 22:59
Изображение пользователя Firemies.

точно реп висит подожди до утра или переключись на основной сервер по обновлению

0
tigris - 16 Апрель, 2011 - 23:19
Изображение пользователя tigris.

а с sudo что? раньше такого не было.

0
Mihkel - 16 Апрель, 2011 - 23:27

Ну, не знаю...
Ровно две минуты назад у меня burg без вопросов установился с вышеприведенной строчки. (Я тут как раз с 11.04 играюсь).
Прекрасно работает. Так что реп на месте и в порядке.
По первому пункту:
Ключ, в принципе, можно и не верифицировать. Ничего страшного не случится. Поставить пакеты без аутентификации, а потом эту строчку из источников стереть и забыть. Вряд ли burg обновлять придется.
А вот по второму пункту явно что-то с правами. Может, в этом все и дело?

0
Firemies - 16 Апрель, 2011 - 23:27
Изображение пользователя Firemies.

это у тебя после обновления в sudo не понятки ,в 10.10 кде 4.6.2

0
Vlad_W_1999 - 16 Апрель, 2011 - 23:29

С чем говоришь? С sudo?

0
Mihkel - 16 Апрель, 2011 - 23:28

переключись на основной сервер по обновлению

А там разве burg есть?

0
Firemies - 17 Апрель, 2011 - 08:12
Изображение пользователя Firemies.

[email protected]:~$ sudo kate /etc/apt/sources.list
[sudo] password for tigris:
Error: "/var/tmp/kdecache-tigris" is owned by uid 1000 instead of uid 0.
kate(22754)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/usr/share/mime/magic"
перезапусти сеанс и все будет ок
или очисти kdecache
Единственное, что понял: можно попробовать очистить /var/tmp/kdecache-username
Автор, пробуйте: sudo rm -rf /var/tmp/kdecache-username

0
tigris - 17 Апрель, 2011 - 08:41
Изображение пользователя tigris.

решилось очисткой kdecashe. всем спасибо.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры