Помогите отключить официально неподдерживаемые обновления в 11.04

Добрый день всем.

В 11.04 в связи с релизом новой версии Амарока и корректирующего пакета к KDE 4.6.3 добавил репозитории ppa:kubuntu-ppa/backports и ppa:kubuntu-ppa чтобы их обновить. Но на 10.10 я помню как наигрался с неподдерживаемыми официально обновлениями когда у меня в Firefox пропали все поисковые системы вместо которых появилось только Ask.com и прочая ерунда появилась. Так вот, думаю посмотрю а не пересекаются ли эти самые неподдерживаемые обновления с обновлениями из названных репозиториев - зашел в KpackageKit, настройки - изменить репозитории и там на вкладке обновления поставил галку "официально неподдерживаемые обновления". Убедился что это совсем разные вещи с пакетами из названных выше репозиториев, но вот теперь эту галку просто не могу убрать - ни одна из галок во вкладке обновления не убирается.

Вопрос - как отключить эти самые неподдерживаемые обновления, может укажете где лежит конфиг менеджера пакетов, чтобы его снести?

Всем ответившим заранее спасибо.

0
Гость - 16 Май, 2011 - 11:49

Нашел костыль - если на первой вкладке "Программное обеспечение Кубунту" снять все галки, то галки с обновлениями тоже очистятся, потом нужно поставить их на место и на вкладке обновления выбрать нужные галки - но снимать галки прямо во вкладке "обновления" не получается

0
DarkneSS - 16 Май, 2011 - 12:52
Изображение пользователя DarkneSS.

Сорс-лист поправить и не париться.

0
_victor_ - 16 Май, 2011 - 20:08
Изображение пользователя _victor_.

Не столько в качестве ответа, как дополнение:
/ets/apt/будет несколько sours.list . Возьми один из старых сохраненных (просмотри их в kate) и замени действующий. И будет тебе счастье.

0
DarkneSS - 16 Май, 2011 - 21:21
Изображение пользователя DarkneSS.

Лучше не тусовать файлы, а прочитать описания веток репозиториев в сети и закомментировать/удалить лишние строки.

0
trubadur4ik - 17 Май, 2011 - 15:30
Изображение пользователя trubadur4ik.

Мне кажется, что ТС ничего из вышесказанного не понял...

0
Dimooon85 - 20 Май, 2011 - 11:54

Но-но-но! Понять то я все понимаю, вот только был вопрос о том, какая строчка соответствует этой галке вот и все, но следующий за темой ответ я же и написал как я решил эту проблему.

0
Гость - 21 Май, 2011 - 16:39

Файлом конфигурации является: /etc/apt/sources.list

"Официально не поддерживаемые обновления" это строки:

deb http://archive.ubuntu.com/ubuntu/ natty-updates universe
deb http://archive.ubuntu.com/ubuntu/ natty-updates multiverse

Закомментируй под рутом например в kate или используй sudoedit в консоли.

0
uicraor - 21 Май, 2011 - 19:15
Изображение пользователя uicraor.

а вот эти официально поддерживаемые обновления? (:
deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu natty main
deb http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu natty main

0
DarkneSS - 21 Май, 2011 - 20:16
Изображение пользователя DarkneSS.

Ппа же ;-)
Нет, официально неподдерживаемые.

0
uicraor - 22 Май, 2011 - 08:05
Изображение пользователя uicraor.

черт, а как тогда обновлять кеды до последних если это официально неподдерживаемые репы? (:

0
DarkneSS - 22 Май, 2011 - 11:51
Изображение пользователя DarkneSS.

Обновлять дистрибутив. Я так и делал в 1й раз: не знал про ппа.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры