Не обновляется система с версии 11.04 до 11.10.[Решено]

Пробую обновить систему через консоль вылетает это:
[email protected]:/home/s# apt-get dist-upgrade
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
Расчёт обновлений... Неудачно
Пакеты, имеющие неудовлетворённые зависимости:
ia32-libs : Рекомендует: ia32-libs-multiarch но он не может быть установлен
             Ломает: nspluginwrapper (< 1.4.4-0ubuntu2) но 1.2.2-0ubuntu9 будет установлен
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.

Подскажите, как решить проблему?

0
DarkneSS - 16 Октябрь, 2011 - 16:40
Изображение пользователя DarkneSS.

Добавить -f

0
beast666_st - 20 Октябрь, 2011 - 19:16

Куда добавить?

0
useless_dream - 20 Октябрь, 2011 - 19:18
Изображение пользователя useless_dream.

[email protected]:/home/s# apt-get dist-upgrade -f

0
beast666_st - 20 Октябрь, 2011 - 19:21

Не помогло.
[email protected]:/home/s# apt-get dist-upgrade -f                                                                                                                       
Чтение списков пакетов... Готово                                                                                                                                                  
Построение дерева зависимостей                                                                                                                                                    
Чтение информации о состоянии... Готово                                                                                                                                           
Расчёт обновлений... Неудачно                                                                                                                                                     
Пакеты, имеющие неудовлетворённые зависимости:                                                                                                                                    
ia32-libs : Рекомендует: ia32-libs-multiarch но он не может быть установлен                                                                                                      
             Ломает: nspluginwrapper (< 1.4.4-0ubuntu2) но 1.2.2-0ubuntu9 будет установлен                                                                                        
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.

0
useless_dream - 20 Октябрь, 2011 - 19:27
Изображение пользователя useless_dream.

попробуйте вместо "apt-get" - "aptitude", только для начала нужно его установить "apt-get install aptitude"

0
beast666_st - 20 Октябрь, 2011 - 19:48

Установилось. Пробую aptitude dist-upgrade
Говорит "Ошибка сегментирования"

0
useless_dream - 20 Октябрь, 2011 - 20:11
Изображение пользователя useless_dream.

на этом мои познания закончились=)

с такой ошибкой никогда не сталкивался

0
beast666_st - 20 Октябрь, 2011 - 20:19

Ну все равно спасибо. Подождем человека с глубокими познаниями.

0
trubadur4ik - 20 Октябрь, 2011 - 20:50
Изображение пользователя trubadur4ik.

Насколько я помню, на форуме разбирали уже проблему с ошибкой сегментирования. Воспользуйтесь поиском, может и найдете что-нибудь полезное.

+2
dm - 20 Октябрь, 2011 - 22:00
Изображение пользователя dm.

Попробуйте удалить nspluginwrapper и flashplugin-installer и после этого обновиться.

sudo aptitude remove nspluginwrapper flashplugin-installer

sudo aptitude dist-upgrade

0
beast666_st - 21 Октябрь, 2011 - 02:30

Ваш вариант помог. Как мне самому это в голову не пришло...

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры