Удаление nouveau в Kubuntu 11.10 x64

Изображение пользователя Flameflower.

Собственно САБЖ.
Как выпилить? У кого какие предложения?
Это прелагает aptitude

Развернуть/свернуть скрытый текст.
[email protected]:~$ sudo aptitude purge libdrm-nouveau1a xserver-xorg-video-nouveau
Следующие пакеты будут УДАЛЕНЫ:                 
  libdrm-nouveau1a{p} xserver-xorg-video-nouveau{p}
0 пакетов обновлено, 0 установлено новых, 2 пакетов отмечено для удаления, и 3 пакетов не обновлено.
Необходимо получить 0 Б архивов. После распаковки освободится 483 kБ.
Следующие пакеты имеют неудовлетворённые зависимости:
  xserver-xorg-video-all: Зависит: xserver-xorg-video-nouveau но его установка не запланирована.
  libgl1-mesa-dri: Зависит: libdrm-nouveau1a (>= 2.4.23) но его установка не запланирована.
  plymouth: Зависит: libdrm-nouveau1a (>= 2.4.23) но его установка не запланирована.
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                                   
1)      flashplugin-downloader                                    
2)      flashplugin-installer                                     
3)      libasound2                                                
4)      libasound2-plugins                                        
5)      libasyncns0                                               
6)      libatk1.0-0                                               
7)      libavahi-client3                                          
8)      libavahi-common3                                          
9)      libc6                                                     
10)     libcairo2                                                 
11)     libcomerr2                                                
12)     libcups2                                                  
13)     libcurl3                                                  
14)     libdatrie1                                                
15)     libdb5.1                                                  
16)     libdbus-1-3                                               
17)     libexpat1                                                 
18)     libffi6                                                   
19)     libflac8                                                  
20)     libfontconfig1                                            
21)     libfreetype6                                              
22)     libgcc1                                                   
23)     libgcrypt11                                               
24)     libgdk-pixbuf2.0-0                                        
25)     libglib2.0-0                                              
26)     libgnutls26                                               
27)     libgpg-error0                                             
28)     libgssapi-krb5-2                                          
29)     libgtk2.0-0                                               
30)     libice6                                                   
31)     libidn11                                                  
32)     libjack-jackd2-0                                          
33)     libjasper1                                                
34)     libjpeg62                                                 
35)     libjson0                                                  
36)     libk5crypto3                                              
37)     libkeyutils1                                              
38)     libkrb5-3                                                 
39)     libkrb5support0                                           
40)     libldap-2.4-2                                             
41)     libnspr4                                                  
42)     libnspr4-0d                                               
43)     libnss3                                                   
44)     libnss3-1d                                                
45)     libogg0                                                   
46)     libpango1.0-0                                             
47)     libpcre3                                                  
48)     libpixman-1-0                                             
49)     libpng12-0                                                
50)     libpulse0                                                 
51)     librtmp0                                                  
52)     libsamplerate0                                            
53)     libsasl2-2                                                
54)     libsasl2-modules                                          
55)     libselinux1                                               
56)     libsm6                                                    
57)     libsndfile1                                               
58)     libspeexdsp1                                              
59)     libsqlite3-0                                              
60)     libssl1.0.0                                               
61)     libstdc++6                                                
62)     libtasn1-3                                                
63)     libthai0                                                  
64)     libtiff4                                                  
65)     libuuid1                                                  
66)     libvorbis0a                                               
67)     libvorbisenc2                                             
68)     libwrap0                                                  
69)     libx11-6                                                  
70)     libxau6                                                   
71)     libxcb-render0                                            
72)     libxcb-shm0                                               
73)     libxcb1                                                   
74)     libxcomposite1                                            
75)     libxcursor1                                               
76)     libxdamage1                                               
77)     libxdmcp6                                                 
78)     libxext6                                                  
79)     libxfixes3                                                
80)     libxft2                                                   
81)     libxi6                                                    
82)     libxinerama1                                              
83)     libxrandr2                                                
84)     libxrender1                                               
85)     libxt6                                                    
86)     nspluginviewer                                            
87)     nspluginwrapper                                           
88)     xserver-xorg-video-all                                    
89)     zlib1g                                                    

      Оставить для следующих пакетов их текущие версии:           
90)     libdrm-nouveau1a [2.4.26-1ubuntu1 (now, oneiric)]         

      Оставить следующие зависимости неразрешёнными:              
91)     kubuntu-restricted-addons рекомендует flashplugin-installer
92)     ubuntu-restricted-addons рекомендует flashplugin-installer


Принять данное решение? [Y/n/q/?] q
Отмена всех результатов по разрешению данных зависимостей.
Останов.
apt-get более суров
Развернуть/свернуть скрытый текст.
[email protected]:~$ sudo apt-get purge libdrm-nouveau1a xserver-xorg-video-nouveau
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
Следующий пакет устанавливался автоматически и больше не требуется:
  python-pyudev plasma-widget-kimpanel-backend-ibus xscreensaver-gl plasma-desktopthemes-artwork kdeartwork-theme-window cdparanoia libfreerdp-plugins-standard
  ktorrent-data libindicate-qt1 libkexiv2-data libkipi-data libotr2 libqtscript4-network libqtscript4-gui kde-icons-mono xscreensaver-data libavahi-glib1
  libtag-extras1 libqtscript4-sql libgadu3 k3b-data libqtscript4-xml libbluedevil1 libqjson0 libkpgp4 libqgpgme1 amarok-utils libavahi-ui0 gtk2-engines-qtcurve
  libdebconf-kde0 libksieve4 libqtgstreamer-0.10-0 libgpod4-nogtk amarok-common libkdgantt2 kdegames-card-data libkexiv2-10 libgrantlee-core0 kwin-style-qtcurve
  libqtglib-2.0-0 python-qt4-dbus quassel-data libqtscript4-uitools liblastfm0 kdewallpapers libfreerdp0 libloudmouth1-0 libqtscript4-core remmina-plugin-data
  libmsn0.3 libgpgme++2
Для их удаления используйте 'apt-get autoremove'.
Пакеты, которые будут УДАЛЕНЫ:
  accountsservice* acpi-support* acpid* akregator* alsa-base* alsa-utils* amarok* anacron* apparmor* apport* apport-kde* apturl-kde* ark* at* avahi-daemon*
  avahi-utils* binfmt-support* bluedevil* bluez* bluez-alsa* bluez-cups* brltty* chromium-browser* chromium-browser-l10n* chromium-codecs-ffmpeg* colord*
  console-setup* consolekit* cron* cryptsetup* cups* cups-driver-gutenprint* dbus* dbus-x11* dmsetup* dolphin* dragonplayer* e2fsprogs* ecryptfs-utils* eject*
  freespacenotifier* friendly-recovery* ftp* gconf2-common* grub-common* grub-gfxpayload-lists* grub-pc* grub-pc-bin* grub2-common* gstreamer0.10-qapt* gwenview*
  hostname* hplip* hplip-cups* icoutils* ifupdown* initramfs-tools* initscripts* irqbalance* jockey-common* jockey-kde* k3b* kaccessible* kaddressbook* kamera* kate*
  katepart* kbd* kcalc* kde-baseapps-bin* kde-config-touchpad* kde-runtime* kde-style-qtcurve* kde-window-manager* kde-workspace* kde-workspace-bin* kde-zeroconf*
  kdeartwork* kdebase-runtime* kdelibs-bin* kdelibs5-plugins* kdemultimedia-kio-plugins* kdenetwork-filesharing* kdepasswd* kdepim-groupware* kdepim-kresources*
  kdepim-runtime* kdepim-strigi-plugins* kdepim-wizards* kdepimlibs-kio-plugins* kdesudo* kdm* kdoctools* keyboard-configuration* kfind* khelpcenter4* kinfocenter*
  klipper* kmag* kmail* kmix* kmousetool* knotes* konsole* kontact* kopete* kopete-message-indicator* korganizer* kpat* kppp* kscreensaver* kscreensaver-xsavers*
  ksnapshot* ksysguard* ksystemlog* ktorrent* kubuntu-debug-installer* kubuntu-desktop* kubuntu-firefox-installer* kubuntu-notification-helper* kvkbd*
  kwalletmanager* language-selector-common* language-selector-kde* lftp* libakonadi-calendar4* libakonadi-contact4* libakonadi-kcal4* libakonadi-kde4*
  libakonadi-kmime4* libcalendarsupport4* libcanberra-pulse* libdevmapper-event1.02.1* libdevmapper1.02.1* libdrm-nouveau1a* libeventviews4* libgconf2-4*
  libgl1-mesa-dri* libincidenceeditorsng4* libio-socket-ssl-perl* libk3b6* libk3b6-extracodecs* libkabc4* libkateinterfaces4* libkatepartinterfaces4* libkblog4*
  libkcal4* libkcalutils4* libkcddb4* libkde3support4* libkdegames5a* libkdepim4* libkdepimdbusinterfaces4* libkdewebkit5* libkemoticons4* libkfile4* libkhtml5*
  libkio5* libkipi8* libkleo4* libkmanagesieve4* libkmediaplayer4* libknewstuff2-4* libknewstuff3-4* libknotifyconfig4* libkonq-common* libkonq5abi1*
  libkontactinterface4* libkopete4* libkparts4* libkpimidentities4* libkpimtextedit4* libkpimutils4* libkprintutils4* libksieveui4* libktexteditor4* libktnef4*
  libktorrent-l10n* libktorrent3* libkunitconversion4* libkworkspace4* libkxmlrpcclient4* liblvm2app2.2* liblwp-protocol-https-perl* libmailcommon4*
  libmailtransport4* libmessagecomposer4* libmessagecore4* libmessagelist4* libmessageviewer4* libmicroblog4* libmuonprivate1* libnss-mdns* libokularcore1*
  libparted0debian1* libplasma3* libplasmaclock4abi2* libplasmagenericshell4* libqapt-runtime* libreoffice-kde* libsane* libsolid4* libsolidcontrol4abi2*
  libsyndication4* libtaskmanager4abi2* libtemplateparser4* libunique-1.0-0* libweather-ion6* libwww-perl* linux-generic* linux-image-3.0.0-12-generic*
  linux-image-3.0.0-13-generic* linux-image-generic* linux-sound-base* logrotate* modemmanager* module-init-tools* mountall* muon* muon-installer* muon-notifier*
  muon-updater* netbase* network-manager* network-manager-pptp* ntfs-3g* ntpdate* okular* okular-extra-backends* parted* partitionmanager* pcmciautils*
  plasma-dataengines-addons* plasma-dataengines-workspace* plasma-desktop* plasma-netbook* plasma-scriptengine-javascript* plasma-scriptengine-python*
  plasma-widget-cwp* plasma-widget-facebook* plasma-widget-folderview* plasma-widget-kimpanel* plasma-widget-menubar* plasma-widget-message-indicator*
  plasma-widget-networkmanagement* plasma-widgets-addons* plasma-widgets-workspace* plymouth* plymouth-label* plymouth-theme-kubuntu-logo*
  plymouth-theme-kubuntu-text* plymouth-theme-ubuntu-text* pm-utils* policykit-1* polkit-kde-1* powermgmt-base* ppp* pppconfig* pppoeconf* pptp-linux*
  printer-applet* procps* pulseaudio* pulseaudio-esound-compat* pulseaudio-module-bluetooth* pulseaudio-module-x11* python-kde4* qapt-batch* qapt-deb-installer*
  qtcurve* quassel* rekonq* remmina* remmina-plugin-rdp* remmina-plugin-vnc* rsyslog* sane-utils* screen-resolution-extra* software-properties-kde*
  system-config-printer-kde* systemsettings* telnet* ubuntu-minimal* ubuntu-standard* udev* udisks* ufw* update-manager-kde* upower* upstart* ureadahead*
  usb-creator-common* usb-creator-kde* usb-modeswitch* usb-modeswitch-data* userconfig* util-linux* wireless-crda* xorg* xserver-xorg* xserver-xorg-core*
  xserver-xorg-input-all* xserver-xorg-input-evdev* xserver-xorg-input-mouse* xserver-xorg-input-synaptics* xserver-xorg-input-vmmouse* xserver-xorg-input-wacom*
  xserver-xorg-video-all* xserver-xorg-video-ati* xserver-xorg-video-cirrus* xserver-xorg-video-fbdev* xserver-xorg-video-intel* xserver-xorg-video-mach64*
  xserver-xorg-video-mga* xserver-xorg-video-neomagic* xserver-xorg-video-nouveau* xserver-xorg-video-openchrome* xserver-xorg-video-qxl* xserver-xorg-video-r128*
  xserver-xorg-video-radeon* xserver-xorg-video-s3* xserver-xorg-video-savage* xserver-xorg-video-siliconmotion* xserver-xorg-video-sis* xserver-xorg-video-sisusb*
  xserver-xorg-video-tdfx* xserver-xorg-video-trident* xserver-xorg-video-vesa* xserver-xorg-video-vmware*
ВНИМАНИЕ: Эти существенно важные пакеты будут удалены.
НЕ ДЕЛАЙТЕ этого, если вы НЕ представляете себе все возможные последствия!
  e2fsprogs util-linux (вследствие e2fsprogs) hostname upstart (вследствие hostname)
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 329 пакетов, и 0 пакетов не обновлено.
После данной операции, объём занятого дискового пространства уменьшится на 854 MB.
То, что вы хотите сделать, может иметь нежелательные последствия.
Чтобы продолжить, введите фразу: 'Да, делать, как я скажу!'
?] q
Аварийное завершение.

Пробовал сделать:
modprobe -r noveau
но блобы NVIDIA по прежнему встают корявенько, вернее говоря не удается заставить работать от Nvidia vdpau.
Пробовал прописать в
/etc/default/grub
Это
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"
Добавил в
/etc/modprobe.d/blacklist.conf
Следующее:
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

И все равно получаю
THE DISTRIBUTION-PROVIDED PRE-INSTALL SCRIPT FAILED
P.S.
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Тоже не канает. :(

0
DarkneSS - 24 Октябрь, 2011 - 07:34
Изображение пользователя DarkneSS.

libdrm-nouveau1a можно не удалять.
А что там заставлять? Просто врубить в плеере вдпау, и оно работает. И вряд ли при проблемах с вдпау стоит винить пакеты нуво.

0
SD - 24 Октябрь, 2011 - 08:48

поддерживаю.
нуво нынче корректно себя ведёт.

0
SD - 24 Октябрь, 2011 - 11:38

может это поможет:
blacklist nouveau в blacklist.conf
в /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset acpi_backlight=vendor"
после
sudo update-grub
а видеокарта какая? если не секрет. (убедиться, что драйвер поддерживает вашу видеокарту)
у себя попробовал:

попробовать удалить xorg.conf, перегрузиться и установить видео-драйвер. без xorg.conf живу довольно долго и без хлопот.
ps:
и ещё. после обновления с 11.04 до 11.10 apt-get и aptitude install -f тоже выдавали длиннющие списки на удаление.
0
Flameflower - 24 Октябрь, 2011 - 11:40
Изображение пользователя Flameflower.

Видео дома: Nvidia GTX-275
Видео на работе: Nvidia 7600-GT
Из всего выше предложенного тобой ничего не помогло.
P.S.
Вообщем то я грешу на multiarch, ибо на соседнем компе с грядущей версией openSUSE данных проблем не наблюдается.

0
DarkneSS - 24 Октябрь, 2011 - 12:17
Изображение пользователя DarkneSS.

У меня мультиарч, установлены все пакеты нуво, не заблеклистены, стоит блоб от нвидиа, установленный через менеджер проприетарных драйверов. Вдпау работает.

0
Flameflower - 24 Октябрь, 2011 - 12:22
Изображение пользователя Flameflower.

Какой именно драйвер ставил используя jockey-kde?

0
SD - 24 Октябрь, 2011 - 13:08

у меня тоже, что и у Даркнесса и тоже проблем нет.
менеджер проприетарных драйверов=jockey-kde

ps: длинные списки как-то смущают...

0
Flameflower - 24 Октябрь, 2011 - 13:17
Изображение пользователя Flameflower.

Если я aptitude дам "поработать", то он мне половину гнома притащит за собой.

0
DarkneSS - 24 Октябрь, 2011 - 19:21
Изображение пользователя DarkneSS.

Что-то про половину гнома я не понял. Активен "Драйвер ускоренной графики NVIDIA (версия current) [рекомендуемый]".

0
Flameflower - 25 Октябрь, 2011 - 05:42
Изображение пользователя Flameflower.
Развернуть/свернуть скрытый текст.
sudo aptitude -f install
Следующие НОВЫЕ пакеты будут установлены:       
  adium-theme-ubuntu apport-gtk{b} aptdaemon-data compiz{b} compizconfig-settings-manager{b} desktopcouch-ubuntuone{b} dmz-cursor-theme empathy-common
  evolution-data-server-common gedit-common gnome-codec-install{b} gnome-desktop-data gnome-desktop3-data gnome-icon-theme{b} gnome-icon-theme-symbolic
  gnome-session-canberra{b} gnome-terminal-data{b} gnome-user-guide{b} gnome-utils-common gwibber-service{b} gwibber-service-facebook gwibber-service-identica
  gwibber-service-twitter hwdata ibus-pinyin-db-android ibus-table{b} language-selector-gnome{b} launchpad-integration libappindicator0.1-cil{b}
  libdbus-glib1.0-cil libdbus1.0-cil libgconf2.0-cil libgdata-common libgdata1.7-cil libgkeyfile1.0-cil libgmime2.4-cil{b} libgnomekbd-common
  libgtk-sharp-beans-cil{b} libgtksourceview-3.0-common libgtop2-common libgudev1.0-cil libgweather-common{b} liblaunchpad-integration-common liblouis-data
  libmono-addins-gui0.2-cil{b} libmono-addins0.2-cil libmono-cairo4.0-cil libmono-csharp4.0-cil libmono-sharpzip4.84-cil libmono-system-core4.0-cil
  libmono-system-drawing4.0-cil{b} libmono-zeroconf1.0-cil libnm-gtk-common libnotify0.4-cil{b} libnux-1.0-common libpeas-common libpurple-bin
  libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-ru libreoffice-l10n-en-gb libreoffice-l10n-en-za libtaglib2.0-cil libubuntuone1.0-cil{b}
  libwebkitgtk-3.0-common libwnck-3-common libwnck-common libyaml-tiny-perl light-themes{b} media-player-info mythes-en-au notify-osd-icons oneconf{b}
  openoffice.org-common overlay-scrollbar{b} python-aptdaemon python-aptdaemon-gtk python-aptdaemon.gtk3widgets{b} python-aptdaemon.gtkwidgets{b}
  python-configglue python-couchdb{b} python-dateutil python-defer python-desktopcouch-application{b} python-desktopcouch-records{b} python-ibus{b}
  python-libproxy python-papyon{b} python-piston-mini-client python-pyatspi2{b} python-pyinotify python-serial python-speechd python-telepathy
  python-twisted-names{b} python-twisted-web{b} python-ubuntuone-control-panel{b} sessioninstaller{b} telepathy-butterfly thunderbird-locale-en{b}
  thunderbird-locale-en-gb thunderbird-locale-en-us thunderbird-locale-ru{b} totem-common transmission-common ubuntu-artwork ubuntu-docs{b} ubuntu-sounds
  ubuntu-wallpapers{b} ubuntuone-control-panel{b} ubuntuone-control-panel-gtk{b} ubuntuone-couch{b} ubuntuone-installer{b} unity-common{b} update-manager{b}
  usb-creator-gtk{b} xdiagnose{b} yelp-xsl zeitgeist-extension-fts zenity-common
0
DarkneSS - 25 Октябрь, 2011 - 07:38
Изображение пользователя DarkneSS.

Однако у меня аптитуд тоже ерундой по -f хочет заниматься, вбейте apt-get лучше.

0
Flameflower - 25 Октябрь, 2011 - 08:11
Изображение пользователя Flameflower.

C apt-get нормально всё.
Вообщем в чем проблема.
Загрузился с флешки на 11.04, поставил проприетарные дровишки, установил wine1.3 и пробую запустить игрушку. Всё работает, особых жалоб нет.
Тоже самое проделал 11.10.
Однако драйвера, при установке, THE DISTRIBUTION-PROVIDED PRE-INSTALL SCRIPT FAILED.
Если проигнорировать сие предупреждение то драйвера то вроде как устанавливаются, да вот только под wine'ом некоторые игрушки не работают.
Гугл мучал долго и упорно. Все сходилось в том, что из за multiarch'a и блобов нвидии не заводится vdpau от NVIDIA. Эксперимента ради попробовал проделать аналогичное на openSUSE - работает.
Вообщем то примерно вот так.
Проблема является несколько "критичной", т.к. "малой", для того что бы поиграться в игрушки запускает vmware и уже от туда "гонит дурку", хотя изначально виртуалки ставил для других целей.

0
DarkneSS - 25 Октябрь, 2011 - 09:54
Изображение пользователя DarkneSS.

Хм, у меня в плеере стоит вдпау, он не ругался после появления мультиарча... Вайн у меня amd64 стоит.

0
Flameflower - 30 Октябрь, 2011 - 11:10
Изображение пользователя Flameflower.

Проблему решил.
Не очень красивым способом, правда.
Вообщем то как всегда сработала поговорка:
"За что не люблю Linux так это за свои кривые руки."
Вполне возможно, что когда сидел еще на бете 11.10 и подключены сторонние PPA и еще несколько других репозиториев и из за этого наблюдались проблемы как с драйверами так и с другими пакетами в плане зависимостей.
В итоге сохранил необходимые конфиги, скачал релиз Kubuntu 11.10 AMD64 и вновь переустановил ОСь. Драйвера встали автоматически. Каких либо проблем не наблюдается.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры