Установка драйверов ATI вручную

Изображение пользователя AiNo07.

Привет всем!!! Не знаю как установить драйвер скачанный с оф сайта на ATI Radeon 9600? смотрел в подшивке но ничего не понял, я новичёк просто и мало чего понимаю. Пытаюсь ставить-пишет такую штуку:

sh ./ati-driver-installer-9-3-x86.x86_64.run --buildandinstallpkg Ubuntu/`lsb_release -c|awk '{print $2}'`
sh: Can't open ./ati-driver-installer-9-3-x86.x86_64.run

Комментарии (65)

0
DarkneSS - 28 Октябрь, 2011 - 11:01
Изображение пользователя DarkneSS.

Надо быть в папке с ati-driver-installer-9-3-x86.x86_64.run или дописать вместо ./ полный путь.

0
AiNo07 - 28 Октябрь, 2011 - 11:06
Изображение пользователя AiNo07.

Не хочет блин! А как будет выглядеть моя строчка полностью если драйвер в домашней папке?

0
DarkneSS - 28 Октябрь, 2011 - 12:17
Изображение пользователя DarkneSS.

Корень домашней папки? Тогда ~/ati-driver-installer-9-3-x86.x86_64.run

0
AiNo07 - 28 Октябрь, 2011 - 12:24
Изображение пользователя AiNo07.

Не хочет. Вот так пишет :(

sh ~/ati-driver-installer-9-3-x86.x86_64.run --buildandinstallpkg Ubuntu/`lsb_release -c|awk '{print $2}'`
sh: Can't open /root/ati-driver-installer-9-3-x86.x86_64.run

+2
Жюстина - 28 Октябрь, 2011 - 11:10
Изображение пользователя Жюстина.

На ати радеон 9600 уже давно вообще драйверы нельзя установить, видеокарта не поддерживаются.

Пользоваться открытыми! (они уже установлены)

0
AiNo07 - 28 Октябрь, 2011 - 11:33
Изображение пользователя AiNo07.

Те, что установлены не работают! Это одно название(всё виснет, тормозит и КДЕ не включишь).
Драйвер у меня есть, я только новичёк и не знаю как его поставить :(

0
DarkneSS - 28 Октябрь, 2011 - 12:18
Изображение пользователя DarkneSS.

Если Жюстина говорит, что фирменный драйвер на эту АТИшку поставить нельзя, я ей верю.
ЗЫ 2003й год! Конечно, поддержка в АТИ давно свёрнута. У вас не получится заставить его работать в современном дистрибутиве. Настройте лучше КДЕ на минимальные аппетиты.

0
wherecat - 28 Октябрь, 2011 - 12:45
Изображение пользователя wherecat.

Тыц
Попробуйте, что там написано про открытые драйверы.
На Радеоне 1950 работало, а он тоже не поддерживается уже.

0
AiNo07 - 28 Октябрь, 2011 - 15:06
Изображение пользователя AiNo07.

Открытый тормозной сильно и видюшка с ним сильно греется. Напишите лучше как всё должно выглядеть в терминале, при условиии, что драйвер в домашней папке, подпапка загрузки. А я попробую. По виду той ошибки которую он мне пишет-я не правильно указываю путь или имя. Файл называется - "ati-driver-installer-9-3-x86.x86_64.run"

0
Жюстина - 28 Октябрь, 2011 - 15:43
Изображение пользователя Жюстина.

sudo chmod +x ~/ati-driver-installer-9-3-x86.x86_64.run
sudo ~/ati-driver-installer-9-3-x86.x86_64.run

И всего делов, и всё это чтоб увидеть как драйверы скажут, что не найдено поддерживаемых устройств.

И открытый драйвер не тормозной, а даже шибко шустрый, это карточка ну очень уже тормозная.

0
AiNo07 - 28 Октябрь, 2011 - 17:00
Изображение пользователя AiNo07.

Да знаю, что тормозная:( да вот только, что мне с неправильным расположением картинки делать и плохой контрастностью, ведь всё это настраивалось с драйвером. Может можно как-то настроить контраст и цвета?

0
Жюстина - 28 Октябрь, 2011 - 17:56
Изображение пользователя Жюстина.

Всё описано тут.

man xrandr

Поэкспериментировать, а потом в автозагрузку нужную команду.

0
AiNo07 - 29 Октябрь, 2011 - 10:15
Изображение пользователя AiNo07.

Спасибо Жюстин! :) Но вот только, что со всем этим списком делать?

0
AiNo07 - 29 Октябрь, 2011 - 10:17
Изображение пользователя AiNo07.

Я не понимаю всех фокусов и не знаю мелочей, поэтому не понимаю. А всё потому, что я грёбаный новичок!

0
virus84 - 28 Октябрь, 2011 - 13:12

попробуйте как она (видеокарта) будет работать с openGL ES. В меня хоть и не такая видяха, но тоже атишная, с OGL ES работает шустрее

0
AiNo07 - 28 Октябрь, 2011 - 15:02
Изображение пользователя AiNo07.

А как это сделать?

+2
Жюстина - 28 Октябрь, 2011 - 15:38
Изображение пользователя Жюстина.

А-а-а-а, правильно, нужно всем узнать как OpenGL ES работает на видеокартах в десктопных компутерах, а то и разработчики наверняка даже не в курсе, они то это всё делали для современных видео встроенных, вроде как для андроидов да блэкберриев всяких, а в коммуникаторы с андроидами встроенные GPU раза в 2-3 мощнее чем радеончик9600 ))))

К тому ж OpenGL ES придумали на много позже чем вышла эта карточка, года на 3-4. Она работает только с OpenGL 2.1 и никак не больше того.

0
AiNo07 - 28 Октябрь, 2011 - 15:41
Изображение пользователя AiNo07.

Напишите лучше как всё должно выглядеть в терминале, при условиии, что драйвер в домашней папке, подпапка загрузки. А я попробую. По виду той ошибки которую он мне пишет-я не правильно указываю путь или имя. Файл называется - "ati-driver-installer-9-3-x86.x86_64.run"

0
Samath - 28 Октябрь, 2011 - 17:52

Да не встанет у тебя закрытый драйвер.
А на счет открытого:
1. они разные бывают. Но мне кажется из открытых лучше - ati
2. можно попробовать настроить по нормальному xorg.
У моего друга вроде такая же карточка, и вроде как у него все работает. Я если что смогу наверно у него стрельнуть конфиг /etc/X11/xorg.cоnf

0
AiNo07 - 29 Октябрь, 2011 - 10:20
Изображение пользователя AiNo07.

Если стрельнешь, то сможешь помочь с настройкой? Да и по ходу в системе у меня нет вообще никакого драйвера видеокарты, всё по умолчанию работает (криво) :(

0
Vlad_W_1999 - 29 Октябрь, 2011 - 11:13

Давай рассуждать логически? Если бы у тебя не было вообще никакого драйвера, то графическая подсистема смогла бы загрузиться? Полагаю, что нет. Стало быть, драйвер (какой-никакой) наличествует. Уже легче, правда? Пошли дальше. Чуть выше (например, здесь) тебе недвусмысленно сказали: драйвера для твоей видеокарточки бывают разные. И лучший из них (по уверению автора вышеозначенного комментария) это ati. Воспользовавшись Хрустальным Шаром ты сможешь узнать как об этих драйверах, так и о методах их установки (ну и о возможных проблемах).

Честно предупреждаю -- меня спрашивать о подробностях не надо, по той причине, что я являюсь счастливым обладателем nVidia и потому проблем с драйверами особо не имею.

0
AiNo07 - 29 Октябрь, 2011 - 11:31
Изображение пользователя AiNo07.

У меня тоже стояла Nvidia 6600? но сгорела день назад, а в магазине из б/у лучше ничего не было. Былаб Nvidia, взял бы Nvidia.

0
Vlad_W_1999 - 29 Октябрь, 2011 - 12:50

не страшно. Жустина уверяет, что жизнь под Radeon'om существует. :-) Потому спокойно почитай и сделай.

0
Zimak - 31 Октябрь, 2011 - 09:13
Изображение пользователя Zimak.

интересно, а какая разница? (Sapphire Radeon HD 5850)

+1
AiNo07 - 31 Октябрь, 2011 - 09:35
Изображение пользователя AiNo07.

С моей видеокартой у меня в этом окошке пусто.

+1
NikolayTrB - 31 Октябрь, 2011 - 10:17
Изображение пользователя NikolayTrB.

Потому что твоя видеокарта уже не поддерживается производителем. И дрова под нее теперь только свободные.

0
AiNo07 - 31 Октябрь, 2011 - 13:44
Изображение пользователя AiNo07.

Так, а как эти свободные дрова установить? Или как настроить? Работает всё криво и картинка не по центру(смещена вправо на 5мм), да и контраст не настроить. Лажа короче! :(

0
NikolayTrB - 31 Октябрь, 2011 - 15:18
Изображение пользователя NikolayTrB.

Они по идее уже должны стоять. Но на всякий случай, выполни в консоли:
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core xserver-xorg-video-radeon xserver-xorg-video-ati

0
AiNo07 - 2 Ноябрь, 2011 - 10:20
Изображение пользователя AiNo07.

Вот что вышло:

0
AiNo07 - 2 Ноябрь, 2011 - 10:36
Изображение пользователя AiNo07.

Всё тоже самое блин! Также криво после переустановки дров, как до неё. По прежнему ни каких опций по настройке изображения, даже элементарных и картинка не по центру(смещена вправо на 5мм) :(

+2
Жюстина - 2 Ноябрь, 2011 - 11:01
Изображение пользователя Жюстина.

Уже б давно кнопочку "Auto" на мониторе нажала. А мож даж и в меню монитора залезла...

0
AiNo07 - 2 Ноябрь, 2011 - 20:31
Изображение пользователя AiNo07.

На моём рабочем мониторе нет меню и кнопки такой тоже нет, а былоб, так не спрашивал...:)

0
trubadur4ik - 2 Ноябрь, 2011 - 20:36
Изображение пользователя trubadur4ik.

Даже на ЭЛТ мониторах года 1998 диагональю 14" были свои инструменты настройки, а вы говорите, рабочий...

Не верю! (Станиславский)

0
AiNo07 - 3 Ноябрь, 2011 - 15:17
Изображение пользователя AiNo07.

При ремонте этот элемент настройки был благополучно извлечон горе мастером. Я бы ему руки-то пообрывал, но поздно. :(

0
Zimak - 3 Ноябрь, 2011 - 19:31
Изображение пользователя Zimak.

вот это настоящее невезение

0
AiNo07 - 4 Ноябрь, 2011 - 14:49
Изображение пользователя AiNo07.

Ха-х! Разобрал сегодня его и всё сделал! :) У моника вдобавок ещё и меню было заблокировано-разблокировал и всё настроил, а модуль при сборке так там и остался, только был установлен "горе-мастером" кое как, вот кнопки и не функционировали;)

+3
Жюстина - 4 Ноябрь, 2011 - 17:19
Изображение пользователя Жюстина.

C этими ATI сплошные проблемы, аж монитор приходится ремонтировать )))))))))))))))))))))))))))))))))))))

0
AiNo07 - 6 Ноябрь, 2011 - 10:08
Изображение пользователя AiNo07.

Это точно Жюстин! Но сейчас ATIнет, есть только AMD. Я о том, что их карточки самые передовые, а вот раньше такое "г" были!

0
DarkneSS - 6 Ноябрь, 2011 - 11:08
Изображение пользователя DarkneSS.

Да как были карточками второго сорта, так и остались.

0
trubadur4ik - 6 Ноябрь, 2011 - 14:56
Изображение пользователя trubadur4ik.

Толсто. ;-)

0
Жюстина - 6 Ноябрь, 2011 - 18:03
Изображение пользователя Жюстина.

Второго сорта это интеловские.

0
SD - 6 Ноябрь, 2011 - 18:19

интеловским я бы никакого сорта не присвоил :)

0
Жюстина - 6 Ноябрь, 2011 - 18:03
Изображение пользователя Жюстина.

У мну 9200 была долгое время и ничего даже, всё прекрасно работало и почти шустренько, в пределах конечно своих.

Правда я тож с паранойей носилась и пыталась проприетарные драйверы поставить. Была даже мысль старый ксорг скомпилировать и потом поставить драйверы, но меня переубедили ))))

0
SD - 6 Ноябрь, 2011 - 18:28

проблема не с самими картами (железо), а с поддержкой этого железа в виде драйверов - вот тут как раз и загвоздка, т.к. нвидиа себя прилично ведёт, а амд (ати) - нет.
с нвидиа с момента их появления и рад этому.

0
Zimak - 6 Ноябрь, 2011 - 19:55
Изображение пользователя Zimak.

да всё нормально с ATI

0
Гость - 26 Январь, 2013 - 18:07

выполнив данную команду и зайдя в настройку разрешения комп "перепрыгнул" на правильное разрешение... спасибо))

0
AiNo07 - 6 Ноябрь, 2011 - 10:10
Изображение пользователя AiNo07.

Так, как мне с драйвером-то быть? Забивать я не привык совсем, да и выход мне кажется есть из любой ситуации, а забить это не выход?) Ведь так?!
Помоги пож., а то я совсем отчаялся с этим драйвером:(

0
dyug - 6 Ноябрь, 2011 - 10:30

Если ты все же собираешься поставить драйвер от марта 2009 года на систему октября 2011 года то я с пожалуй, понаблюдаю за ЭТИМ процессом..

Всегда интересовало, как функционирует альтернативная логика, количество использования которой все увеличивается....

0
DarkneSS - 6 Ноябрь, 2011 - 11:12
Изображение пользователя DarkneSS.

3 варианта:
новый линукс и открытые дрова;
старый линукс и фирменные дрова;
собирать генту со старыми иксами и ядром, фирменными дровами и относительно новым софтом.

0
Samath - 6 Ноябрь, 2011 - 16:04

AiNo07, покажите свой конфиг /etc/X11/xorg.conf

Хотя возможно он у Вас не существует. Если это так, то можно попробовать его создать.

Для начала добавьте этот репозиторий с последними дровами

Далее введите в терминале sdo apt-get update && sudo apt-get upgrade
После обновления перезагружаемся (возможно у Вас и так могут стоять последняя версия дров ati).
Если после обновления дров лучше не стало, то смотрим (создаем, настраиваем конфиг xorg.conf).

Создаем конфиг ксорга:
sudo Xorg -configure

Приводим /etc/X11/xorg.conf к такому виду

Перезагужаемся. Смотрим.

P.S. Если я тут что-то не то советую, то поправьте меня.

0
dyug - 6 Ноябрь, 2011 - 17:25

я обычно, перед советом, читаю весь тред. для ТС последняя версия протеитарных дров 9.3 от марта 2009 года, больше не выпускалось.
"Не знаю как установить драйвер скачанный с оф сайта на ATI Radeon 9600"
О каких "последних дровах" может идти речь?
предлагаю проделать следующее в гугле набрать "ati radeon 9600 driver linux" и перейти по первой же ссылке.
На этой ссылке выбрать необходимые параметры, и убедиться, что АМД/АТИ забила болт на все (по ее мнению) "устаревшие адаптеры" в марте 2009 года.
вот ссылка
После чего попробовать перевести эту фразу "The Linux ATI Catalyst™ driver will only be supported in Linux distributions prior to February 2009 for the legacy products listed above." и подумать, почему этот продукт НЕ станет в кубунте 11.10

+1
Жюстина - 6 Ноябрь, 2011 - 17:56
Изображение пользователя Жюстина.

Комментарий был про установку последних версий открытого драйвера, а не фирменного )))

0
dyug - 6 Ноябрь, 2011 - 18:11

гмм, и какого органа тогда создавать то, что уже релиза два не используется?
да и в системе стоит xserver-xorg-video-ati_6.14.99~git20110811.g93fc084-0ubuntu1_i386.deb
А с учетом всех изменений (да, я поглядел в ченжлог)... не вижу я смысла...
Даже для 6.15 не вижу.

Но это так, поговорить... :-)

0
Жюстина - 6 Ноябрь, 2011 - 18:20
Изображение пользователя Жюстина.

Файлик /etc/X11/xorg.conf используется и активно даже, но не на открытых драйверах в основном.

тож скучно ))))

0
Samath - 6 Ноябрь, 2011 - 19:13

гмм, и какого органа тогда создавать то, что уже релиза два не используется?

Ну просто, когда у меня были проблемы с ати/амд, тоже не было файла xorg.conf. Тогда я создал файл xorg.conf и отредактировал так как мне надо. И это мне помогло.

P.S. Я просто хочу помочь ТС и считаю, что ставить старый дистр с закрытыми дровами не вариант.

0
AiNo07 - 7 Ноябрь, 2011 - 11:41
Изображение пользователя AiNo07.

Так бли! Понаписали-то! Чёрт ногу сломит! Чего мне делать-то, совсем запутали:(

0
misterleks - 5 Июнь, 2012 - 14:39

Подскажите, есть смысл обновлять драйвер видео карты:
Карта: ATI Radeon® Xpress 1150 256MB HyperMemoryTM (integrated)12
ОС: Kubuntu 12.04 LTS Precise Pangolin Release

И если есть смысл, то обновиться через репозиторий или с официального сайта? Я скачал драйвер ati-driver-installer-9-3-x86.x86_64.run, но там написано, что это релиз 2009 года, вот и думаю, может все это уже есть в ядре ...

0
dyug - 5 Июнь, 2012 - 14:42

Нет. после установки можно получить неработающий линух (без графики)

0
misterleks - 5 Июнь, 2012 - 14:46

Это такая старая карточка? Можно узнать почему?

0
dyug - 5 Июнь, 2012 - 14:52

Да, это неподдерживаемая АТИ карточка, точно такая же как и моя на ноуте.. Х1250 :-(

0
Гость - 29 Июль, 2012 - 11:42

И моя X1300 на ноуте тоже в пролёте... Всё бы ничего, но шестерникрутятся всего на 60 кадров за 5 секунд... А это ОЧЕНЬ мало... X700 на проприетаных дровах выдаёт 14000 кадров за 5 сек...

0
Platon - 29 Июль, 2012 - 15:59
Изображение пользователя Platon.

Являюсь обладателем карточки X1250 и нашел таки способ оживить графические эффекты на моей старушке.
Начнем с перечня карточек которые более не поддерживается проприетарными драйверами AMD:

Теперь рецепт как лечить(все через консоль)
0
dyug - 29 Июль, 2012 - 16:27

Гмм, ну как на мой взгляд - текст внятный и логичный - может и помочь.

Впрочем, не мне
[email protected]:~# lsmod |grep radeon
radeon                737789  3
ttm                    65344  1 radeon
drm_kms_helper         45466  1 radeon
drm                   197692  5 radeon,ttm,drm_kms_helper
i2c_algo_bit           13199  1 radeon

У меня, как видно он грузится сам, без дополнительных действий с моей стороны.
Что подтверждает:
cat /etc/modprobe.preload
cat: /etc/modprobe.preload: Нет такого файла или каталога

и
cat /etc/modprobe.conf
cat: /etc/modprobe.conf: Нет такого файла или каталога

Ну и в качестве подтверждения:
lspci |grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Radeon Xpress 1250

0
Platon - 29 Июль, 2012 - 20:24
Изображение пользователя Platon.

вероятно, файлы кнфигурации создаются в результате выполнения приведенной в рецепте команд (ЕМНИП echo - передает значение)
Для сравнения у меня:
~$ lsmod |grep radeon
radeon                737789  3
ttm                    65344  1 radeon
drm_kms_helper         45466  1 radeon
drm                   197692  5 radeon,ttm,drm_kms_helper
i2c_algo_bit           13199  1 radeon
# совпадает
~$ cat /etc/modprobe.preload
radeon
~$ cat /etc/modprobe.conf
options radeon modeset=1
# файлы существуют
~$ lspci |grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Radeon Xpress 1250
# совпадает

0
Гость - 9 Октябрь, 2012 - 18:39

http://vasilisc.com/ati_driver_ubuntu
мне помогло на 6370м

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры