Кривая установка программ

Здравствуйте. Установил kubuntu 11.10 только не давно...вообщем доволен, только вот у меня какая-то хрень с установкой программ. Качаю тот же Trix дэб пакет с оф-сайта, устанавливаю, все без сбоев, пишет "Завершено". Но он не появляется не в Меню и вообще нигде...нашел только системный файл аж глубоко в системных папках, и то когда запускаю то нет никаких "иконок" иллюстрации и т.д...вообщем криво установлен. Такая же фигня и со Скайпом...Подскажите в чем проблема. Спасибо!

0
DarkneSS - 23 Ноябрь, 2011 - 14:37
Изображение пользователя DarkneSS.

1) Устанавливаете gdebi
2) Запускаете в терминале gdebi /путь/пакет.deb(показываете вывод нам)
3) Запускаете в терминале моя_крутая_программа(показываете нам)
Опять же скриншоты не помешают. Всё большое помещаем под кат (кнопка CL).

0
SuPCh1k - 23 Ноябрь, 2011 - 16:32

:~$ gdebi /home/supch1k/Загрузки/trix_0.94-1_i386.deb
Программа 'gdebi' на данный момент не установлена.

0
Mike - 23 Ноябрь, 2011 - 16:41
Изображение пользователя Mike.

зачем гдеби?? dpkg - это уже не по пацански чтоле?

0
SuPCh1k - 23 Ноябрь, 2011 - 16:46

ну так оно вроде ведь по умолчанию через dpkg устанавливает...и как видишь у меня ничего хорошего не получается

0
Mike - 23 Ноябрь, 2011 - 17:16
Изображение пользователя Mike.

я не знаю, чем, откуда и как ты ставил пакет. За последние 6 лет, что я имел дело с dpkg, у меня ни разу ничего не перекашивало. И вот тут то возникает закономерный вопрос: ЧЯДНТ?

0
SuPCh1k - 23 Ноябрь, 2011 - 17:23

та даже если обычным двойным кликом устанавливать..дэб

0
useless_dream - 23 Ноябрь, 2011 - 18:18
Изображение пользователя useless_dream.

зачем так удивляться=)

0
DarkneSS - 23 Ноябрь, 2011 - 19:16
Изображение пользователя DarkneSS.

dpkg не разруливает зависимости. Теперь я уверен, что ТС именно dpkg дел и натворил.

0
Mike - 23 Ноябрь, 2011 - 20:26
Изображение пользователя Mike.

какэта?? dpkg при неудовлетворенных зависимостях прям так и требует... чтобы удовлетворили... прямым текстом

0
DarkneSS - 24 Ноябрь, 2011 - 00:43
Изображение пользователя DarkneSS.

Требовать - это хорошо. Но форс никто не отменял.
Опять же недавно над иксами издевался. Дпкг поставил нужные пакеты без форса и ругани, а апт просто в шоке от того, что вышло))

+1
Mike - 24 Ноябрь, 2011 - 08:20
Изображение пользователя Mike.

если юзер бездумно делает форс, значит он сам себе злое [censored]буратино, и это правильно, что после этого он подвергся анальным карам. Дабы в последствии такого не делать.
UPD какой хитрый антимат о__О
а ведь там ни слова про [censored] не было

0
DarkneSS - 24 Ноябрь, 2011 - 12:54
Изображение пользователя DarkneSS.

На зависимости ему кстати пофиг. Ругается только, если не может настроить пакет (без какого-то другого).

0
useless_dream - 23 Ноябрь, 2011 - 15:02
Изображение пользователя useless_dream.

просто
sudo apt-get remove qapt
sudo apt-get install gdebi-kde
и потом уже кликаете на свои деб пакеты

0
SuPCh1k - 23 Ноябрь, 2011 - 16:18

сейчас буду пробовать...но перед тем наверное надо удалить ту хрень что оно поустанавливало...а как это сделать??...в менеджере пакетов их нету

0
useless_dream - 23 Ноябрь, 2011 - 18:21
Изображение пользователя useless_dream.

какую кто

0
DarkneSS - 23 Ноябрь, 2011 - 19:17
Изображение пользователя DarkneSS.

Сделайте sudo apt-get install -fПотом, ставьте гдеби и вперёд.

0
SuPCh1k - 24 Ноябрь, 2011 - 11:53

установил при помощи sudo apt-get install gdebi-core потом поставил Trix
sudo gdebi /home/supch1k/Загрузки/trix_0.94-1_i386.deb...ну теперь вроде сам чат норм работает и иллюстрация есть, но все равно сам файл "exe" вообщем запуска я нахожу аж /usr/local/bin...в меню он сам не добавляется...ну я знаю как в ручную..но все равно я не считаю это правильным...или этот файл должен быть там?
а еще мне советуют забить и перейти на lubuntu, не слушать же?...Спасибо..=))

0
viktus - 24 Ноябрь, 2011 - 11:59
Изображение пользователя viktus.

если проблема только с установщиком .deb, то точно не слушать... lubuntu уж слишком ущербной после kubuntu смотрится...
у меня тоже проблема с установкой пакетов .deb была, установил через менеджер программ Muon Gdebi-kde и сделал, что бы deb по умолчанию открывались данной программой - и никаких проблем...
для себя выбрал Kubuntu, как лучший дистр на сегодняшний день из семейства *ubuntu

0
SuPCh1k - 24 Ноябрь, 2011 - 12:14

кстати Скайп установился норм через gdebi и в меню сам залепился...
та пока что только с дэб ну и с норм установкой вайна и виндовс прог разобраться не могу...но тут уже скорее всего дело не в ос, а в руках))...а muon Gdebi-kde нужно отдельно ставить?...есть в репозе или дашь ссылку на дэб?

0
viktus - 24 Ноябрь, 2011 - 12:37
Изображение пользователя viktus.

да нет) Muon - менеджер установки программ стандартный, а через него уже ставил Gdebi-kde

0
8givchik8 - 24 Ноябрь, 2011 - 12:40

Мне всегда помогало sudo dpkg -i ваш_пакет.deb. Это если графика сбоит, а чтоб dpkg сбоило не видел. Хотя всякое может быть, но пользоваться Gdebi так и не довелось.)

0
SuPCh1k - 24 Ноябрь, 2011 - 12:43

а разница-то в том через что устанавливать?

0
DarkneSS - 24 Ноябрь, 2011 - 12:53
Изображение пользователя DarkneSS.

Разница в том, что гдеби скачает и поставит зависимости.

0
SuPCh1k - 24 Ноябрь, 2011 - 13:03

имхо..ну так лучше уже так устанавливать сразу с гдеби с зависимостями...

0
8givchik8 - 24 Ноябрь, 2011 - 13:43

Ранее при использовании этой утилиты проблем с зависимостями не возникало - skype (не люблю эту прогу, но к сожалению реклама влиятельный инструмент и много родственников сидят на ней) и ему подобные без зависимостей не станут. А бывало такое что Muon глючил и ставил такие пакеты именно через dpkg - все ок!)

0
8givchik8 - 4 Декабрь, 2011 - 12:09

Хотя aptitude со счетов снимать не нужно!)

0
SuPCh1k - 24 Ноябрь, 2011 - 15:15

кстати на счет вайна...не у кого не было проблем с установкой gecko 110 и 120...

"ОК"

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры