Проблема с X server

При установке ос Кубунта ставит дрова nvidia (current) и бинарники ати. В параметрах системы -> Экран почему-то частота 0 гц и слишком высокое расширение по дефалту. Настройки не сохраняются (при входе в систему обратно дефалт). NVIDIA X Server Settings на конфиг матерится: "Unable to load X Server Display Configuration page: Failed to query NoScanout for screen 0".
Если удалить nvidia (current), то в настройках вместо NVIDIA X Server Settings ати катализатор (не запускается) а файл xorg.conf пустой Если снести бинарники ати то ос рухнет и даже не забутится. Но монитор почему-то нормально работает (частота и расширение и сохраняет настройки).
Чтобы поиграть в гамы вайну надо дрова видюхи. Если поставлю рекомендуемые дрова нвидиа верс 173, кубунта обратно возмется за своё только вместо нуля будет 56,8 гц.
Помогите пожалуйста.

Конфигурация:
gigabyte ga 8i865gme-775
intel celeron 2.8 ghz
1.5 gb ddr ram
nvidia geforce fx 5200 128 mb
Kubuntu 11.10

ps

На убунте 11,04 почему-то таких проблем небыло

0
DarkneSS - 5 Январь, 2012 - 01:01
Изображение пользователя DarkneSS.

Поставить дрова нвидиа. Выполнить sudo nvidia-xconfigИксорг.конф появится.

0
rebel09 - 5 Январь, 2012 - 07:47

нвидиа сейчас не стоит, только бинарники ати.
если поставлю дрова нвидиа, sudo nvidia-xconfig иксорг не будет ему пустым, но это ему не поможет:
кубунта обратно возмется за своё только вместо нуля будет 56,8 гц.
и
Unable to load X Server Display Configuration page: Failed to query NoScanout for screen 0

0
DarkneSS - 5 Январь, 2012 - 12:42
Изображение пользователя DarkneSS.

Я ничего не понял. Какая у вас карточка, ставьте такие дрова. Как сделать иксорг для нвидиа, я написал. Про ати не знаю.

0
rebel09 - 5 Январь, 2012 - 20:51

Карточка у меня nvidia geforce fx 5200. Если я поставлю её дрова. NVIDIA X Server Settings выдает Unable to load X Server Display Configuration page: Failed to query NoScanout for screen 0 Никак немогу настроить частоту и расширение. В параметры системы -> Экран меняется только расширение, и то оно постоянно сбрасывается на дефалт.
"sudo nvidia-xconfig" ничего не меняет

0
SmartByte - 5 Январь, 2012 - 21:27
Изображение пользователя SmartByte.

Значит надо править xorg.conf ручками. В инете полно мануалов. Да-да, а что ты хотел, это линукс))
Не знаю какой сейчас правильный способ, но раньше делал так:
1) Идём в NVIDIA X Server Settings и выставляем там нормальное разрешение и частоту, применяем (Apply)
2) Жмём Save to X Configuration File, в открывшемся окне нажимаем Show preview, выдеяем и копируем весь открывшийся текст.
3) Открываем из под рута xorg.conf (например, в консоли через нано: sudo nano /etc/X11/xorg.conf), стираем всё что есть, и вставляем наш скопированный конфиг
4) Сохраняем (в nano: Ctrl+o, Enter), перезагружаемся.

0
DarkneSS - 5 Январь, 2012 - 21:23
Изображение пользователя DarkneSS.

Да не надо в настройках кде ничего трогать. Есть nvidia settings.

0
rebel09 - 6 Январь, 2012 - 21:41

Не работает nvidia settings.

0
DarkneSS - 7 Январь, 2012 - 11:18
Изображение пользователя DarkneSS.

Поясните.

0
tumim - 7 Январь, 2012 - 14:33

у меня та же проблема, Не сохраняются настройки Nvidia в Ubuntu делал следующее:
запустил

sudo nvidia-settings

сделал настройки, сохранился. Но все равно, при перезагрузке все слетает. смотрю файл xorg.conf
в файле настройки сохранились. Что делать? Правил потом все ручками, но все равно при перезагрузке не сохраняется.

0
DarkneSS - 7 Январь, 2012 - 15:48
Изображение пользователя DarkneSS.

Не понимаю, как может игнорироваться /etc/X11/xorg.conf

0
tumim - 7 Январь, 2012 - 16:15

я сам в шоке, уже три дня пытаюсь решить проблему

0
rebel09 - 7 Январь, 2012 - 16:38

У меня в убунту 11.04 все работало ок. А как перешёл на кубунту 11.10, тогда началось

0
itrch - 10 Январь, 2012 - 10:27
Изображение пользователя itrch.

надо вроде nouveau удалить сначала. также нифига не работало, пока не удалил.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры