Обновление ядра до версии 3.2 в Ubuntu 11.10 и Linux Mint 12

Изображение пользователя serega_yaskovich.

Обновление ядра до версии 3.2 в Ubuntu 11.10 и Linux Mint 12
Оригинал: How to upgrade to Kernel 3.2 in Ubuntu11.10 and LinuxMint12|PPA
Автор: pirat9
Дата публикации: 11 января 2012 года
Перевод: А. Кривошей
Дата перевода: 12 января 2012 г.

Несколько дней назад вышел официальный релиз ядра Linux 3.2. Он включает поддержку для блоков размером до 1 Мб в файловой системе ext4, что увеличивает производительность при работе с большими файлами; btrfs теперь поддерживает автоматическое резервное копирование критических системных метаданных, кроме того она получила инструменты для ручной проверки файловой системы. В планировщик процессов добавлена возможность задания верхних лимитов на выделяемое процессорное время. Улучшена отзывчивость рабочего стола во время сильной загрузки системы. Также обновлен TCP, который получил алгоритм, ускоряющий восстановление соединения после потери пакетов. Добавлена поддержка новой архитертуры - сигнального процессора Hexagon от Qualcomm. Кроме того, как всегда, исправлено множество мелких ошибок и добавлены новые драйверы устройств.
Если вы хотите узнать больше о новом ядре, почитайте release notes. Группа Ubuntu уже подготовила прекомпилированную версию нового ядра, чтобы упростить его установку для новичков.
Внимание: сделайте резервную копию данных, прежде чем продолжить. Все нижеописанные операции вы выполняете на свой страх и риск. Мы проверяли новое ядро на одном из наших тестовых серверов (система Peas OS на базе Ubuntu). Устанавливал на "старое" железо, на видео GeForce 8600 иксы не запустились (пока)

1. Установка Kernel 3.2 в Ubuntu 11.10 и Mint 12 из PPA:

Откройте терминал и введите следующие команды:
$ sudo apt-add-repository ppa:francisbrwn9/kernels
$ sudo apt-get update
$ sudo apt-get dist-upgrade

Если вы хотите откатиться на предыдущую версию ядра, необходимо установить PPA Purge с помощью команды:
$ sudo apt-get install ppa-purge
Затем удалите PPA с помощью команды:
$ sudo apt-get install ppa-purge

2. Установка из Debian-пакета

Для установки нового ядра Linux kernel 3.2 в Ubuntu или Mint из Debian-пакета необходимо выполнить следующие действия:
Для 32-битного дистрибутива Ubuntu/Mint
Откройте терминал и введите следующие команды:
$ cd mkdir kernel && cd kernel
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200_3.2.0-030200.201201042035_all.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200-generic_3.2.0-030200.201201042035_i386.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-image-3.2.0-030200-generic-pae_3.2.0-030200.201201042035_i386.deb
$ sudo dpkg -i *.deb

Для 64-битного дистрибутива Ubuntu/Mint
Откройте терминал и введите следующие команды:
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200_3.2.0-030200.201201042035_all.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-headers-3.2.0-030200-generic_3.2.0-030200.201201042035_amd64.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/linux-image-3.2.0-030200-generic_3.2.0-030200.201201042035_amd64.deb

Теперь перезагрузите компьютер и наслаждайтесь.
pirat9@Unixmen:~$ uname -a Linux Unixmen 3.2.0-030200-generic #201201042035 SMP Thu Jan 5 01:36:31 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux pirat9@Unixmen:~$

Комментарии (33)

0
DarkneSS - 13 Январь, 2012 - 12:17
Изображение пользователя DarkneSS.

Кстати да, блобы на видео не обязаны становиться на свежее ядро.

0
Flameflower - 16 Январь, 2012 - 06:28
Изображение пользователя Flameflower.

Таки если уж обновлять ядро то лучше его собирать самому.
Делается весьма не сложно.
p.s. На 3.1 блоб nvidia "работает".

0
Гость - 29 Январь, 2012 - 14:32

обновился как написано, работает нормально, гефорсе 8800

0
voicah - 5 Февраль, 2012 - 23:36
Изображение пользователя voicah.

Обновился, все работет нормально.AMD Athlon(tm)||X2 250 Processor, ATI Radeon HD 5770

0
Susumo - 6 Февраль, 2012 - 09:36
Изображение пользователя Susumo.

Команды на установку "ppa purge" и удаление ppa одинаковые.

-1
SUDAKDVAER - 6 Февраль, 2012 - 13:09
Изображение пользователя SUDAKDVAER.

Только что обновился. Почти двух кратное увеличение скорости работы приятно удивило)))

0
trubadur4ik - 6 Февраль, 2012 - 17:32
Изображение пользователя trubadur4ik.

Опа-на! Как считал? Теперь картинка открывается не 0,005, а 0,0028 мс.?

0
Гость - 6 Февраль, 2012 - 18:46

Susumo правильно заметил(а) насчет одинаковых команд , но в оригинале они разные.

0
sotas - 8 Февраль, 2012 - 12:18
Изображение пользователя sotas.

Обновился ноут
Dell Inspiron N5110
Intel Core i5 2400 МГц Sandy Bridge (2430M)
6144 Мб DDR3-1066МГц
nVidia GeForce GT 525M
Дистрибутив Kubuntu 11.10 x64

Мои попугаи :)
У меня по сравнению с предыдущим ядром количество попугаев добавилось :)
на glxgears +29
на optirun glxgears +396
на glxspheres +22
на optirun glxgears +15
Да юзаю Bumblebee так как Nvidia Optimus
Жаль не сделал замеры перед обновлением было бы нагляднее :)
В общем система на мой взгляд стала поотзывчивей :)
Мну пока доволен :)
А как У Вас :)?
0
DarkneSS - 8 Февраль, 2012 - 12:23
Изображение пользователя DarkneSS.

Running synchronized to the vertical refresh.Никакого ускорения видно не будет. Выше частоты монитора не прыгнет.

0
sotas - 8 Февраль, 2012 - 13:05
Изображение пользователя sotas.

DarkneSS поэтому и два теста один из них как вы правильно заметили вертикалка, более точную информацию дает glxspheres из комплекта VirtualGL, поэтому и попугаи разные. Но самое главное что прирос есть :) А по поводу чистоты монитора у всех девайсов есть свой потолок:) При подключении к телеку посредством HDMI Видео 1024 у меня пошло лучше :)

0
SUDAKDVAER - 13 Февраль, 2012 - 20:30
Изображение пользователя SUDAKDVAER.

Первые три дня было всё нормально... Но сегодня система при включении (после перезагруза) висла намертво раз пять. Подскажите неофиту,господа опытные, как откатится на прежнее ядро? Или переустанавливать придётся?

0
DarkneSS - 13 Февраль, 2012 - 21:02
Изображение пользователя DarkneSS.

Вы старое удаляли? По умолчанию ядра накапливаются =)

0
Гость - 14 Февраль, 2012 - 11:57

Честно говоря, даже не подумал об этом по неопытности))) Ставил новое по инструкции из этой темы, но по вышеизложенной причине вчера вечером откатился на старое по инструкци, найденной через Яндекс... Перезагрузился... Глюки и тормоза исчезли... Я так понимаю,новое ядро будет по умолчанию в Kubuntu 12.04 и когда я буду обновляться с 11.10 старое удалится и встанет новое? Нет?

0
DarkneSS - 14 Февраль, 2012 - 12:00
Изображение пользователя DarkneSS.

Насколько я помню, старые ядра не удаляются сами по себе.

0
SUDAKDVAER - 14 Февраль, 2012 - 14:09
Изображение пользователя SUDAKDVAER.

Тогда как удалить старое ядро перед установкой нового?

+1
knuckles - 14 Февраль, 2012 - 14:21
Изображение пользователя knuckles.

Не надо удалять старые ядра! А перед установкой нового их тем более не надо удалять!!!

0
DarkneSS - 14 Февраль, 2012 - 17:23
Изображение пользователя DarkneSS.

Перед установкой нового точно удалять не стоит. Ищите пакеты с linux и удаляйте те версии, которые вам не нравятся.

0
Poker - 31 Март, 2012 - 22:08

После перезагрузки синий экран и все. GeForce 9600GT 1Gb. Хорошо старое ядро сохранилось. При установке нового ядра были вот такие строчки:
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169

0
Cyber_M - 1 Апрель, 2012 - 01:16
Изображение пользователя Cyber_M.

Рискнул обновился в командировке, Aser Aspier 5820tg проблем нет как и не было (ATI Moblity Radeon HD 5650). Все работает и это хорошо...

0
Erik1794 - 19 Ноябрь, 2012 - 21:12

Если я правильно понял, то таким же образом можно обновить и более свежие версии ядра (v3.6.7).
Подскажите пожалуйста в способе "Установка из Debian-пакета", после ввода в терминале "cd mkdir kernel && cd kernel", выдаёт такую ошибку:

Что я делаю не так? Заранее спс. PS: Если гуру Mike раздражает вопрос, просьба воздержаться от коментариев. Я сам знаю что нуб :)
0
Mike - 19 Ноябрь, 2012 - 21:14
Изображение пользователя Mike.

=)))
Тут надо определиться, что нужно: cd или все же mkdir =)
что-то мне подсказывает, что команда все же должна выглядеть так:
mkdir kernel && cd kernel
Просто это у топикстартера в сообщении ошибка.

0
dyug - 19 Ноябрь, 2012 - 21:16

mkdir kernel && cd kernel
оно вот так должно выглядеть.
там лишний cd в начале.

p.s. ты еще меня не сильно раздражал. :-) или я этого не помню.. :-)

0
Erik1794 - 19 Ноябрь, 2012 - 21:24

Сегодня:
думаю, перенести следует в мусорную корзину. Дабы не плодить дублей на форуме.Ответ. Хе-Хе. Я знал что Вы хороший человек :). Можете сказать какие + и - этого способа по сравнению с пересборкой описанной в ссылка

0
DarkneSS - 19 Ноябрь, 2012 - 21:53
Изображение пользователя DarkneSS.

Если вы не вносите никаких дополнительных патчей, лучше и проще качать готовые дебы ядер.

0
Erik1794 - 19 Ноябрь, 2012 - 23:38

Обновил ядро с готовых deb. и ... беда! Отвалилась мышка с клавой, и в режиме восстановления не могу выбрать командную строку установить Nvidia. Как поступить и что подправить? Загрузился со старого ядра. Посоветуйте пожалуйста.

0
DarkneSS - 20 Ноябрь, 2012 - 00:25
Изображение пользователя DarkneSS.

Честно говоря, такого у меня не бывало. Блоб не вставал, бывало, а чтобы клавомышка отвалилась… Попробуйте установить другую версию для начала.

0
Erik1794 - 20 Ноябрь, 2012 - 00:54

Чую в другом месте рыть нужно. Nouveau заблокирован, ставил дрова Nvidia вручную с сайта - думаю здесь собака порылась. Нужно как то из Grub попасть в командную строку и переустановить драйвер Nvidia. В Grub всё работает прекрасно.

0
DarkneSS - 20 Ноябрь, 2012 - 07:48
Изображение пользователя DarkneSS.

Груб же без ядра работает :)

0
Erik1794 - 22 Ноябрь, 2012 - 14:14

К действиям ТС добавил:

И всё работает прекрастно
0
Erik1794 - 21 Ноябрь, 2012 - 21:42

Подскажите пожалуйста, установки пакетов перечисленных TC хватит или необходимо ещё установить: linux-image-extra-3.6.6-030606-generic_3.6.6-030606.201211050512_amd64.deb для системы 86_64 , т.к у меня присутствует данный пакет (linux-image-extra) ранних версий в установленных.

"ii"-это установленные, а "i" и "rc"? linux-image-3.6.7-030607 я удалил, т.к не работали USB порты (не работали мышь с клавой и Wi-Fi свисток)
Заранее спасибо.
0
DarkneSS - 21 Ноябрь, 2012 - 21:50
Изображение пользователя DarkneSS.

Нужны linux-headers соответствующих версий для сборки проприетарных драйверов. В остальном linux-image разных версий вполне самодостаточны.

0
Erik1794 - 22 Ноябрь, 2012 - 13:59

Вопрос снят (решено)!

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры