Defender G-lens 321 vs Kubuntu 11.10 x64

Изображение пользователя Hellblazer.

Доброго времени суток.
Собственно суть вопроса в том что имеется камера Defender G-lens 321 (со встроенным микрофонам) и нигде не работает ни камера ни микрофон.
Помогите советом.
P.S:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
и
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype
безрезультатно.

0
Vlad_W_1999 - 10 Февраль, 2012 - 14:11

Можно вот так с порога поинтересоваться? А покажи ка, мил человек, вывод команды lsusb! Это в консоли набрать, получить какой-то "выхлоп" и заслать его сюда. Таким образом мы увидим, а система вообще как-то реагирует на твою камеру, или нет. Дальше будем посмотреть.

0
Гость - 10 Февраль, 2012 - 14:20

судя по всему нет

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 1532:0002 Razer USA, Ltd
Bus 001 Device 007: ID 093a:2620 Pixart Imaging, Inc.
Bus 001 Device 005: ID 125f:385a A-DATA Technology Co., Ltd.
Bus 001 Device 008: ID 09da:0260 A4 Tech Co., Ltd

хотя скайп камеру видит

0
Hellblazer - 10 Февраль, 2012 - 14:32
Изображение пользователя Hellblazer.

не заметил что сессия кончилась, не мог понять почему сообщение не отправляется =))

0
Hellblazer - 10 Февраль, 2012 - 14:23
Изображение пользователя Hellblazer.

да видит под номером 007

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 1532:0002 Razer USA, Ltd
Bus 001 Device 007: ID 093a:2620 Pixart Imaging, Inc.
Bus 001 Device 005: ID 125f:385a A-DATA Technology Co., Ltd.
Bus 001 Device 008: ID 09da:0260 A4 Tech Co., Ltd

0
Vlad_W_1999 - 10 Февраль, 2012 - 14:51

Чудненько и славненько! Теперь небольшое уточнение: скайп видит камеру? А где ещё хочется, чтобы камера была видна? Потому как сдаётся мне, что она у тебя вполне работает. Если проблемы с микрофоном, то где-то здесь на форуме мелькала как раз схожая тема.

И чисто из спортивного интереса (прошу прощения за назойливость): а что за устройство Razer USA, Ltd?

0
rlepish - 10 Февраль, 2012 - 14:58

Razer Diamondback Optical Mouse

0
Hellblazer - 10 Февраль, 2012 - 15:16
Изображение пользователя Hellblazer.

Видеть то он её видит, да вот только не показывает она ничего, скриншот я выше выложил, в основном камера нужна в скайпе, ну можно ещё чтобы Chrome увидел, но это не так критично. Микрофон тоже не работает, пульс ковырял, алсу тоже пробовал тыкать, ничего не помогает. =((
как правильно подметил rlepish
Razer USA, Ltd = Razer Diamondback Optical Mouse

0
Vlad_W_1999 - 10 Февраль, 2012 - 15:52

Ага. Значит, скайп её не видит. Он вроде как знает, что в системе что-то есть, но не реагирует. Очень хорошо! А что говорит Хрустальный Шар на эту тему? Может стоило задать вопрос? Мне, например, приглянулся вот этот ответ с дружественного форума.

Я за тебя должен поиском заниматься? Так у меня камера работает! Может взвалить на тебя решение проблемы стыковки моего упса с кубунтой? Уже не первую неделю долбаюсь. Хочешь за меня этим заняться? Сам приучайся к использованию поиска!

P.S.: Если по совету от коллег заведётся -- отпишись.

0
Hellblazer - 10 Февраль, 2012 - 16:16
Изображение пользователя Hellblazer.

Если бы Вы внимательно прочитали мой первый пост, то увидели бы что я написал:
P.S:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
и
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype
безрезультатно.
это именно то что предлагают в найденной Вами теме, и в десятках других кстати, за три дня я их много перечитал.

0
SD - 10 Февраль, 2012 - 16:31

а что показывают:
hwinfo | grep 093a:2620
hwinfo | grep Pixart

0
Hellblazer - 10 Февраль, 2012 - 17:14
Изображение пользователя Hellblazer.

[email protected]:~$ hwinfo | grep 093a:2620
process 6603: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
  E: ID_V4L_PRODUCT=USB Camera (093a:2620)

[email protected]:~$ hwinfo | grep Pixart
process 6661: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
  E: ID_VENDOR_FROM_DATABASE=Pixart Imaging, Inc.
  Model: "Pixart Imaging Unclassified device"
  Vendor: usb 0x093a "Pixart Imaging, Inc."

0
SD - 10 Февраль, 2012 - 18:43

тишина

0
Vlad_W_1999 - 10 Февраль, 2012 - 16:40

Где "выхлоп" по первой команде? А по второй? В приведённой ссылке путь к v4l1compat.so отличается от того, что у тебя. С этим разбирался?

0
Hellblazer - 10 Февраль, 2012 - 17:18
Изображение пользователя Hellblazer.

[email protected]:~$ LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype
libv4l2: error turning on stream: Ошибка ввода/вывода

[email protected]:~$ LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype
libv4l2: error turning on stream: Ошибка ввода/вывода

0
SD - 10 Февраль, 2012 - 19:53

а так? установив libv4l-0:i386
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype
если не поможет, то погуглите (где-то наталкивался) драйвер gspca

0
Гость - 6 Март, 2012 - 14:47

Есть подобная проблема, скайп не видит и не слышить, а вот все остальные программы убунтовские видят, но при этом аудио захвата не происходит... Странно, уже разное пробовали, ничего не помогает(((

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры