GIMP из ppa поломался после обновления [Решено]

Установлен GIMP (версия 2.7.4) из ppa PPA named mrw-gimp-svn for matthaeus123. Вчера пришли обновления gimp-data libgimp2.0, но сам GIMP удалился. В ppa есть версия GIMPa 2.7.5.
При попытке установить GIMP, ругань на зависимости

Пакет libglib2.0-0 версии (> = 2.31.2) на http://packages.ubuntu.com/ есть только для 12.04 "precise", для Oneiric только версия 2.30.0-0ubuntu4.

upd. Отключил ppa-реп Gimpa, удалил файлы libgimp2.0 (2.7.5) и gimp-data (2.7.5), обновил список пакетов.
GIMP не устанавливается

Никто с таким не встречался?
Тема на соседнем форуме

+2
DarkneSS - 12 Февраль, 2012 - 21:00
Изображение пользователя DarkneSS.

E: Невозможно устранить проблемы, у Вас имеются поломанные зафиксированые пакеты.Какие есть зафисированные пакеты?
GIMP 2.7.5 Will not work with the current glib and gtk in Oneiric. To fix the problem install these repos

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main

deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main
Это сделали?

0
rlepish - 12 Февраль, 2012 - 21:13

Какие есть зафисированные пакеты?

В Муоне не нашол где посмотреть

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main
deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main
Это сделали?
да, сделал.

sudo apt-get install gimp
все так же ругается на зависимости

0
DarkneSS - 12 Февраль, 2012 - 21:17
Изображение пользователя DarkneSS.

Смотрите там, где ставите: в апте.

0
rlepish - 12 Февраль, 2012 - 21:16

счас еще дообновлюсь

0
DarkneSS - 12 Февраль, 2012 - 21:17
Изображение пользователя DarkneSS.

Сразу надо было обновится ;-)

0
rlepish - 12 Февраль, 2012 - 21:24

дообновился. все таже ругань на зависимости при установке гимпа(

0
DarkneSS - 12 Февраль, 2012 - 21:40
Изображение пользователя DarkneSS.

Эта песня хороша: список заблокированных!

0
rlepish - 12 Февраль, 2012 - 21:46

В aptitude посмотрел пакеты которые с "-f" (там был раздел установленные вручную и еще чтото). там 4 пакета было.
удалил их

теперь такого раздела пакетов в aptitude нет.

обновил список пакетов, упгрейд сделал (ничего не удалялось и не обновлялось).
install gimp - ругань на зависимости

0
rlepish - 12 Февраль, 2012 - 22:01

Удалил sudo aptitude remove gimp-data libgimp2.0

и установил GIMP
sudo apt-get install gimp

установился gimp версии 2.6.11 и при том не работающий
0
rlepish - 12 Февраль, 2012 - 22:05

Моей ошибкой было то, что я закоментил ppa mrw-gimp-svn for matthaeus123

раскоментировал и gimp дообновился до версии 2.7.5

Решено

0
buerger - 21 Февраль, 2012 - 00:16
Изображение пользователя buerger.

сорри, что-то я таки не понял, где надо ppa mrw-gimp-svn for matthaeus123 раскомментировать? такая же проблема, не ставится 2.7.5 из-за неудовлетворённых зависимостей...

0
DarkneSS - 21 Февраль, 2012 - 00:32
Изображение пользователя DarkneSS.

В списке источников пакетов.

0
rlepish - 21 Февраль, 2012 - 16:00

или добавить его

+1
Condor - 14 Февраль, 2012 - 08:34
Изображение пользователя Condor.

Смасибо, DarkneSS, столкнулся с этой проблемой, твой пост здорово помог, а то после 2.7 в старой версии 2.6 уже невозможно работать!

0
DarkneSS - 14 Февраль, 2012 - 09:13
Изображение пользователя DarkneSS.

Не за что! Пост не мой, а инструкции написаны в самом ppa.

0
Гость - 19 Февраль, 2012 - 16:21

Спасибо! Очень выручили!
Не знала, как завтра работать: без Gimp`а - как без рук)

0
Vlad_W_1999 - 3 Март, 2012 - 12:49

После сегодняшнего обновления опять слетел. На этот раз что ему не хватает?

+1
speaker - 3 Март, 2012 - 13:13
Изображение пользователя speaker.

У меня не слетел.

0
DarkneSS - 3 Март, 2012 - 14:08
Изображение пользователя DarkneSS.

А в ппа ничего нового не написано? Хм. Вроде нет. Можно написать сборщику.

0
Vlad_W_1999 - 4 Март, 2012 - 15:40

Если на днях не исправится, то напишу.

0
Гость - 25 Март, 2012 - 07:52

у меня тоже не устанавливается. Как сборщику написать.
А то такая фигня получается.

[email protected]:~$ sudo apt-get install gimp

0
DarkneSS - 25 Март, 2012 - 10:37
Изображение пользователя DarkneSS.
  • Добавить ppa, написанные в шапке ppa гимпа, обновить список пакетов и попробовать ещё раз.
  • Если нет, поставить 2.7.4 отсюда и не париться.
0
dm - 5 Март, 2012 - 10:43
Изображение пользователя dm.

У меня тоже не слетел, хотя гимповские пакеты обновились.

0
Vlad_W_1999 - 5 Март, 2012 - 02:33

Попытался посмотреть из aptitude. Вот что увидел:

У кого-то мысли есть? Я что-то не соображаю совсем...

0
trubadur4ik - 5 Март, 2012 - 07:01
Изображение пользователя trubadur4ik.

A apt-get то же самое выдаёт?

0
Vlad_W_1999 - 5 Март, 2012 - 15:35
0
Master_Yoda - 5 Март, 2012 - 12:04

Я решил эту проблему установкой версии 2.7.4.

0
DarkneSS - 5 Март, 2012 - 13:02
Изображение пользователя DarkneSS.

Аналогично. А то чиз отваливался =(

0
Vlad_W_1999 - 5 Март, 2012 - 15:36

Так не хочется это делать руками... Это искать все пакеты, устанавливать... Ладно, ещё денёк повоюю и таки откачусь. Тем более, что сейчас гимп без надобности.

+3
Master_Yoda - 5 Март, 2012 - 18:51

Чтобы не искать:
sudo apt-add-repository ppa:jmou/ppa
Gimp 2.7.4

0
Vlad_W_1999 - 7 Март, 2012 - 02:03

Благодарю! Пока будем на этой версии сидеть, а потом уже разбираться.

0
Гость - 13 Март, 2012 - 03:30
0
DarkneSS - 13 Март, 2012 - 07:45
Изображение пользователя DarkneSS.

matthaeus123/mrw-gimp-svn отключить бы.

+3
DarkneSS - 13 Апрель, 2012 - 23:33
Изображение пользователя DarkneSS.

GIMP 2.8 RC1 теперь доступен для 11.10

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install gimp
Интересно, есть ли там однооконный режим, как в 2.7. Есть обзор, но там как-то мутно.

+2
speaker - 13 Апрель, 2012 - 23:53
Изображение пользователя speaker.

Обновил до 2.8. Однооконный режим есть.

0
DarkneSS - 14 Апрель, 2012 - 00:27
Изображение пользователя DarkneSS.

Спасибо! А у меня требует libgtk2.0-0 (>= 2.24.10), а оцелоте только 2.24.6. Странно, в том же ппа новее... Ога, много что ломается с ней, вот и не ставится. Не судьба, значит.

+1
Condor - 29 Апрель, 2012 - 20:00
Изображение пользователя Condor.

DarkneSS опять спас челавекав!

0
8givchik8 - 29 Апрель, 2012 - 11:24

Всем спасибо за эту тему и решение.
DarkneSS и speaker плюсую (эти посты и предложенное в них решение особо обрадовало).
И вопрос по ходу: ppa:otto-kesselgulasch/gimp - это он?)

0
rlepish - 29 Апрель, 2012 - 13:40

да, я оттуда gimp 2.8rc ставил

0
novocat - 30 Апрель, 2012 - 10:35
Изображение пользователя novocat.

Тоже поставил GIMP 2.8.0-RC1 из ppa:otto-kesselgulasch/gimp
Не матерился и не пинал никого - сразу всё завелось.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры