ATI Radeon HD 3450 после установке проприетарного драйвера пропадает изображение

Изображение пользователя AiNo07.

Привет ВСЕМ!!! А особенно Жюстине!:). Вопрос преимущественно к ней, потому, как она в этом спец. Проблема такая - после установки проприетарного драйвера на ATI Radeon HD 3450 и перезагрузки вижу такую картину. а верней вообще никакой - моник пишет вне диапазона 70\60 Герц. Как устранить данную проблему? Может быть драйвер нужно ручняком ставить и с оф. сайта? Сразу скажу, что видеокарта новенькая AGP 8x, производства Saphire. Под виндой всё работает замечательно, но не люблю я Виндовс, а видюшка мне опять всё портит! С открытым драйвером разрещение больше чем 1024х768 не поставить, да и не пойдёт открытый, хочется в Амнезию поиграть :)

0
knuckles - 13 Февраль, 2012 - 16:13
Изображение пользователя knuckles.

Я, конечно, не Жюстина и не претендую, но все же обнаглею и посоветую заюзать nomodeset в загрузчике :-)

0
AiNo07 - 13 Февраль, 2012 - 16:35
Изображение пользователя AiNo07.

Сейчас попробую, спасибо!

0
DarkneSS - 13 Февраль, 2012 - 17:06
Изображение пользователя DarkneSS.

Если она новая, есть ли она в списке поддерживаемых драйвером?

0
Vlad_W_1999 - 13 Февраль, 2012 - 18:04

А у меня другой вопрос: монитор какой? Мой Packard Bell C700 тоже пытался так выкаблучиваться. Решилось прописыванием в xorg.conf секции:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Packard Bell"
    ModelName      "C700"
    HorizSync       30.0 - 80.0
    VertRefresh     60.0 - 75.0
    Option         "DPMS"

А в секцию Section "Screen" строки

Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400" "640x350"

Разумеется, из этой же секции убрать, если есть, глупости типа

Option         "metamodes" "1152x864 +0+0"

Ну и на всякий случай: файл xorg.conf находится в /etc/X11 и частоты HorizSync, VertRefresh у тебя будут свои.

0
AiNo07 - 13 Февраль, 2012 - 18:40
Изображение пользователя AiNo07.

Дак я ведь сейчас не могу зайти под Линем, выходит нужно грузится в ознакомительном режиме, искать этот файл и редактировать его, так? Тогда ещё вопрос - где лежит xorg.conf?

0
DarkneSS - 13 Февраль, 2012 - 18:43
Изображение пользователя DarkneSS.

/etc/X11/
Можно загрузиться в режим восстановления.

0
AiNo07 - 13 Февраль, 2012 - 18:58
Изображение пользователя AiNo07.

У меня там почему-то вообще вот такой бред:

0
AiNo07 - 13 Февраль, 2012 - 19:01
Изображение пользователя AiNo07.

А как должно выглядеть содержание этого файла для меня?
Монитор: LG FLATRON L1717S

0
DarkneSS - 13 Февраль, 2012 - 19:02
Изображение пользователя DarkneSS.

Это в спецификации надо смотреть.

0
AiNo07 - 13 Февраль, 2012 - 19:11
Изображение пользователя AiNo07.

Вот:

0
DarkneSS - 13 Февраль, 2012 - 19:54
Изображение пользователя DarkneSS.

Так я уже нашёл. И кусок файла нарисовал под катом.

0
AiNo07 - 14 Февраль, 2012 - 11:45
Изображение пользователя AiNo07.

Отредактировал - та же хрень:(

0
DarkneSS - 14 Февраль, 2012 - 11:59
Изображение пользователя DarkneSS.

А в секцию Section "Screen" строки

ModesДелали?

-1
AiNo07 - 14 Февраль, 2012 - 12:04
Изображение пользователя AiNo07.

Нет, я прописал всё как вы написали выше, я же просил всё содержание этого файлика, а не кусок, я ж не профи :(

0
DarkneSS - 14 Февраль, 2012 - 12:23
Изображение пользователя DarkneSS.

Примерно так. Чтобы полностью запилить файл, нужно узнать название модуля видео. Вообще лучше всего его сгенерировать, как там принято у АТИшников и просто подправить.

0
knuckles - 14 Февраль, 2012 - 12:13
Изображение пользователя knuckles.

Уточни, в какой момент у тебя возникает эта ошибка. Постскрин видно, меню загрузчика видно? nomodeset пробовал?

0
AiNo07 - 14 Февраль, 2012 - 12:56
Изображение пользователя AiNo07.

Возникает после того, как пройдёт загрузка Kubuntu, загрузчик видно, но разрешение при этом кажись 600x800, загружается система, экран немного мигнёт и всё - картинка пропадает (моник пишет "вне диапазона 70\60 Герц"). nomodeset не помог:(

0
knuckles - 14 Февраль, 2012 - 13:52
Изображение пользователя knuckles.

Попробуй вообще xorg.conf убрать (переименовать в xorg.conf.tmp, например) и загрузиться без него. Еще поищи в папке /etc/X11 какой-нибудь xorg.conf.default или xorg.conf.install и переименуй его в xorg.conf, попробуй загрузиться.

0
AiNo07 - 14 Февраль, 2012 - 18:02
Изображение пользователя AiNo07.

Попробывал переименовать xorg.conf в xorg.conf.tmp - результат тот же результат, а файлов xorg.conf.default или xorg.conf.install - там вообще нет :(

Есть ещё тот факт, что когда я ставил Xubuntu был тот же баг с изображением, что и сейчас.

0
AiNo07 - 14 Февраль, 2012 - 18:04
Изображение пользователя AiNo07.

А может дровишьки попробывать ручняком поставить, предварительно скачав с оф. сайта? Или это не поможет?

0
knuckles - 14 Февраль, 2012 - 18:16
Изображение пользователя knuckles.

А что "aticonfig --initial" выводит?

0
AiNo07 - 14 Февраль, 2012 - 18:20
Изображение пользователя AiNo07.

Как он чего-то может выводить если я ничего не вижу, или есть какие-то другие методы посмотреть, да и как? То что ты спрашиваешь для меня вообще в новинку.

0
AiNo07 - 14 Февраль, 2012 - 18:32
Изображение пользователя AiNo07.

Давай ка лучше попробуем официальный драйвер поставить. Не подскажете как ставит файлы "run" и как будет выглядеть процесс установки в целом. Имя файла драйвера amd-driver-installer-12-1-x86.x86_64.run, лежит допустим в папке Документы.

+1
Foxy - 15 Февраль, 2012 - 00:16
Изображение пользователя Foxy.

Удалить все предыдущие версии драйвера:
sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get purge fglrx*

Переустановить зависимости:
sudo apt-get install ia32-libs ia32-libs-multiarch:i386 build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 libstdc++6:i386 dkms libqtgui4 execstack libelfg0 dh-modaliases
sudo ln -svT lib /usr/lib64

Перезагрузиться, можно в режим восстановления, и залогиниться в консоли.
Сделать файл run исполняемым:
chmod +x /путь/к/файлу/amd-driver-installer-12-1-x86.x86_64.run
Сгенерировать деб-пакеты:
sudo sh ./amd-driver-installer-12-1-x86.x86_64.run --buildpkg Ubuntu/oneiric
(искренне надеюсь, что у Вас последняя версия кубунту, в противном случае поправьте команду под свою версию)
Установка драйвера:
sudo dpkg -i fglrx*.deb
Сгенерируем новый ксорг:
sudo aticonfig --initial -f
Перезагружаемся.
Ссылко на неофициальную вики для ати (к сожалению на английском)
Желаю удачи!

0
knuckles - 15 Февраль, 2012 - 06:07
Изображение пользователя knuckles.

Да, только перед всем этим надо сделать chroot, если по прежнему удается загрузиться только с LiveCD.

0
Foxy - 15 Февраль, 2012 - 07:49
Изображение пользователя Foxy.

Поправлю себя. После chmod нужно перейти в папку с run:cd /путь/л/папке

0
Foxy - 15 Февраль, 2012 - 08:13
Изображение пользователя Foxy.

Я думаю, что режима восстановлия будет достаточно.

0
knuckles - 15 Февраль, 2012 - 08:33
Изображение пользователя knuckles.

Да, если загрузится)

P.S. Кстати, может не загрузиться, потому что дефолтный модуль для ATI/AMD (не помню название) после установки fglrx заблэклистился. Если да, то м.б. достаточно его разблэклистить?

0
DarkneSS - 15 Февраль, 2012 - 09:34
Изображение пользователя DarkneSS.

И месу тоже блеклистит? о__0 Да и в режиме восстановления можно без иксов пожить.

0
Foxy - 15 Февраль, 2012 - 16:35
Изображение пользователя Foxy.

Режиму восстановления отсутствие драйвера мешать не должно, там по сути только консоль грузится, а графика не стартует вообще. Дефолтный модуль должен был снестись после установки fglrx, там конфликт возникает между разными драйверами. Установить его заново то еще удовольствие. А вообще я за переустановку fglrx из ppa, если есть уж такая необходимость. Дрова с сайта производителя в кубунту не отличаются покладистостью при установке.

0
AiNo07 - 15 Февраль, 2012 - 10:24
Изображение пользователя AiNo07.

Спасибо!!! Попробую.

0
DarkneSS - 14 Февраль, 2012 - 18:43
Изображение пользователя DarkneSS.

Загрузитесь в режим восстановления.

0
knuckles - 14 Февраль, 2012 - 18:21
Изображение пользователя knuckles.

Еще интересно вывод "aticonfig --query-monitor" поглядеть.

З.Ы. Запускать лучше через судо)

0
AiNo07 - 14 Февраль, 2012 - 18:34
Изображение пользователя AiNo07.

Дак это можно в режиме демонстрации посмотреть, да?

0
knuckles - 14 Февраль, 2012 - 18:35
Изображение пользователя knuckles.

Забыл, что у тебя вообще ничего не показывается на мониторе. Попробуй тогда в live-сессии "Xorg -configure" выполнить. Только надо это делать в каталоге, куда записать файл можно. Команда сформирует дефолтный xorg.conf.

0
knuckles - 14 Февраль, 2012 - 18:41
Изображение пользователя knuckles.

Можно еще попробовать в /etc/init/rc-sysinit.conf записать: env DEFAULT_RUNLEVEL=3 или даже env DEFAULT_RUNLEVEL=1 и попробовать загрузиться. Если консоль будет работать, то попробовать выполнить вышеперечисленное.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры