Проблема с gtk2.0

Здравствуйте.
Дистрибутив Кубунту 12.04 х64. После установки vpnpptp (инсталлятор с офсайта vpnpptp_setup-ru-Linux-x86_64-Install.tar.gz ) программа не запускалась, не хватало библиотеки libgtk-x11-2.0.so.0. Она нашлась в пакете libgtk2.0-0. Установил его - vpnpptp работает, интернет есть. Но, при попытке установить любую программу терминал выдает следующее:

[email protected]:~$ sudo apt-get install synaptic
[sudo] password for evgeny:
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
firefox : Зависит: libgtk2.0-0 (>= 2.24.0) но 2.20.1-2 будет установлен
firefox-globalmenu : Зависит: libgtk2.0-0 (>= 2.24.0) но 2.20.1-2 будет установлен
libgdk-pixbuf2.0-0 : Ломает: libgtk2.0-0 (< 2.21.3) но 2.20.1-2 будет установлен
libgtk2.0-0 : Зависит: libjpeg62 (>= 6b1) но он не будет установлен
               Рекомендует: libgtk2.0-bin
libgtk2.0-common : Ломает: libgtk2.0-0 (< 2.24.8-2) но 2.20.1-2 будет установлен
synaptic : Зависит: libept1.4.12 но он не будет установлен
            Зависит: libgtk2.0-0 (>= 2.24.0) но 2.20.1-2 будет установлен
            Зависит: libvte9 (>= 1:0.24.0) но он не будет установлен
            Рекомендует: libgtk2-perl (>= 1:1.130) но он не будет установлен
            Рекомендует: rarian-compat но он не будет установлен
            Рекомендует: software-properties-gtk но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
[email protected]:~$

0
Master_Yoda - 4 Май, 2012 - 17:14

Вас вот эта фраза ни на какие мысли не наводит "Попытайтесь выполнить «apt-get -f install», не указывая имени пакета"?

0
Flanker - 4 Май, 2012 - 17:51

Наводит, естественно, это первое, что я сделал, но эффекта - ноль ((

0
DarkneSS - 4 Май, 2012 - 17:53
Изображение пользователя DarkneSS.

Удалите libgtk с помощью dpkg, а потом делайте sudo apt-get -f install

0
trubadur4ik - 4 Май, 2012 - 19:20
Изображение пользователя trubadur4ik.

У меня тож проблемы c этой либой. Хочу установить AdobeAir, а тот ругается:

[email protected]:~$ ./AdobeAIRInstaller.run
/tmp/air.U3oSu8/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

libgtk2.0-0 устанавливал:

[email protected]:~$ sudo aptitude search libgtk2.0-0
i A libgtk2.0-0                                                            - GTK+ graphical user interface library                                          
p   libgtk2.0-0:i386                                                       - GTK+ graphical user interface library                                          
p   libgtk2.0-0-dbg                                                        - GTK+ libraries and debugging symbols                                           
p   libgtk2.0-0-dbg:i386                                                   - GTK+ libraries and debugging symbols     

0
DarkneSS - 4 Май, 2012 - 20:48
Изображение пользователя DarkneSS.

Что странно. Попробуй перед установкой сделатьexport LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnuИли перезапусти шелл и пробуй "i386-linux-gnu" если первое не покатит.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры