Очень долго стартует система

Приветствую.
После перехода на 18.04 (уже пол года как, по факту kde-neon) система начала стартовать очень долго. если раньше вся загрузка занимала 20 сек, то сейчас минуту.
гугл указал на отключение некоторых сервисов типа NetworkManager-wait-online.service - но это не помогло. удаление самбы ускорило буквально на 2 секунды.

буду признателен за помощь, если какая инфа нужна - пишите, я скину :)
спасибо

0
lord_i - 14 Август, 2019 - 12:05
Изображение пользователя lord_i.

Я такие вещи ищу по по выхлопу dmesg -H
Там слева идет временная шкала и аномалии сразу видны.

0
ozim - 14 Август, 2019 - 13:21
0
lord_i - 14 Август, 2019 - 14:07
Изображение пользователя lord_i.

:) Это самое начало. Нажимаешь пейдж даун и изучаешь. Там страниц 20-30 до полной загрузки таких

0
ozim - 14 Август, 2019 - 21:59

а что именно искать? если данные больше нуля или что? типа +0,002223 ?

0
ozim - 14 Август, 2019 - 22:02

есть такое, там циферки побольше

0
ozim - 14 Август, 2019 - 22:16

в общем, гуглил, отрубал что-то, типа hdmi audio - ничего не поменялось. на данный момент выхлоп

пробовал включать с вытянутым кабелем инета - безрезультатно..

0
ozim - 14 Август, 2019 - 22:23

вроде как добавил в блеклист этот модуль
echo "blacklist enp3s0" | sudo tee -a /etc/modprobe.d/blacklist.conf
но нихрена не поменялось, и он в логах все равно есть, и время загрузки до секунды совпадает со всеми предыдущими..

0
ozim - 14 Август, 2019 - 22:24

а modinfo enp3s0
выдает
modinfo: ERROR: Module enp3s0 not found.

0
ozim - 14 Август, 2019 - 22:24

удалено

0
kot040188 - 14 Август, 2019 - 19:31
Изображение пользователя kot040188.

Вангую — проблемы с диском.

0
lord_i - 14 Август, 2019 - 20:32
Изображение пользователя lord_i.

Да, это достаточно вероятная причина

0
Boom - 15 Август, 2019 - 00:11
Изображение пользователя Boom.

Это бывает.Когда то помогло. https://www.linux.org.ru/forum/desktop/14261271?cid=14272815

0
ozim - 15 Август, 2019 - 22:59

не помогло :(

0
Denisok39 - 15 Август, 2019 - 06:23
Изображение пользователя Denisok39.

Незнаю зачем и почему, но с недавнего времени тормоза сильно добавляют snapd и packagekit , с какой стати эта хрень теперь стартует при запуске так и не понятно), если их снести, хотя бы один - snapd(если и"пакаджекит", то и "дискавер" придется, но при необходимости - установка "plasma-discover" вернет все как было)) и почистить за ними, то скорость запуска заметно прибавится. А для начала мжно просто включить "пустой сеанс"

+1
AlexBKost - 15 Август, 2019 - 15:17

Denisok39, можно и снести snapd, если нет необходимости устанавливать пакеты snap. А вот снос packagekit приведет к отключению автоматической проверки обновлений. Кому это надо?

0
Denisok39 - 15 Август, 2019 - 17:45
Изображение пользователя Denisok39.

Так мне как раз это и надо было) - на 19.04 автообновление стартует вместе с запуском системы, поэтому и пришлось сносить этот пакаджекит, сравнил потом логи - вот и увидел - скорость старта прибавилась)

0
ozim - 15 Август, 2019 - 23:01

пустой сеанс и стоит, снап д ниче в логах не показывает.
меня больше смущает это
enp3s0: link is not ready
enp3s0: link down

собака явно тут зарыта

-1
Denisok39 - 15 Август, 2019 - 17:50
Изображение пользователя Denisok39.

Кстати, у кого нибудь получается выключить в "источниках" поиск обновлений при каждом старте(на 19.04) или это возможно только на LTS? там вроде как "по барабану" куда галочки ставить, один фиг - стартует при каждом запуске

0
AlexBKost - 15 Август, 2019 - 21:17

Если к выше упомянутому packagekit снести ещё apt-xapian-index, то ничего обновляться не будет не зависимо от LTS.

0
Denisok39 - 16 Август, 2019 - 05:39
Изображение пользователя Denisok39.

попробую, может тогда и "дискавер" вместе с "снапом" можно будет не трогать
ЗЫ. а ни фига, там зависимости принципиальные:

хотя, если все нужное уже установлено, то может и стОит), нервы и заряд батареи(в дороге) - дороже)
0
ozim - 15 Август, 2019 - 22:56

попробуйте привести строку к виду
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
в файле /etc/default/grub

а нет гоню, это не то, я вчера нагугли что то такое, ща поищу
UPD блин а может и оно, попробуйте

+1
jzyken - 17 Август, 2019 - 11:33
Изображение пользователя jzyken.

Т.к. у вас graphical.target достигается уже через 6 сек, то, дело, я так понимаю, в графической подсистеме. У меня были подобные проблемы. Плазма что-то чудила с виджетами и панелями, и при использовании нескольких мониторов они, бывало, пропадали. Я добавлял новые, но в конфиге оставались и старые также. В итоге при старте плазмы всё это хорошо подвисало. Вручную почистить конфиг достаточно сложно, нужно разбираться с форматом. Поэтому попробуйте его переименовать:
mv "${HOME}/.config/plasma-org.kde.plasma.desktop-appletsrc" "${HOME}/.config/plasma-org.kde.plasma.desktop-appletsrc.backupppp"
И перезагрузитесь, или перезапустите dm:
sudo systemctl restart sddm.service

0
ozim - 17 Август, 2019 - 22:42

спасибо. на 5 сек ускорилось, но общей картины не поменяло :(

0
ozim - 17 Август, 2019 - 22:45

сейчас вижу такое
[  +3,539492] snd_hda_intel 0000:01:00.1: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.
что то со звуковой картой, видимо?

0
jzyken - 17 Август, 2019 - 22:54
Изображение пользователя jzyken.

А киньте весь лог:
sudo journalctl -b > "${HOME}/startup.log"
Может dm тупит? На каком именно этапе висит?

0
ozim - 17 Август, 2019 - 22:56

https://pastebin.com/tNUtyHVA
насчет этапа не могу сказать, но судя по логу dmesg -H в конце )

0
jzyken - 18 Август, 2019 - 00:57
Изображение пользователя jzyken.

Подозрительные записи в логе:
org.kde.kactivities.resources: QSqlError("11", "Невозможно получить строку", "database disk image is malformed")
Может kactivities много раз пытается прочесть свою базу, поэтому и задежка..?
Попробуйте заставить её пересоздать:
mv "${HOME}/.local/share/kactivitymanagerd/resources/database" "${HOME}/.local/share/kactivitymanagerd/resources/database.backup"
И перезагрузитесь, если удачно переименовалось.

0
ozim - 18 Август, 2019 - 20:15

короче, я сдуру переключил дисплейный сервер, и не смог стартануть систему вообще, в терминал зайти тоже не получалось. установил mint cinnamon - и, не поверите, тут точно такая же история со временем загрузки..
и тут такая же лажа
[  +0,710179] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[  +0,141856] r8169 0000:03:00.0 enp3s0: link down
[  +0,000004] r8169 0000:03:00.0 enp3s0: link down
[  +0,000093] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[  +2,268401] r8169 0000:03:00.0 enp3s0: link up
[  +0,000020] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready

0
jzyken - 18 Август, 2019 - 20:49
Изображение пользователя jzyken.

Эти записи, я так понимаю, говорят о попытках поднять сетевой интерфейс с ipv6 адресом. Возможно ожидаются таймауты SLAAC. Но, вы посмотрите, эти записи появляются в течение первых 10 секунд со старта. Каким образом это может увеличить длительность загрузки на полминуты?
На какой дисплейный сервер? Вы теперь на Wayland? Вы пробовали переименовать папку, которую я указал?

0
ozim - 21 Август, 2019 - 18:50

я после выбора wayland вообще не смог стартануть систему, и установил mint, этот лог уже с минта.
да, переименовал, но на минте этот файл вообще не появляется.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры