OpenOffice 3 [РЕШЕНО]

Изображение пользователя extaaazzzy.

Добрый день, форумчане!
Вышел релиз OpenOffice 3. Кто нибудь ставил его? На оф. сайте нашел только файлы rpm и для ручной сборки. А для *бунту подобных есть что нибудь?!

0
Bazilio - 24 Октябрь, 2008 - 15:39
Изображение пользователя Bazilio.

DEB пакеты есть:
тут
тут

0
extaaazzzy - 24 Октябрь, 2008 - 17:33
Изображение пользователя extaaazzzy.

спасибо.

0
Ibergard - 24 Октябрь, 2008 - 17:19

вот у меня стоит ООо 2.4.1... можно его через репозитарии как нибудь обновить? или тока накатывать дебом? если через деб делать, то старый сносить или новый заменой ляжет сверху?

0
Soi-Fong - 24 Октябрь, 2008 - 19:13
Изображение пользователя Soi-Fong.

они независимы друг от друга, у меня стояли оба, потом я вторую версию снес
а в репах убунты вроде пока нету третьего ооо

0
Гость - 26 Ноябрь, 2008 - 23:52

не появился ещё третий опенофис в репозитариях?
как можно поставить третий вместо второго. чтоб корректно открывались файлики, а не каждый раз нужно было выбирать через что открывать.
какие-то продвижения есть вообще? поставить тройку не проблема, я не могу её заставить работать по умолчанию.

0
dm - 27 Ноябрь, 2008 - 14:39
Изображение пользователя dm.

Появился давным давно.

Добавляем репозиторий:

deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main

И обновляемся:

sudo aptitude update
sudo aptitude upgrade

0
alfavictory - 3 Декабрь, 2008 - 10:26

Привет!!!

Ввел как ты написал (копи-пастом) в результате... болт
0 пакетов обновленно...
Kubuntu 8.10 + KDE 4.1 + OpenOffice 2.4.1 ... :(

Проверил через Менеджер пакетов все есть (ссылка на репу)

В чем могут быть грабли?

Очень хочу третий офис...

0
dm - 4 Декабрь, 2008 - 11:09
Изображение пользователя dm.

Ну а репозиторий то добавили в /etc/apt/sources.list ?

У меня все нормально обновилось из данного репозитория, правда обновлялся я уже давольно давно. МОжет что-то и поменялось, не знаю.

0
keeper-andrew - 4 Декабрь, 2008 - 17:33

Ептель. Ну естественно добавляли.

0
keeper-andrew - 3 Декабрь, 2008 - 15:37

Аналогично. На этом репе похоже нету нового офиса или ошибка в ссылке.

0
keeper-andrew - 15 Декабрь, 2008 - 15:45

Вчерась заработало и появился третий офис. Обновился легко и быстро. Третий офис дальше сплэшскрина не работает. Где-то пробегал пост анонимуса с логом - у меня идентичная проблема была. Снес весь офис поставил 3-ку с нуля = та же фигня. Снес, закоментарил эти урлы и вернул свой старый добренький 2.4. Сижу злой - дофига времени убил и остался с тем же что и был.

0
Bazilio - 16 Декабрь, 2008 - 10:19
Изображение пользователя Bazilio.

а сборку от инфры не пробовал?

0
keeper-andrew - 16 Декабрь, 2008 - 12:56

Не кошерно.

Начиная с того, что старый офис прийдется удалить, а это сделать не так просто, потому что в адепте поиск испоганили в полное гавно - вводишь "openoffice.org" а на выходе туева хуча пакетов, причем пакеты начинающиеся с "openoffice.org" могут быть в любом месте этого списка без какой-либо логики на сортировке.

Заканчивая тем, что обновиться на следующую версию будет тоже проблема - прийдется сносить руками и заново ставить. Да и сборка от инфры ставит весь офис, а мне надо только writer, calc и math - все остальное ненужно и только тянет лишние dependency которые мне будут стоить много $ так как инет у нас в беларуси не дешевый.

0
Bazilio - 16 Декабрь, 2008 - 15:02
Изображение пользователя Bazilio.

ну что тут можно сказать.
новый адепт, конечно, фигня. я посмотрел на него и решил, что буду наверно синаптик юзать.

по поводу всех пакетов
[email protected]:~$ ls Distr/OOo_3.0.0_LinuxIntel_install_ru_infra_deb/ru/DEBS/
desktop-integration ooobasis3.0-impress_3.0.0-9_i386.deb ooobasis3.0-ru-writer_3.0.0-9_i386.deb
ooobasis3.0-base_3.0.0-9_i386.deb ooobasis3.0-javafilter_3.0.0-9_i386.deb ooobasis3.0-testtool_3.0.0-9_i386.deb
ooobasis3.0-binfilter_3.0.0-9_i386.deb ooobasis3.0-kde-integration_3.0.0-9_i386.deb ooobasis3.0-writer_3.0.0-9_i386.deb
ooobasis3.0-calc_3.0.0-9_i386.deb ooobasis3.0-math_3.0.0-9_i386.deb ooobasis3.0-xsltfilter_3.0.0-9_i386.deb
ooobasis3.0-core01_3.0.0-9_i386.deb ooobasis3.0-onlineupdate_3.0.0-9_i386.deb openoffice.org3_3.0.0-9_i386.deb
ooobasis3.0-core02_3.0.0-9_i386.deb ooobasis3.0-ooofonts_3.0.0-9_i386.deb openoffice.org3-base_3.0.0-9_i386.deb
ooobasis3.0-core03_3.0.0-9_i386.deb ooobasis3.0-ooolinguistic_3.0.0-9_i386.deb openoffice.org3-calc_3.0.0-9_i386.deb
ooobasis3.0-core04_3.0.0-9_i386.deb ooobasis3.0-pyuno_3.0.0-9_i386.deb openoffice.org3-dict-de_3.0.0-9_i386.deb
ooobasis3.0-core05_3.0.0-9_i386.deb ooobasis3.0-ru_3.0.0-9_i386.deb openoffice.org3-dict-en_3.0.0-9_i386.deb
ooobasis3.0-core06_3.0.0-9_i386.deb ooobasis3.0-ru-base_3.0.0-9_i386.deb openoffice.org3-dict-ru_3.0.0-9_i386.deb
ooobasis3.0-core07_3.0.0-9_i386.deb ooobasis3.0-ru-binfilter_3.0.0-9_i386.deb openoffice.org3-dict-uk_3.0.0-9_i386.deb
ooobasis3.0-draw_3.0.0-9_i386.deb ooobasis3.0-ru-calc_3.0.0-9_i386.deb openoffice.org3-draw_3.0.0-9_i386.deb
ooobasis3.0-extension-pdf-import_3.0.0-9_i386.deb ooobasis3.0-ru-draw_3.0.0-9_i386.deb openoffice.org3-impress_3.0.0-9_i386.deb
ooobasis3.0-extension-presentation-minimizer_3.0.0-9_i386.deb ooobasis3.0-ru-help_3.0.0-9_i386.deb openoffice.org3-math_3.0.0-9_i386.deb
ooobasis3.0-gnome-integration_3.0.0-9_i386.deb ooobasis3.0-ru-impress_3.0.0-9_i386.deb openoffice.org3-ru_3.0.0-9_i386.deb
ooobasis3.0-graphicfilter_3.0.0-9_i386.deb ooobasis3.0-ru-math_3.0.0-9_i386.deb openoffice.org3-writer_3.0.0-9_i386.deb
ooobasis3.0-images_3.0.0-9_i386.deb ooobasis3.0-ru-res_3.0.0-9_i386.deb openoffice.org-ure_1.4.0-9_i386.deb

Как не сложно понять, можно поставить только те пакеты, которые тебе необходимы.

0
Bazilio - 28 Ноябрь, 2008 - 14:00
Изображение пользователя Bazilio.

а я скачал deb пакеты с сайта инфра-ресурс, снёс OpenOffice 2 и поставил командой sudo dpkg -i *.deb OpenOffice 3
Работает хорошо.

0
vbifyz - 28 Ноябрь, 2008 - 22:19

Bazilio
Работает хорошо а лучше OpenOffice 2 -????
а то опять новый софт
опять ищи новые кнопки

0
Bazilio - 1 Декабрь, 2008 - 16:43
Изображение пользователя Bazilio.

Да, лучше.
Самое главное улучшение - пропали проблемы с кодировками. Также некоторые документы, слепленные в ворде, стали лучше выглядеть.

0
CHIPOLINO - 3 Декабрь, 2008 - 13:47
Изображение пользователя CHIPOLINO.

Ммм ... а ОО-2.4 надо удалять или можно поверх? Пакеты с Оф сайта брал.

0
Bazilio - 3 Декабрь, 2008 - 14:32
Изображение пользователя Bazilio.

я ставил сборку от инфра-ресурс
у меня всё ставилось кроме пакета openoffice.org3.0-debian-menus_3.0-9358_all.deb
а без него программа в К-меню не появлялась.
такчто я всё снёс и поставил все пакеты командой sudo dpkg -i *.deb работает превосходно, я рад :)

0
Soi-Fong - 3 Декабрь, 2008 - 14:59
Изображение пользователя Soi-Fong.

У меня openoffice.org3.0-debian-menus_3.0-9358_all.deb из сборки инфры тока после сноса оо2 встал, и все заработало круто: и меню и ассоциации файлов.
И вроде оо2 и оо3 работают независимо друг от друга.

0
Bazilio - 4 Декабрь, 2008 - 11:04
Изображение пользователя Bazilio.

а зачем оо2, если есть оо3?

0
Soi-Fong - 5 Декабрь, 2008 - 00:36
Изображение пользователя Soi-Fong.

Чтобы иметь за спиной что-то рабочее и проверенное. Вот когда оо3 поработает некоторое время и покажет свою стабильность, тогда можно и оо2 снести.

0
Bazilio - 5 Декабрь, 2008 - 10:23
Изображение пользователя Bazilio.

так это же стабильный релиз. ну вобщем как знаешь :)

0
rlepish - 5 Декабрь, 2008 - 13:22

Хелп. хотел установить 3 офис на кубунту 8,10.
в консоле запустил в папке с дебами sudo dpkg -i *.deb. ругнулось на

dpkg: regarding openoffice.org3.0-debian-menus_3.0-9354_all.deb containing openoffice.org-debian-menus:
openoffice.org-core conflicts with openoffice.org-unbundled
openoffice.org-debian-menus provides openoffice.org-unbundled and is to be installed.
dpkg: error processing openoffice.org3.0-debian-menus_3.0-9354_all.deb (--install):
conflicting packages - not installing openoffice.org-debian-menus
....
Processing triggers for menu ...
Errors were encountered while processing:
openoffice.org3.0-debian-menus_3.0-9354_all.deb

Через Адепт Манагер удалил все программы ОпенОфиса. (из меню Офис значки пропали).
проблема осталась.
порыл гугла, нашол что правильно удалять офис 2,4 нужно

sudo apt-get remove openoffice.org

запускаю, в ответ
Пакет удалить невозможно, поскольку он не установлен.

Установить новый офис не могу.
хотел восстановить через Адепт офис 2,4 из CD8.10 (не найден), из DVD8,4 (установилось только презентации, врайтер и електронные таблицы не установились)

запускаю,

sudo apt-get remove openoffice.org

в ответ
Пакет удалить невозможно, поскольку он не установлен.

что посоветуете?

0
Bazilio - 5 Декабрь, 2008 - 14:05
Изображение пользователя Bazilio.

зайти в адепт-менеджер
в поиске набрать openoffice
снять галку "неустановлено" в фильтре
удалить всё, что установлено
заново попробовать установить офис из скачанных деб пакетов.

0
brun65 - 20 Январь, 2009 - 13:24
Изображение пользователя brun65.

А попробуй sudo apt-get -f autoremove
может какие зависимые пакеты застряли.

0
Гость - 14 Декабрь, 2008 - 10:52

У Go-oo(третий офис с улучшенным быстродействием http://go-oo.org/) пакеты находятся в формате .rpm, поэтому для установки на Ubuntu скачиваем и конвертируем: sudo alien /путь к пакетам/*.rpm, используя alien, в формат .deb.

Архив с пакетами уже конвертированными в .deb, включены только языковые пакеты для русккого языка:
www.narod.ru/disk/4226352000/Go-OO3.tar.gz.html (146.12 Мб)

Для установки, извлекаем из архива пакеты и выполняем:
sudo dpkg -i /путь к пакетам/*.deb

0
kortik - 24 Декабрь, 2008 - 00:46

Обновился в Kubuntu intrepid до 3.0 и поллная ж. Загораеться таблица, что документ будет восстановлен, а дальше любые действия приводят к тому что я прикрепил. Снёс 3.0 и поставил от инфра-ресурс ooobasis 3.0 Pro. Блин, опять такое-же.
В чём причина,кто нибудь сталкивался.
И как теперь удалить ooobasis 3.0 Pro ?

0
Bazilio - 24 Декабрь, 2008 - 10:37
Изображение пользователя Bazilio.

Посмотри, все ли пакеты ты установил, там же не только ooobasis надо ставить. все основные пакеты надо ставить и те, которые нужны: writer, calc, math и т.д.

0
kortik - 24 Декабрь, 2008 - 12:56

Да я все и поставил командой sudo dpkg -i *.deb.

Потом решил переустановить с репов.Установил, запустился. Шрифты,фон были страшными,и пропадало меню когда мышку наводил. Методом доустановки разных пакетов определил, что когда доустанавливаю пакет openoffice.org-gtk 3.0 или openoffice.org-kde 3.0 тогда не запускается и всё тоже что я указал чуть выше.Без этих пакетов всё работает!!!!!!!!!!!

0
Гость - 6 Январь, 2009 - 19:52

с помощью заранее закаченных deb-пакетов, везде рекомендуют сперва удалить старую версию ОО, а потом поставить новую командой dpkg -i *.deb, однако данный способ автоматическин не разрешает зависимости, что плохо.
Поэтому рекомендую натравить aptoncd на папку с закаченным ОО3, создать образ диска,

снести старый open!!!

примонтировать его:
sudo mount -o loop aptoncd-oo3.iso /media/cdrom0
добавить диск:
sudo apt-cdrom add -m
и обновиться:
sudo aptitude upgrade
и всё, при чём все зависимости будут разрешены...

НО!!!, увы не все так просто ...

далее пошол в ход бубен

итак - отключаем все репы, через синаптик ставим все пакеты относящиеся к openoffice и ooobasis (для экономии трафика и времени) версии 3.0

потом ставим openoffice.org3.0-debian-menus_3.0-9358_all.deb

у меня не стал - поэтому делал не так как должно, а как получилось :

Добавляем репозиторий:

deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main
потом, ставим стятягивая с нета недостающие пакеты.(мне докачало 500метров)

0
dude_sam - 5 Апрель, 2009 - 10:56
Изображение пользователя dude_sam.

Хотел установить OOo3, но случайно :) скачал пакет Linux X86-64 (tar.gz), а не Linux X86-64 (DEB).
Файл ./configure не вижу - получается это не исходники?
В никсах новичок и что делать дальше не знаю... :)
Или скачать deb и не париться? Просто хочется разобраться, что делать, так сказать, "на будущее"...

0
picaro - 5 Апрель, 2009 - 19:47
Изображение пользователя picaro.

Скорее всего это бинарник и его можно установить с инсталятора. Ищи исполняемый файл.

0
Sapphire - 5 Апрель, 2009 - 11:14
Изображение пользователя Sapphire.

пришлось обновить через apt-get dist-upgrade если sudo aptitude update
sudo aptitude upgrade
то не захотело оно. так и оставило 2.4

0
Гал - 6 Апрель, 2009 - 05:05
Изображение пользователя Гал.

Ставил оо3 таким образом. Скачал пачку deb-пакетов с инфрарус. Далее командой
sudo aptitude remove openoffice.org-core
снес старый офис. Причем этот пакет тянет за собой все остальные. Затем в папке DIST
sudo dpkg -i *.deb
и напоследок ставим пакет для отображения его, офиса, в кменю.
все встало ровно, работает тоже пока ровно. :)

0
dude_sam - 6 Апрель, 2009 - 08:25
Изображение пользователя dude_sam.

и напоследок ставим пакет для отображения его, офиса, в кменю.
Простите :), а что за пакет?

0
Гал - 6 Апрель, 2009 - 21:59
Изображение пользователя Гал.

openoffice.org3.0-debian-menus_3.0-9379_all.deb

0
dm - 6 Апрель, 2009 - 20:41
Изображение пользователя dm.

Установка скаченных .deb пакетов есть не самый правильный путь при наличии репозитария.

Правильный способ установки Оpen Office 3

0
Гал - 6 Апрель, 2009 - 22:01
Изображение пользователя Гал.

dm а какая собстно разница? Вот если бы у меня все криво встало, тогда бы я считал что мой способ не правильный. А так я доволен))))

0
dm - 6 Апрель, 2009 - 22:26
Изображение пользователя dm.

Разница в том, что при установке через репозитарий, программа будет автоматически обновляться при выходе новых версий или заплаток, на пример даже если просто пропишешь рапозитарий при установелнном OO 2.4 система сама предложит обновиться на последнюю версию, это как пример. Во вторых не возникнет проблем при удалении.

Я не говорю что ставить из пакетов нельзя, я говорю, что более правильно ставить прописывая репозитории. Схема проста:
1) Прописываешь репозитарий,
2) обновляешь список доступных для установки пакетов,
3) ставишь нужный пакет.

При этом нет необходимости следить за обновлениями и новыми версиями программ. Хотя безусловно, работать может и отдельно установленный пакет.

0
dude_sam - 8 Апрель, 2009 - 07:41
Изображение пользователя dude_sam.

Не подскажите:
А как для версии от Инфра-Ресурс прописать репозитарий?
Чтобы потом все само обновлялось?
И как убрать из списка доступных пакетов в adept версию 2,4?

0
dm - 8 Апрель, 2009 - 07:51
Изображение пользователя dm.

Так ведь тремя постами выше ссылку давал на инструкцию по установке ОО3 от инфра ресурса.

0
Гал - 8 Апрель, 2009 - 18:49
Изображение пользователя Гал.

Ага, с этим согласен. Тока с репозитария он качает не руссифицированную версию. А у меня до этого русская стояла((( Спасибо dm.... )))))) Блин. Буду искать способ руссификации.....

+1
dm - 8 Апрель, 2009 - 19:22
Изображение пользователя dm.

Для русификации ОО 3 установи пакет:

sudo aptitude install openoffice.org-l10n-ru

0
Гал - 8 Апрель, 2009 - 22:04
Изображение пользователя Гал.

спасибо, сработало )))))

0
SVA - 8 Ноябрь, 2009 - 17:23
Изображение пользователя SVA.

И мне помогло! +1 и почему после установки 9.10 в ОО автоматом выставился английский? ))

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры