Skype+pulseaudio+микрофон Web камеры [РЕШЕНО]

Изображение пользователя fox4.

После установки звукового сервера pulseaudio у меня в Skype перестал работать микрофон от web-камеры.
В настройках Skype наблюдаем такую картину

причём выбрать другие устройства кроме PulseAudio server (local) невозможно (ну покрайней мере у меня)
После Гугления чтения форумов и шаманство с Kmix и AlsaMixer смог запустить только микрофон с гарнитуры. Как оказалось решение лежало на поверхности доустанавливаем pavucontrol
sudo apt-get install pavucontrol
Запускаем и на вкладке "Устройства ввода" смотрим что выбрано в качестве микрофона у меня было
"Встроенное аудиоустройство Analog Stereo" теперь понятно почему работал микрофон с гарнитуры
Идём на вкладку "Запись" запускаем Skype делаем контрольный звонок и в появившихся для приложения настройках ввода выбираем требуемое устройство

проверяем на вкладке "Устройства ввода" наличие выбранного устройства

всё пользуемся.

Комментарии (93)

0
пионер - 16 Январь, 2010 - 11:41
Изображение пользователя пионер.

Блин, на 9.04 ваще не определяет встроенный микрофон, только ALC262 analog...=(((((

0
Chibiko - 24 Март, 2010 - 18:01
Изображение пользователя Chibiko.

Спасибо. плюсую, поднимаю 8)
Помогло.

0
dyug - 26 Март, 2010 - 17:01

давно использую, именно по причине внешнего внутрикамерного микрофона.
других способов включения микрофона я не нашел

главное - что с рисунками... :-)

0
Kayoma - 26 Март, 2010 - 21:30

Мне вот это не понятно Оо

0
fox4 - 29 Март, 2010 - 15:48
Изображение пользователя fox4.

Установи pulsaudio в консоли
sudo apt-get install pulseaudio
или через KPackageKit

0
Гость - 23 Август, 2012 - 03:46

открой понел упровление зайди звук и там настрой

0
buba - 10 Июнь, 2010 - 22:50
Изображение пользователя buba.

У меня пропал после этого входящий звук))

0
fox4 - 11 Июнь, 2010 - 12:43
Изображение пользователя fox4.

"Кто пропал и куда пропал ?" В смысле другое приложение не воспринимает входной сигнал со звуковухи ? Поточнее нельзя ?

0
jolly - 30 Октябрь, 2010 - 18:11
Изображение пользователя jolly.

в линухе я нуб, так что сильно не ругайте ...
у меня кубунту 10.10 х64, pulsaudio вроде как установлен (при поиске в KPackageKit на против него есть галочка), но выбрать микрофон в скайпе не выходит остается неизменный PulseAudio server (local)

скайп 2.1.0.81, устанавливал с оф. сайта для Ubuntu 8.10+ 64-bit

что не так, самому пока разобраться не получается ...

0
DarkneSS - 30 Октябрь, 2010 - 18:30
Изображение пользователя DarkneSS.

Скайп тут не поможет. Установите и запустите pavucontol, проверьте и настройте в нём ваш микрофон. Тут вам пригодится любая программа, которая может записывать звук: например, kwave или audacity.

+1
jolly - 30 Октябрь, 2010 - 21:07
Изображение пользователя jolly.

спасибо заработало =)
pavucontol я не нашол, но установил PulseAudio Volume Control по началу амарок был единственным там приложением, но я его закрыл и настроил скайп ...
теперь все хорошо, только в скайпе как-то тихо ...

0
DarkneSS - 30 Октябрь, 2010 - 22:44
Изображение пользователя DarkneSS.

Двигайте ползунки.

0
dyug - 31 Октябрь, 2010 - 10:55

кайп 2.1.0.81, устанавливал с оф. сайта для Ubuntu 8.10+ 64-bit
То есть, мыши кололись, но продолжали жрать кактус.
включить репозитарий "партнер" и поставить скайп оттуда не было возможности?
Хотя он там лежит уже 2-й релиз....

+1
Lexxa - 30 Октябрь, 2010 - 21:22

pavucontol я не нашол, но установил PulseAudio Volume Control

Это не одно и то же?

0
DarkneSS - 30 Октябрь, 2010 - 22:44
Изображение пользователя DarkneSS.

Одно.

0
jolly - 31 Октябрь, 2010 - 20:52
Изображение пользователя jolly.

слышимость в скайпе не очень хотя громкость везде на максимуме ...

походу дело не в микрофоне, а уши почему то тихо вещают ... ну главное что заработало, а с остальным чуть позже разберусь =)

+1
Гость - 1 Ноябрь, 2010 - 19:32

В то 10.04 у меня не пошел микрофон под пульсаудио, а в 10.10 - все настроилось само и спокойно работает, хоть оно трижды пульсаудио!

+1
dyug - 3 Ноябрь, 2010 - 12:10

Итак...
Проблема, как я понял не в скайпе, но в пульсеаудио...
Описание проблемы:
Нетбук Асер Емашине 350 со встроенным микрофоном, вебкамерой...
Не работает встроенный микрофон.
Все пляски с бубнами, с версиями алсы, версиями ядра не приводят ни к каким результатам.

Но я нашел решение, как всегда, с помощью гугла...
http://ubuntologia.ru/forum/viewtopic.php?f=96&t=1934#p17223

и оно работает!!!
Кратко: отключить в пульсеволюме связку каналов - ака замочек, и разнести регуляторы в разные стороны.
У меня во всяком случае не играет роли какой канал включен, а какой выключен.
главное, чтоб была между ними разница.

Честно, просто не пришла такая простая идея самому в голову... :-(

+1
Гость - 8 Ноябрь, 2010 - 20:02

Народ помогите проблема со скайпом или с ОС я не знаю. У меня ноут Lenova G555. меня не слышно в скайпе, регулировал громкость, поставил pavucontrol, там мой микрофон не определился вообще.

+1
opan - 8 Ноябрь, 2010 - 21:21

Спасибо заработало).

+1
Гость - 30 Ноябрь, 2010 - 23:19

Спасибо за статью, наконец-то я микрофон в скайпе настроил :-)

0
Гость - 24 Декабрь, 2010 - 00:13

я готова убить kubuntu, до этого хотя бы я слышала, после установки pulsaudio уже ни я ничего не слышу, ни меня не слышно. и где найти эту вкладку "устройсто ввода", у меня есть только "вывод"

0
PostaL - 24 Декабрь, 2010 - 01:36
Изображение пользователя PostaL.

поставь pavucontol там настройки pulsaudio

0
Гость - 24 Декабрь, 2010 - 09:06

поставила, и где его теперь найти?

0
DarkneSS - 24 Декабрь, 2010 - 10:03
Изображение пользователя DarkneSS.

В меню?.. Или просто вбить pavucontol в терминале или по Alt+F2

0
Lexxa - 24 Декабрь, 2010 - 10:37

Программы - Мультимедиа - дальше сама.

0
Andrei_Lem - 14 Февраль, 2011 - 23:56

Спасибо за очень четкий мануал со скриншотами. Я мучился с микрофоном месяц и перелопатил кучу инфы, и только по твоему руководству все получилось быстро и четко. Респект.

0
fox4 - 15 Февраль, 2011 - 17:20
Изображение пользователя fox4.

Наберёшь Кармы доставай плюсомёт :-)

0
virus84 - 17 Февраль, 2011 - 00:53

Спасибо, fox4. На ThinkPad x100e помогло, причем на альфа-дистрибутиве 11.04

0
Гость - 10 Апрель, 2011 - 17:25

спасибо! мне помогло.

0
Гость - 31 Май, 2011 - 19:54

Спасибо большое! Мне помогло!

0
fox4 - 31 Май, 2011 - 22:39
Изображение пользователя fox4.

Ну собственно для этого и создавалась статейка :-) теперь и в подшивке

0
viler - 22 Июнь, 2011 - 18:15
Изображение пользователя viler.

спасибо, помогло. kubuntu natty 11.04. у меня почему-то по-умолчанию pulse audio считал устройством захвата звука front microphone переставил на аналоговый микрофон - и все ок.

0
Гость - 18 Июль, 2011 - 20:18

Спасибо, помогло на ксубунте + ноут IBM R51.

0
Гость - 23 Июль, 2011 - 19:53

не получается!

0
ColdFlames - 23 Июль, 2011 - 22:12

"Я ничего не делал, но ничего не работает..."
Конкретнее в чем загвоздка?

0
Гость - 17 Август, 2011 - 17:58

Решил проблему следующим образом:
в система>звук в область уведомлений передвинь ползунок на максимум и сними галочку,а в пункте Тема звуков: Без звуков. Обычно все передвигают ползунок на минимум или ставят галочку.

0
supersvoboda - 28 Август, 2011 - 11:18
Изображение пользователя supersvoboda.

У меня в pavucontrol не переключаются вкладки. Только на первой могу делать изменения. Что делать? (Kubuntu 11.04)

0
DarkneSS - 28 Август, 2011 - 12:01
Изображение пользователя DarkneSS.

Попробуйте навести курсор на табы и поводить колесом мыши.

+2
supersvoboda - 28 Август, 2011 - 13:37
Изображение пользователя supersvoboda.

Это ж надо так лохануться. Спасибо
З.Ы.: "Если умный человек делает глупость, то уж, во всяком случае, не малую"И.В. Гёте

0
DarkneSS - 28 Август, 2011 - 14:29
Изображение пользователя DarkneSS.

Вы не лоханулись. Это баг темы оформления.

0
Iglin - 12 Сентябрь, 2011 - 09:36

Дополнение к теме. В Kubuntu 11.10 Oneiric Ocelot в репах установлена версия pavucontrol, которая может глючить (не запускается). В этом случае нужно её снести и установить предыдущую версию pavucontrol_0.9.9-1_i386.deb. Далее - как в первом посте.

0
Гость - 18 Октябрь, 2011 - 13:44

Спасибо, помогло! =)
Насчёт "слабой слышимости" - попробуйте снять галку с "Позволить Skype автоматически подстраивать громкость"

0
Гость - 21 Октябрь, 2011 - 11:56

Спасибо, действительно помогло.

0
serkre - 22 Октябрь, 2011 - 10:58
Изображение пользователя serkre.

Спасибо! Помогло.

0
z00m - 27 Январь, 2012 - 23:44
Изображение пользователя z00m.

В кубунте 11.10 камера уже нормально определилась и в скайпе глюков не было, только вот микрофон никак меня не слышал... Тоже перерыл все настройки, в пульсе вроде все нормально было, так оказалось что в кмиксе просто выключен был микрофон камеры.
Может быть кому еще поможет моя невнимательность... =)

0
Гость - 26 Март, 2012 - 15:29

Спасибо, помогло)

0
Гость - 14 Апрель, 2012 - 22:13

Спасибо.

+1
Гость - 1 Май, 2012 - 21:35

и на сусе 12.1 помогло, эта была первая статья которая попалась в гугле и такая удача! )) А то по комментам видно что поиски обычно длятся неделями)))))

0
fox4 - 7 Май, 2012 - 10:33
Изображение пользователя fox4.

Рад что труд не пропадает даром :-)

0
Гость - 30 Май, 2012 - 15:51

Спасибо огромное! совет в самый раз)))

0
kymkaz - 15 Июнь, 2012 - 18:35

Всем доброе время суток.
У меня Kubuntu 12.04 Lts
Komp.- Asus 61sl с HD Radeon 4570
.
Проблема - в скайпе, когда говорю в микрофон, с моим голосом идет какой-то шум и треск!
fox4 я попробовал все что ты написал.
Снес PulseAudio. В консоли прописал команду на pavucontrol. Запустил скайп - а там опять стоит PulseAudio server (local) - то есть нельзя выбрать никакое устройство!
Как я понял, разработчики вместо "Павука" грузят мне на комп "ПульсАудио".
Понял что от этого PulseAudio - никуда не деться, давай там разные конфигурации пробовать, перетаскивал ползунки в разные стороны, отключал, выбирал другое оборудование, результат = "0".
Самое интересное что во вкладке запись, где собсно и нужно выбирать оборудование, у меня всего три варианта:

Почему так, не могу понять, ведь я подключаю камеру с микрофоном, да и в ноуте самом тоже есть микрофон.
Вообщем хелп! ;)

0
fox4 - 15 Июнь, 2012 - 21:15
Изображение пользователя fox4.

По ссылке пишут что вебкамера опционально так она у вас есть или внешнюю пользуете что в консоли sudo lsusb выдаёт вообще-то Я не писал что нужно сносить PulseAudio как раз удалять его не нужно так как это звуковой сервер микширующий звуковые потоки а Pavucontrol это его настройщик с графической мордой у вас как вебкамера в скайпе хоть как то определяется если да то модель камеры какая ? И после подключения камеры (если она внешняя) надо бы перезагрузиться Linux для некоторых устройств не всегда автоматом драйверы подгружает

0
DarkneSS - 15 Июнь, 2012 - 21:39
Изображение пользователя DarkneSS.

Убавить мик буст, выключить в скайпе автоподбор громкости.

0
dyug - 16 Июнь, 2012 - 09:04

Меня гораздо больше интересует что во вкладке "устройства ввода" есть...
И основное: pavucontrol - это интерфейс для управления pulse audio, поэтому он работать без него не умеет, и устанавливает его в случае выбора...

Вы бы хоть попытались понять, что делаете, а не тыкали разные инструкции подряд бездумно..
Здесь не виндовс, где толком как оно работает все равно не понятно, здесь все построено логично....

0
kymkaz - 17 Июнь, 2012 - 00:07

ВО вкладке "устройства ввода" все тоже самое что и при выборе во вкладке "запись".

У меня один вопрос: "ЧТО ДЕЛАЕТ ШУМЫ? / Из-за ЧЕГО ИМЕННО шумы?" Я использовал разные микрофоны(правда всего 2-ва: встроенный в ноуте микрофон и подключал USB-камеру с микрофоном), результат ОДИН И ТОТ ЖЕ - непонятные звуки, вроде потрескивания или шипения, вместе с моим голосом(который, если бы не шумы и треск очень хорошего качества). О_о

0
dyug - 17 Июнь, 2012 - 10:03

Я не вижу на данной картинке юсб камеры с микрофоном.
то есть вообще.
У меня это выглядит вот так:

И как можно заметить - у меня есть микрофон от юсбкамеры.
Правда, у меня и нет тресков и шумов на голосе.

0
kymkaz - 18 Июнь, 2012 - 11:41

Так и я о том же! Я тоже этого не вижу!! ПОЧЕМУ???

0
dyug - 18 Июнь, 2012 - 14:58

может там нет ЮСБ микрофона, и он включается отдельным проводом? :-)))))))))

0
kymkaz - 19 Июнь, 2012 - 20:08

Да, USB-видеокамера подключается 2-мя проводами(USB и проводом к микрофону), но я их и включаю 2-ВА!
Может какая другая прога есть для настройки аудио? Или может другой скайп? Какая версия скайпа у вас?

0
dyug - 20 Июнь, 2012 - 09:45

Вообще у меня их (вебкамер) штук 5 разных, так что у меня есть опыт использования.
Есть с двумя проводами (она у меня работает), есть с одним юсб (с микрофоном и без микрофона) и все работают.
В твоем варианте - у тебя не будет отдельного входа для микрофона камеры.
То есть твой сриншот соответствует твоей камере.
У тебя, вероятно, есть проблема со входом микрофона.
Проблемы решения я так, навскидку, не вижу.

Наверное есть, но я не пользуюсь. Скайп до этого стоял из репов, после выхода 4 поставлен тот, что отдается со сайта скайпа.
Никаких посторонних шумов, скрежетов, у меня не наблюдается. ни на старой версии, ни на новой.

Единственное, что я могу посоветовать - попробовать запустить какую либо программу для записи звука, и играться с настройками звуковой подсистемы.

0
kymkaz - 22 Июнь, 2012 - 17:56

Проблема где-то в программных настройках, так как до Kubuntu, имея "виндовс" - проблем с камерой и микрофоном не было ... :/
Что ж, суть понятна ... играться дальше с ползунками в PulseAudio ... мрак ... хотя этот дистрибутив, как вы говорите, логичен - для меня он темный лес без всякой логики ...

P.s. А если, к примеру, дрова на эту камеру скачать и установить, поможет? Одно выводит - в скайпе не могу выбрать оборудование - там стоит только одно - PulseAudio server (local)

0
dyug - 22 Июнь, 2012 - 21:17

гмм, скажите, Вы умеете читать? А понимать прочитанное?
При чем тут дрова на камеру, если у Вас проблема именно с микрофонным входом? (учитывая, что Вы сами сказали, что у Вас микрофон включен отдельным проводом, включаемым в отдельный, я так думаю, в микрофонный вход)
То есть - еще раз, решать проблему нужно с микрофонным входом, а не с камерой.

0
kymkaz - 23 Июнь, 2012 - 13:31

Я понял вашу мысль - спасибо за идею.;) Но она однозначно направляет меня по неверному пути решения проблемы.
Повторяю на Windows XP и 7-ке, оба микрофона (как встроенный в ноуте так и с USB-камеры), работали ОТЛИЧНО!
Или для вас это не довод того, что проблема не с микрофонным входом? о_О

0
dyug - 23 Июнь, 2012 - 14:27

мдя, тяжело иметь дело с лицом не умеющим ни читать, но и даже думать.
Я о Вас, kymkaz, говорю.
Я подозреваю, что у меня не хватит терпения разъяснить Вам всю глубину Вашего непонимания, и нежелания понять, что Вам необходимо разобраться с Вашей звуковой системой (в частности - с драйверами)...
Извините, дальше для меня эта тема закрыта.
Вы только что подтвердили,Я понял вашу мысль - спасибо за идею.;) Но она однозначно направляет меня по неверному пути решения проблемы.
Повторяю на Windows XP и 7-ке, оба микрофона (как встроенный в ноуте так и с USB-камеры), работали ОТЛИЧНО!
что не хотите решать проблему путем, который приведет Вас к решению.
Нет, я конечно посоветую все же более внимательно почитать выдачу поиска на сайте по вопросу "не работает микрофон", но у Вас, совершенно очевидно, есть уверенность, что я ничего не знаю, и не понимаю, я так рассказываю то, что для любого "специалиста" (я специалист, я документацию не читаю) является неправильным, ибо ни один "специалист" не читает документацию, ибо всем известно, что в документации на виндовс ничего полезного не написано. :-)

0
DarkneSS - 17 Июнь, 2012 - 10:33
Изображение пользователя DarkneSS.

У меня шумы даёт выкрученный на максимум мик буст.

0
Гость - 2 Июль, 2012 - 17:13

И у меня то же самое, даже в выпадающем меню всего 2 пункта (аналоговое стерео и монитор). Такое ощущение что пульсаудио сервер вообще не подхватил встроенный микрофон... А микрофон есть и рабочий - на офтопике все работает... если найдете решение - дайте знать.

0
rod - 3 Июль, 2012 - 12:31

Предыдущее мое сообщение. Помогло после всех вышесказанных манипуляций вот что (ноутбук Lenovo G570)
отредактировать файл /etc/modprobe.d/alsa-base.conf
В этот файл вписать строку в конец
options snd-hda-intel model=asus
Перезагрузиться.... (ноут леново а писать асус)

0
kymkaz - 1 Июль, 2012 - 07:59

Всем спасибо за помощь, но к сожалению проблему я не решил. :(
Тяжеловата для меня KUBUNTU, вообщем я перешел обратно на Windows 7.
Да к стати, микрофон на Виндовсе - работает просто СУПЕР. (Может в будущем это поможет как-то в САМОМ деле решить проблему). :)
P.s. Без обид, реально всем СПАСИБО! Всех благ! ;)

0
dyug - 1 Июль, 2012 - 09:12

флаг в руки, и так далее, по тексту... :-)
Тяжела любая новая операционная система. Ибо незнакома.

0
Гость - 25 Август, 2012 - 18:00

аналогично в скайпе как не было звука так и нет:)

а венда она и в африке венда

0
Гость - 22 Июль, 2012 - 14:53

Спасибо большое, помогло!

0
vladimir80 - 27 Август, 2012 - 15:02

У всех на скриншотах в пункте "запись"высвечивается скайп.У меня почему то пусто хотя скайп запущен-микрофон не работает.Проблема остаётся.

0
Гость - 3 Октябрь, 2012 - 21:21

Спасибо большое, помогло! Для SB400 и PulseAudio только этот регулятор!!!

0
Гость - 9 Октябрь, 2012 - 19:01

Спасибо! Теперь у меня в скайпе есть звук. Но пропало видео :)

0
Гость - 13 Ноябрь, 2012 - 20:14

Огромное человеческое спасибо!

+2
Гость - 13 Ноябрь, 2012 - 20:43

А, я по другому решил проблему pavucontrol - конфигурация - встроенное аудио в профиле было установлено "аналоговый стрео дуплекс" который я заменил на "аналоговый стерео выход" и вуаля звук заработал!!!!

0
Гость - 15 Декабрь, 2012 - 18:29

Большое спасибо! Альтлинукс 6 - полет нормальный =)

0
Гость - 28 Февраль, 2013 - 08:52

Большое спасибо!!! Помогло.
Linux Mint 14 xfce

0
ost-nikolaj - 23 Март, 2013 - 18:36

Обновился до KDE — 4.10.1, Kubuntu 12.04
Пропал звук от микрофона со встроенного в вебку Logitech C-300
копал везде где мог, вот чего показывают все настроечные окна

KMix перестал запускаться даже в консоли.
В Kwave вообще не видно мой микрофон.
Не видно движения на индикаторах уровня входного сигнала от микрофона, с видео проблем нет.
На ноуте HP Pavilion dv5 er1069, кстати та же беда с микрофоном, и как следствие со Скайпом, блин!
Кто может помогите, плиииз!
Извиняюсь, но под кат картинку спрятать не сумел.
0
ost-nikolaj - 1 Апрель, 2013 - 13:52

Всем спасибо, расколдовал Skype под 10-е Кеды! Крути верти всякие настройки и найдется рабочий вариант. Оба компика вылечил.
pavucontrol отличная штучка для регулировок и настроек в графике. Как включили б Каноникал себе такую штуку в сборку и поддержку. Кто скажет как подсоветовать им?

0
dyug - 1 Апрель, 2013 - 13:59

гмм.. и давно пульсеаудио выпилен? :-)

тут вечные жалобы что он тут мешает..
а павуконтрол - это просто средство управления пульсеаудио..
он есть в дистрибутиве уже давно.

0
Гость - 22 Октябрь, 2013 - 14:24

Да не нужен павуконтрол в кде. Гному гномово. Все делается в настройках мультимедиа -> запись звука -> общение. Нужный микрофон от камеры поднять в самый верх и сохранить. Все.

0
Гость - 26 Октябрь, 2014 - 17:50

а у меня проблема в том, что все вроде бы так; но при тестовом звонке - скайп не появялется в в списке программ что-либо использующих

0
fox4 - 26 Октябрь, 2014 - 22:05
Изображение пользователя fox4.

Уважаемый для начала вы бы хоть до конца оформили свою проблему.
А то из вашего сообщения не очень понятно где скайп не появляется.
Вы учтите что статье в блоге около 5 лет многое поменялось.
В частности скайп был куплен майкрософтом был "насильственный" переход на версию 4.3 в общем жизнь продолжается.
Хотелось бы большей конкретики а то напоминает сказку "пойди туда не знаю куда принеси то не знаю что".

0
Гость - 19 Январь, 2015 - 07:01

При проверочном звонке всё работает, но не сохраняется после окончания проверки ( запись не включена)

0
Гость - 27 Февраль, 2015 - 12:02

Спасибо))
Ничего не читал, но после просмотра второй фотографии меня озарило)) Все заработало)

0
Problem - 16 Июнь, 2015 - 12:10
Изображение пользователя Problem.

Спасибо, помогло.

0
Гость - 29 Июнь, 2015 - 20:11

Огромное Вам человеческое спасибо!

0
Гость - 1 Август, 2015 - 08:30

Первое время в настройках из меню аудиовхода можно было выбирать микрофон вебкамеры и работало... После удаления лишних прог Linux микрофон вебкамеры в Skype исчез и возможность пообщатся. Сделал как посоветовали, микрофон вебки так и не появился в настройках, но звук с микрофона заработал. Спасибо

+1
Гость - 13 Август, 2015 - 18:33

Уфф... СПАСИБО!

0
Гость - 7 Январь, 2016 - 05:27

Очень огромное СПАСИБО!!!!!

0
Гость - 25 Апрель, 2016 - 19:41

Спасибо помогло