KDE 4.4.4 на Kubuntu 9.10 [НЕТ РЕШЕНИЯ]

Изображение пользователя palyanich.

Уважаемые, помогите дилетанту! Сосбсна как поставить последние стабильные КЕДЫ 4.4.4 на Kubuntu 9.10 (Karmic Koala)? Какой реп добавить? Ибо при добавлении бекпортов:
deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu karmic main в списке обновлений появляются блокированные апдейты в количестве 65 штук с версиями пакетов 4:4.6.2 - то есть нужных мне как воздух!

*Актуальное состояние системы: Kubuntu 9.10 (Karmic Koala), KDE 4.3.2

0
Voyageur - 24 Июнь, 2010 - 15:47
Изображение пользователя Voyageur.

В консолиsudo aptitude update
sudo aptitude dist-upgrade

0
palyanich - 24 Июнь, 2010 - 15:50
Изображение пользователя palyanich.

...ииии я буду иметь кеды 4.4.2 а нуна 4.4.4

*пробовал брат! было бы так просто - сюда б не обращался)))

0
Voyageur - 24 Июнь, 2010 - 16:34
Изображение пользователя Voyageur.

Это?
Ой, и опять прошу прощения, проморгал, что у тебя 9.10.

0
palyanich - 24 Июнь, 2010 - 16:47
Изображение пользователя palyanich.

а ЭТО как?!?!?!

в смысле как ставить-то?! ибо:
добавляешь: ppa:kubuntu-ppa/ppa он тебе: deb http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu kirmic main а там КЕДЫ 4.4.3 (или 4.4.2)...

0
trubadur4ik - 24 Июнь, 2010 - 16:55
Изображение пользователя trubadur4ik.

Сюда заглянь. Добавишь репы, должно обновиться. Я так делал.

0
palyanich - 24 Июнь, 2010 - 16:57
Изображение пользователя palyanich.

А вот скажи брат, если я вхреначу sudo aptitude full-upgrade это мне до 10.04 систему не обновит?!?!

0
trubadur4ik - 24 Июнь, 2010 - 17:06
Изображение пользователя trubadur4ik.

Судя по ману, да. :-(
<b>full-upgrade</b>
           Upgrades installed packages to their most recent version, removing or installing packages as necessary. This command is less conservative than <b>safe-upgrade</b> and thus more likely to perform
           unwanted actions. However, it is capable of upgrading packages that <b>safe-upgrade</b> cannot upgrade.

               <b>Note</b>
               This command was originally named <b>dist-upgrade</b> for historical reasons, and aptitude still recognizes <b>dist-upgrade</b> as a synonym for <b>full-upgrade</b>.

Можно будет safe-upgrade
<b>safe-upgrade</b>
           Upgrades installed packages to their most recent version. Installed packages will not be removed unless they are unused (see the section “Managing Automatically Installed Packages” in the
           aptitude reference manual). Packages which are not currently installed may be installed to resolve dependencies unless the <b>--no-new-installs</b> command-line option is supplied.

           It is sometimes necessary to remove one package in order to upgrade another; this command is not able to upgrade packages in such situations. Use the <b>full-upgrade</b> command to upgrade as many
           packages as possible.
попробовать или обновить только кеды (тока я чё-то не знаю, как это сделать).

0
knuckles - 14 Сентябрь, 2010 - 18:56
Изображение пользователя knuckles.

А вот скажи брат, если я вхреначу
sudo aptitude full-upgrade
это мне до 10.04 систему не обновит?!?!
Нет, потому что там только KDE-ные пакеты - т.е. обновит только кеды и все :-)

+1
dyug - 14 Сентябрь, 2010 - 22:48

гмм, как я помню, фулапгрейд апдейтит систему с выкачкой недостающих пакетов.
Но НЕ МЕНЯЕТ релиз.
для смены релиза существуют другие команды. :-)

0
knuckles - 15 Сентябрь, 2010 - 05:11
Изображение пользователя knuckles.

Недостающих - это каких? Насколько я помню full-upgrade отличается тем, что в некоторых случаях может удалить пакеты, если они мешают разрешению зависимостей.

0
balamutick - 15 Сентябрь, 2010 - 06:54
Изображение пользователя balamutick.

я хз о чём вы, но вот недавно на нетбуке обновил себе до ЛТС Кубунту.

Делал так

1. # apt-get update
2. # apt-get upgrade
3. # vi /etc/apt/source.list
в vi командой
:s/karmic/lucid/gc
заменял по всему тексту кармическую на ясную.
:wq - сохранился и выходил из vi
4. apt-get dist-upgrade (full-upgrade это вроде тоже самое).
После этого, мне сказали, что скачать надо 1017 мб пакетов (с учётом, что вай-фай и точка не рядом). После обновлялась часок с чем-то.

Перезагрузилась, недогрузилась, из консоли
1. # apt-get update
2. # apt-get upgrade
Перезагрузился ещё раз и всё запахало с новой версией релиза.

Если инструкция достойная, то в мемориз!

+1
dyug - 15 Сентябрь, 2010 - 09:19

Все правильно.
только ты не учел, что ты РУЧКАМИ заменил название релиза, а речь шла о том, сам по себе, без вот этой стадии
3. # vi /etc/apt/source.list
в vi командой
:s/karmic/lucid/gc
заменял по всему тексту кармическую на ясную.
:wq - сохранился и выходил из vi

смена релиза не произойдет.
И не больше.

-1
balamutick - 15 Сентябрь, 2010 - 15:14
Изображение пользователя balamutick.

без вот этой стадии
Не ну а как вы предполагаете сменяться релизу ? Программа телепатирует сама, куда вы хотите откатится, обновится и т.п.

Хотите чтобы спец. программа сама меняла source.list ?

ДА и что сложного ? Если пугает Vi можно хоть в OpenOffice поменять это и работать. Ещё в пакетном менеджере Адепт когда-то была возможность заменить это, если я не путаю ничего.

+1
knuckles - 15 Сентябрь, 2010 - 15:24
Изображение пользователя knuckles.

balamutick, это все верно, но изначальный вопрос был такой:

А вот скажи брат, если я вхреначу
sudo aptitude full-upgrade
это мне до 10.04 систему не обновит?!?!

и отвечали мы именно на него (см. выше).

0
dyug - 15 Сентябрь, 2010 - 16:02
я ленивая тварь
0
balamutick - 15 Сентябрь, 2010 - 17:37
Изображение пользователя balamutick.

Скромно ВКЛ: Боги тоже ошибаются...
Скромно Выкл: ну я подумал, что вполне уместно напомнить :-)

0
knuckles - 15 Сентябрь, 2010 - 18:05
Изображение пользователя knuckles.

Все правильно, баламутик должен баламутить! ;-)

0
dyug - 24 Июнь, 2010 - 17:29

Исходя из просмотра ппа для кармика есть только 4.4.2
https://launchpad.net/~kubuntu-ppa/+archive/ppa?field.series_filter=karmic

выбираем в фильтре ликуд, и понимаем все.

сам 4.4.2 есть только в бекпорте
https://launchpad.net/~kubuntu-ppa/+archive/backports?field.series_filter=karmic

Все репрозитарии кубунту ппа можно увидеть здесь. :-)

0
palyanich - 24 Июнь, 2010 - 18:03
Изображение пользователя palyanich.

то есть решения у этой проблемы нет?! и мне остается сменить тему на:
KDE 4.4.4 на Kubuntu 9.10 (Karmic) [НЕ РЕШАЕМО]?

0
dyug - 24 Июнь, 2010 - 18:12

думаю - да.
Впрочем - всегда есть возможность собрать самому... :-)

0
palyanich - 24 Июнь, 2010 - 18:20
Изображение пользователя palyanich.

))))

да не будет никакого гнева))) знать бы как это делается... ибо все мои попытки терпели фиаско(((

0
dyug - 25 Июнь, 2010 - 12:05
0
palyanich - 28 Июнь, 2010 - 00:20
Изображение пользователя palyanich.

ну что ж, спасибо))) будет времени вдоволь - обязательно изучу!

0
palyanich - 24 Июнь, 2010 - 17:45
Изображение пользователя palyanich.

Ну что мне на это ответить?! Хочешь жить - крутись... )))

я вот сейчас сижу с разрешением 1024 на 768@60гц - глаза болят уже! Специально не обновляю только что поставленную Кармическую Коалу, и драйвера не ставлю - жду хоть какого-нибудь решения моей проблемы... Приходится спамить постить везде :/

0
palyanich - 26 Июнь, 2010 - 21:15
Изображение пользователя palyanich.

Вобщем сижу на 4.3.5 и понимаю, что по стабильности они делают и 4.4.2 и 4.4.4... жаль все-таки что некоторые виджеты так и не запахали (((

+1
Жюстина - 14 Сентябрь, 2010 - 19:19
Изображение пользователя Жюстина.

Гг, с такими запросами то ксорг новый надо, то кде поновее, генту лучше уж тогда, по нужным запчастям собрать да и всё, чего кубунтиться то тут?

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры