Проблемы установки kubuntu 10.04 на ноутбук Samsung NP-R20

Здравствуйте.
Столкнулся с проблемой установки kubuntu 10.04 на ноутбук samsung NP-R20 (видеокарта интегрирована ATI Radeon Xpress 1250): после установки и перезагрузки чёрный экран!
Пробовал: Через F6 ACPI=off, подключал внешний моник (Samtron)- чёрный экран везде.
Может кто решил подобную проблему?

+1
dyug - 26 Июль, 2010 - 09:49

угу.
radeon.modeset=0
работает.
У меня R18 это 20 без винды в комплекте.
заносится в строку граба
я уже описывал это на форуме.

0
KAPAKyPT - 28 Июль, 2010 - 06:21

Начитался форумов до рези в глазах... проблема осталась. Я новичок в Линуксах - для меня много не понятных вещей. Если не трудно распишите алгоритм:
1. Режим установки
2. Нестандартные настройки в процессе установки (если нужны)
3. Действия после перезагрузки - вот на этом месте - полный ступор!
Хотя бы ссылку дайте на то место, где решение подобной проблемы описано.
Заранее благодарен.

0
balamutick - 28 Июль, 2010 - 06:39
Изображение пользователя balamutick.

для меня много не понятных вещей. Вещей очень много, какие непонятны именно вам, сложно понять.

Потому:
1. Режим установки - что не понятного ? Вы не понимаете как ставить ? Или вы не понимаете Alternate и т.п. варианты установки ?

2. Нестандартные настройки в процессе установки (если нужны), нестандартные настройки чего ? Под видеокарту ?

3. Действия после перезагрузки - вот на этом месте - полный ступор! - после перезагрузки, пользоваться системой. Если не получается пользоваться, то читаете как перейти в консоль и что в ней ввести, чтобы пользоваться системой с ограниченной графикой, или какими движениями установить драйвер для вашей видеокарты.

0
knuckles - 28 Июль, 2010 - 06:53
Изображение пользователя knuckles.

...после установки и перезагрузки чёрный экран!
Вот так прям сразу, даже БИОС ничего не выводит? :-) Опишите поподробнее!

0
balamutick - 28 Июль, 2010 - 06:57
Изображение пользователя balamutick.

+1
Во-во, я вот например свои карты Таро сегодня уже использовал, а кофейную гущу лень заваривать.

+1
KAPAKyPT - 28 Июль, 2010 - 10:27

:) Попытаюсь подробно.
Что происходит по порядку:
1. БИОС - всё как обычно
2 меню Загрузчика (появился после установки - он и есть ГРАБ?) показывает варианты:
- загрузка убунты/кубунты
- загрузка убунты/кубунты (save mode)
- ещё пара строк с тестами
-
- загрузка windows xp
всё это дело ждёт таймер обратного отсчёта 10 сек
предлагает поправить меню посредством "е" и ещё что-то

3 Самое интересное:
если грузить по умолчанию - помигает вверху слева курсор и чёрный экран, alt+ctrl+F1 - нет реакции
если выбрать сэйф-моде - пару секунд бегут строчки загрузки чего-то, потом снова чёрный экран

Вот на самом интересном я и зависаю: что нужно сделать, чтоб загрузить ОС в нормальном виде?

Что я пытался (из адекватных вещей):
1. подключал монитор на внешний выход - результат то же на обоих экранах (на внешнем слегка отстаёт)
2. Правил меню загрузчика:
- "е", переход в конец текста, ввод новой строки
- прописываю: radeon.modeset=0
- ctrl+x
3. Ситема грузится с тем же результатом - чёрный экран.

(не адекватные вещи):
устанавливал ubuntu 10.04, kubuntu 10.04, xubuntu 10.04 - всё это с офф сайта alternate CD х86, загонял образ на флэшку и ставил с флэшки, установка с подключенной сетью и без сети (прямое подключение к инету, DHCP работает правильно)

Плюнул на samsung - поставил ubuntu 10.04x64 на asus F7z - с первого раза ось установилась, запустилась, подгрузила обновления и дрова...Всё бы хорошо, но это не мой ноут! у меня Samsung NP-R20 с интегрированной видеокартой ATI Radeon Xpress 1250 - под Виндой XP ставятся только дрова с комплектного CD либо с сайта Samsung, 7-ка сама откуда-то дрова скачивает.

Вот как смог, так подробно описал.
Гуру Линукса, помогите советом по настройке ноута! Не располагаю средствами для покупки другого ноута. В случае успешной установки, обязуюсь расписать подробно этапы установки на эту железяку в пластиковом корпусе.

0
knuckles - 28 Июль, 2010 - 10:53
Изображение пользователя knuckles.

Срочно в подшивку с комментарием:

Как надо правильно задавать вопросы

:-)

0
balamutick - 28 Июль, 2010 - 10:57
Изображение пользователя balamutick.

В плане того, что он всё правильно ответил ? да ?

0
knuckles - 28 Июль, 2010 - 11:08
Изображение пользователя knuckles.

В плане того, что он все блестяще описал! Разве что дампа ядра в момент зависания не хватает :-)

UDP: кажется, сообразил, что ты имел ввиду. Я не про то, как я задал ему вопрос, а про то, как он задал его нам со второй попытки))

+1
dyug - 28 Июль, 2010 - 13:47

2. Правил меню загрузчика:
- "е", переход в конец текста, ввод новой строки
- прописываю: radeon.modeset=0
- ctrl+x
3. Ситема грузится с тем же результатом - чёрный экран.

не ввод новой строки а в конец строки начинающейся с (счас перегружу ноут и скажу)
linux /boot/vmlinuz ..................
и в конец ЭТОЙ строки дописать radeon.modeset=0

во всяком случае у меня так :-)
И работает

0
knuckles - 28 Июль, 2010 - 14:26
Изображение пользователя knuckles.

2. Правил меню загрузчика:
- "е", переход в конец текста, ввод новой строки

Блин, как мы это проморгали???

0
KAPAKyPT - 28 Июль, 2010 - 11:08

:)
А где же желанные советы по теме?
Господа, нужен ответ, да такой чтоб всё понятно и по полочкам (по полочкам потом сам разложу)
Что делать - то? Уже думаю поставить более ранние релизы (8 или 9)...

0
knuckles - 28 Июль, 2010 - 11:13
Изображение пользователя knuckles.

К сожалению, с ноутами вечная проблема, а причин - море.
Попробуй передать ядру nomodeset вместо radeon.modeset=0.

если выбрать сэйф-моде - пару секунд бегут строчки загрузки чего-то, потом снова чёрный экран
А последние несколько строк можешь поймать как-нибудь?

0
dyug - 28 Июль, 2010 - 13:55

строчка не в том месте :-)
потому и не будет работать. :-)

0
KAPAKyPT - 28 Июль, 2010 - 11:31

nomodeset не обнаружил эффекта

В сэйф-моде заснял процесс на видео. 4 Мб в формате MP4 куда можно положить для просмотра?

0
KAPAKyPT - 28 Июль, 2010 - 11:40

Последние строчки в сейф-моде:

0
knuckles - 28 Июль, 2010 - 11:54
Изображение пользователя knuckles.

После этого:
...
Begin: Running /scripts/init-bottom ...
Done.

совсем ничего?

0
dyug - 28 Июль, 2010 - 13:56

и тут должен быть переход в графику... :-)
после чего все тупо виснет... :-(

0
KAPAKyPT - 28 Июль, 2010 - 14:04

Да. После этого всё тупо виснет :-(...
Завтра испытаю совет от dyug - отпишу.

+1
KAPAKyPT - 29 Июль, 2010 - 09:07

linux /boot/vmlinuz ..................
и в конец ЭТОЙ строки дописать radeon.modeset=0

И происходит чудо! :-)

0
knuckles - 29 Июль, 2010 - 09:33
Изображение пользователя knuckles.

Ну, слава Богу :-)

+1
KAPAKyPT - 29 Июль, 2010 - 09:08

dyug - Респект и уважуха! Всё отлично работает.

0
dyug - 29 Июль, 2010 - 11:27

дык, я же в первом посте написал - у меня тот же ноут. :-)
только наклейка R18plus, a не R20PlusЮ, ибо он продавался без винды, точнее вообще без операционки.

только чтоб не вводить это постоянно необходимо дописать в файле
/etc/default/grub
добавить в строке
GRUB_CMDLINE_LINUX_DEFAULT="......... radeon.modest=0"
и потом обновить груб
update-grub

разумеется, это все необходимо делать с правами рута
перед началом действий необходимо выполнить sudo -s и ввести свой пароль. :-)

Вроде ничего не забыл :-)

0
KAPAKyPT - 30 Июль, 2010 - 20:31

А как добавить то?!
Текстовым редактором нельзя...
Что нужно сделать, чтоб редактировать GRUB?
Понимаю, что в терминале, но как?
Извиняюсь за полное нубство :-)

0
rlepish - 30 Июль, 2010 - 21:15

sudo kate /etc/default/grub

K.O.

0
KAPAKyPT - 31 Июль, 2010 - 07:19

Разобрался:
sudo текстовый_редактор ....

0
dyug - 31 Июль, 2010 - 11:05

разумеется, это все необходимо делать с правами рута
перед началом действий необходимо выполнить sudo -s и ввести свой пароль. :-)

я для кого это написал? для прикола что ли?
Запустить терминал, и в нем читая инструкции было сложно сделать? :-(

Просто злобен.

0
Гость - 2 Август, 2010 - 14:28

Не просто сложно, а не реально, когда не знаешь, как пользоваться терминалом!
Открыл терминал
в терминале: sudo -s потом пароль -
а как открыть в терминале /etc/default/grub ?
edit - не подошло, на других форумах искал - везде разная команда, тупил пока не дошло: это не команда, а название редактора:))
Теперь всё ясно и понятно, пишешь команду - она выполняется, пишешь хрень - хрень и выполняется :-)

0
FedFed - 12 Сентябрь, 2010 - 14:03
Изображение пользователя FedFed.

А как открыть терминал "на опережение", т.е. до того, как он зависнет?

0
dyug - 12 Сентябрь, 2010 - 17:52

никак разумеется.
стрчку нужно вписать в режиме редактирования груба.
как это сделать здесь раза три описано.

0
FedFed - 13 Сентябрь, 2010 - 14:52
Изображение пользователя FedFed.

А, понял, а как перейти в меню загрузчика? Он у меня сразу Кубунту пускать начинает, без вариантов.

0
dyug - 13 Сентябрь, 2010 - 16:25

эээ господа, напомните, человеку, я не помню, что там нажимать надо, а с моим текущим носом, и болящей головой мне только поиском заниматься... :-(

Единственная мысль что сейчас приходит - загрузиться с компакта в рескуре моде...
там дальше есть возможность подмонтировать раздел рутовый в консоли.

0
mft - 13 Сентябрь, 2010 - 17:05

shift надо удерживать при загрузке...

0
FedFed - 13 Сентябрь, 2010 - 17:06
Изображение пользователя FedFed.

Во! Вышел в терминал. Kate, естественно, не грузит. Мона как-нибудь без него, через консоль файлик etc/default/grub поправить?

0
Жюстина - 13 Сентябрь, 2010 - 17:09
Изображение пользователя Жюстина.

sudo nano /etc/default/grub

0
FedFed - 13 Сентябрь, 2010 - 17:09
Изображение пользователя FedFed.

Спасибо. Пробую.

0
FedFed - 13 Сентябрь, 2010 - 17:09
Изображение пользователя FedFed.

Вот че нашел: http://ubuntologia.ru/grub2-settings-file
sudo sed 's/GRUB_TIMEOUT="текущее значение"/GRUB_TIMEOUT="новое значение"/g' -i /etc/default/grub
Есть идея, что тут что-то по образу и подобию.

0
FedFed - 13 Сентябрь, 2010 - 17:17
Изображение пользователя FedFed.

Почти прошло, но пишет, что файловая система доступна только для чтения.

0
Жюстина - 13 Сентябрь, 2010 - 17:29
Изображение пользователя Жюстина.

А фс вообще исправна? Он ещё должен бы написать почему она только для чтения...

0
FedFed - 13 Сентябрь, 2010 - 17:31
Изображение пользователя FedFed.

Думаю, что исправна. Просто пишет, что запись невозможна, доступна только для чтения.

0
FedFed - 13 Сентябрь, 2010 - 17:34
Изображение пользователя FedFed.

Может попробовать man mount.ntfs-3g ?

0
Жюстина - 13 Сентябрь, 2010 - 17:37
Изображение пользователя Жюстина.

а бывает такое что /etc/default/grub на разделе ntfs??? O_o

0
FedFed - 13 Сентябрь, 2010 - 18:23
Изображение пользователя FedFed.

Не знаю)

0
FedFed - 13 Сентябрь, 2010 - 20:55
Изображение пользователя FedFed.

Удалось сделать через загрузчик ГРАБа. Не помогло.

0
dyug - 13 Сентябрь, 2010 - 21:07

гмм, кажется я рекомендовал это именно так и сделать (через загрузчик), а можно узнать конкретно и по шагам что именно делалось, и как именно делалось?

Ибо у всех - работает, а у тебя нет, есть мнение, что ты что то сделал неправильно...

0
FedFed - 13 Сентябрь, 2010 - 23:48
Изображение пользователя FedFed.

Вышел в редактор в загрузчике. К указанной строке приписал нужные слова. Нажал Сtrl+X. No result.

0
dyug - 14 Сентябрь, 2010 - 09:08

тогда я не знаю.
возможно или не та проблема, или что то все же делается не так.
Смотреть надо физически.

0
FedFed - 15 Сентябрь, 2010 - 16:00
Изображение пользователя FedFed.

Сорри за оффтоп, но засорять форум лишней пустяковой теомй не хотелось. Я решил попробовать решить проблему, поставив последний АТИшный драйвер к видюхе. он у меня на флешке. Никто не мог бы подсказать, как это действие выполнить из командной строки (конкретно интересует адрес флешки по умолчанию)?

0
dyug - 15 Сентябрь, 2010 - 16:11

по умолчанию, если у тебя один винт, то должен быть /dev/sdb1 если есть картридер то скорее всего sdc1

Если у тебя видео НЕ соответсует списку поддерживаемых то и ставить не имеет смысла. причем совсем.
Проверь это по сайту.

0
FedFed - 15 Сентябрь, 2010 - 16:20
Изображение пользователя FedFed.

Списку поддерживаемых чем? Если драйвером - то моя видюха в списке.
USB флешка я имею в виду, не карточка)
ЗЫ Моя видюха: ATI Mobility Radeon HD 3650.

0
Жюстина - 15 Сентябрь, 2010 - 16:25
Изображение пользователя Жюстина.

sudo fdisk -l ---- оно покажет список накопителев с разделами, вот там легонько можно найти похожее на флешку, по размеру и по фс. Карточка поддерживается в проприетарных драйверах.

0
FedFed - 15 Сентябрь, 2010 - 17:17
Изображение пользователя FedFed.

Нашел. /dev/sdb1
Для проверки sudo cd /dev/sdb1 отвечает Not a directory. Странно. Пробовал добавлять / в конце - то же самое.

0
dyug - 15 Сентябрь, 2010 - 18:03

это а кто будет монтировать флешку то?
средства автоматизации КДЕ не запущены же...

0
knuckles - 15 Сентябрь, 2010 - 18:04
Изображение пользователя knuckles.

Это просто файл устройства. Его еще примонтировать надо:
sudo mount /dev/sdb1 /путь/куда/монтировать

0
FedFed - 15 Сентябрь, 2010 - 18:29
Изображение пользователя FedFed.

РАБОТАЕТ! Запишите, пожалуйста))) Драйвер версии 10.8 работает.

0
FedFed - 15 Сентябрь, 2010 - 18:37
Изображение пользователя FedFed.

Спасибо всем большое за советы.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры