Проблема с установкой kubuntu-10.04-dvd-amd64 на Lenovo X100e

Ставлю на ноут Lenovo X100e (конфигурация http://www.ixbt.com/portopc/lenovo-x100e.shtml) с 4гиговой флешки сделанной unetbootin-windows-471, так как сидирома в комплекте нет. Никакой операционной системы на нем небыло изначально. Если выбираю в меню UNetbootin Default, то недолго думая комп любезно выдает мне

ALERT! does not exist/ Dropping to a shell!

BusyBox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu11) built-in shell (ash)
Enter 'help' for a list of build-in commands.

(initramfs)_

Если в меню UNetbootin выбираю Install - после выбора языка пытается настроить сеть с помощью DHCP, с чем естественно обламывается ввиду отсутствия оной, после чего, как ни странно, к локальному зеркалу подключится у него не выходит, и я оказываюсь в главном меню программы установки Ubuntu. Среди непройденных мною пунктов установки, по порядку: выбор зеркала архива Ubuntu, загрузка компонентов программы установки, изменение уровня важности debconf, сохранение файлов журнала с отладочной информацией, запуск оболочки, отмена установки.

Как начать правильно установку?

0
kolodyazhnyj - 21 Сентябрь, 2010 - 15:32

http://www.ubuntu.com/desktop/get-ubuntu/download Второй пункт - создание загрузочной флешки. Может попробовать стандартными средствами от ubuntu?

0
Agat - 21 Сентябрь, 2010 - 16:47

Спасибо, действительно, с офицального загрузщика ставится вообще без проблем, и очень быстро! Но теперь новая проблема: вовремя загрузки, сразу с появлениек курсора, появляется на синем фоне кубунты окно с изображением в центре слева жосткого диска (никаких подписай), держится секнд 5, потом черный экран (курсор мыши остается), в течении секунд 15 мышю еще можно двигать, а затем полное зависание. Подскажите, пожалуйста, что с этим делать. Спасибо.

0
Mike - 21 Сентябрь, 2010 - 16:54
Изображение пользователя Mike.

пробуй ставить не с графического установщика, а с текстового. там в комплекте есть.

0
Agat - 21 Сентябрь, 2010 - 17:18

Кстати, при попытке загрузить кубунту с флешки очень похожая проблема: появляется такое-же окно с изображением жосткого диска, курсор, котормым можно секунд 10 поёрзать, а затем зависание. Без чёрного экрана, прямо на синем, но в целм очень похоже.
В инсталлере кубунты есть такие пункты: Run Kubuntu from this USB (что происходит - абзац выше); Install Kubuntu on Hard Disk (то, что было сделанно ранее); Test memory; Boot from first hard disk; Advanced options (в этом меню пусто); Help. После выбора установки возможности перейти в консольный режим не видел: сразу выбор языка, расположения, менеджер жосткого диска и автоматическая установка. Если выйти из установщика появляется тот же синий экран с тем же окном, но зависает еще даже до того, как картинка жесткого диска приобретает фокус (она анимированая).

0
kolodyazhnyj - 21 Сентябрь, 2010 - 17:19

вовремя загрузки, сразу с появлениек курсора, появляется на синем фоне кубунты окно с изображением в центре слева жосткого диска (никаких подписай)
Нажми Alt+Ctrl+F1, введи логин, пароль и набери команды:
sudo aptitude update && sudo aptitude upgrade
Когда обновится:
sudo reboot
Может баг какой и обновление поможет.

0
Agat - 21 Сентябрь, 2010 - 18:04

Выполнил команды (что то выполнилось, хотя ноут к нэту не подключен), но теперь совсем странная фигня: в графическом интерфейсе не принимает пароль! В текстовом - все ок, а вграфическом никак. Пароль 123, так что ошибится точно немогу :) Поидеи заветный зависающий экран должен быть после логина, так что пока сказать помогло-ли, не переставляя систему без пароля, не могу. Кстати, за это время уже 2 раза переставил систему, и оба раза не логинится в графическом интерфейсе

0
kolodyazhnyj - 21 Сентябрь, 2010 - 18:11

Без подключения к интернету это было бессмысленно делать...

Зачем переставлять систему по 100 раз? Так проблема не решится. Попробуй то, что я в следующем посте написал.

0
kolodyazhnyj - 21 Сентябрь, 2010 - 17:39

А видеокарта радеон? Попробуй во время загрузки (когда у тебя синий экран с курсором появится) нажать Alt+Ctrl+F1, потом:
sudo nano /etc/default/grub
и замени строчку:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
на:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"
Сохранени изменения и:
sudo update-grub && sudo reboot

0
Agat - 21 Сентябрь, 2010 - 18:21

Выполнил. Теперь после надписи kubuntu с 5ю точками выкинуло сразу в текстовую консоль с предложением ввести логин и пароль. Прежде чем я успел это сделать оно очистело экран и вывело

fsck from util-linux-ng 2.17.2
/dev/sda1: clean, 94171/14934016 files, 1511285/59733760 blocks
* Starting AppArmor profiles [OK]
* Setting sensors limits [OK]
* Starting Common Unix Printing System: cupsd [OK]
* Cecking battery state... [OK]

Чуть ниже потом помигал курсор ввода, не ввобд не реагируя, потом пропал и он. На этом наглухо и завис.

Upd. Даже если успеваю залогинится за 3 секунды, через 2 всеравно выкидывает такое же сообщение

0
Жюстина - 21 Сентябрь, 2010 - 18:40
Изображение пользователя Жюстина.

acpi=off а оно от этого не перестанет выключаться по требованию, а то операционная система то выключится а компутер будет продолжать работать, acpi разве не этим заведует? (ну там ещё и другое есть важное)

0
kolodyazhnyj - 21 Сентябрь, 2010 - 19:01

Этим, и еще управлением питанием, энергосбережением и прочим...

Надо попробовать разные опции загрузки и посмотреть, что из этого выйдет. Система установилась без ошибок, загружается, но ни в live режиме, ни в установленном виде не заходит в графический режим - значит в сторону видеокарты надо копать :)

0
kolodyazhnyj - 21 Сентябрь, 2010 - 19:05

А если не
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off",
а
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"?

0
Agat - 21 Сентябрь, 2010 - 19:48

Похоже предидущее действие навернуло систему серьезно. Теперь даже в консольный режим невойти. Переставил систему. Интересный нюанс: если я загружаю консоль, то через некоторое время издается звук похожый на загрузку системы. Как выйти из консоли и посмотреть что там? :) Хотелось бы попробовать прежде чем снова что то менять

0
Agat - 21 Сентябрь, 2010 - 19:56

Изменил эти параметры. По большому счету ничего не изменилось. В переустановленной версии отключил пароль, так что система снова виснит на том же месте, только чуть раньше: меньше чем за секунду экрана с изображением жосткого диска, так что он даже не успевает войти в фокус

0
kolodyazhnyj - 21 Сентябрь, 2010 - 20:22

чтобы выйти из консоли в графический режим - Alt+F7.

0
kolodyazhnyj - 21 Сентябрь, 2010 - 20:23

Кстати, вот такая вот трабла.
Можешь конечно попробовать поставить новое ядро, или установить драйверы, но... Из консоли, думаю это будет тяжеловато. Так что лучше подожди 10 октября - kubuntu 10.10 с нужным ядром (см. ссылку выше) подоспеет. А пока лучше почитай про установку (в особенности про разбиение hdd), настройку системы, чтобы потом иметь представление о том, что установил и как с этим работать :)

0
Agat - 21 Сентябрь, 2010 - 21:21

Я правильно понимаю, 2.6.35rc2 ядро появилось после выпуска 10.04 убунты, и оно, или более новое, будет вместе с нужным драйвером входить в 10.10?

0
kolodyazhnyj - 21 Сентябрь, 2010 - 21:39

Да, в 10.10 будет ядро 2.6.35 с нужным тебе драйвером. Наверно :)

0
Agat - 21 Сентябрь, 2010 - 21:26

Что-ж, большое спасибо за помощь, придется переждать на винде, слава болгу осталось не долго :) Надеюсь вся эта длинная ветка сможет еще кому то помочь, и сэкономит время учасников. Но, насколько я понимаю, зависание из-за драйвера, это описанное мною последнее зависание в консоли, а в графической системе причина, возможно, и другая, с учетом того, что до смены конфигурации файла консоль работала нормально, верно?

0
kolodyazhnyj - 21 Сентябрь, 2010 - 21:53

Можешь пока попробоать бета версию - ядро там уже новое. На предмет работает - не работает.

0
Voyageur - 21 Сентябрь, 2010 - 22:12
Изображение пользователя Voyageur.

Если очень хочется попробовать, то можно скачать бета-версию 10.10, она, говорят, вполне рабочая))
Отсюда

0
Agat - 22 Сентябрь, 2010 - 00:34

А какой программой этот образ можно загнать на флешку?

0
Agat - 21 Сентябрь, 2010 - 21:31

Кстати, а если отключить аккомулятор, и работать только от сети, то все должно работать?

0
kolodyazhnyj - 21 Сентябрь, 2010 - 21:55

Несчего ему работать. ACPI данной модели пока не поддерживается. Грубо говоря, ОС не может нормально общаться с BIOSом компьютера.

0
knuckles - 22 Сентябрь, 2010 - 07:01
Изображение пользователя knuckles.

Ребята, объясните для не очень умных, при чем здесь acpi, если зависание происходит только после логина в kdm? Было бы дело в ACPI, он бы даже экран заставки не показал.

0
kolodyazhnyj - 22 Сентябрь, 2010 - 22:01

В принципе да, но гугл показал вот это.

0
knuckles - 23 Сентябрь, 2010 - 07:21
Изображение пользователя knuckles.

:-) Интересный пост.
Автор пишет, что дело в acpi, а потом в конце допиcывает, что acpi=off не помогает (из чего, собственно, следует, что дело не в acpi).

0
kolodyazhnyj - 23 Сентябрь, 2010 - 09:27

:) Ступил я, собственно.

0
knuckles - 23 Сентябрь, 2010 - 09:50
Изображение пользователя knuckles.

:-) Все равно новое ядро, видимо, нужно.

0
knuckles - 22 Сентябрь, 2010 - 07:49
Изображение пользователя knuckles.

Agat, раз появляется курсор мыши, значит иксы успевают загрузиться (а потом подвисают). Загрузись в консоли, посмотри файл /var/log/Xorg.0.log - возможно, это прояснит ситуацию.

0
Agat - 22 Сентябрь, 2010 - 14:35

В этом файле более 600 строк. Какая часть нужна, или как его на флешку скопировать? И в целом, вопрос как загнать бэту 10.10 на флешку все еще открыт...

0
knuckles - 22 Сентябрь, 2010 - 15:50
Изображение пользователя knuckles.

надо строки с пометкой (EE).

0
Agat - 22 Сентябрь, 2010 - 16:04

Ни одной строки с такой пометкой. Два раза проверил.

0
knuckles - 23 Сентябрь, 2010 - 07:22
Изображение пользователя knuckles.

Ну, тогда не знаю. Придется грызть кактус...

0
knuckles - 23 Сентябрь, 2010 - 07:54
Изображение пользователя knuckles.

Да любой программой, которая умеет загрузочные образы на флэшки писать. 10.04 как загонял? также и 10.10 загони :-)

0
Agat - 23 Сентябрь, 2010 - 08:15

Не одна из этих прог версию 10.10 не поддерживает. Или можно загонять как 10.04, и никакой разници? Более старые версии все отличаются.

0
knuckles - 23 Сентябрь, 2010 - 09:16
Изображение пользователя knuckles.

Что это за проги такие, которые от версии Кубунту зависят? O_o Попробуй загони как 10.04, а вообще надо прогу, которая просто пишет загрузочный образ на флэшку - любой образ.

0
Agat - 23 Сентябрь, 2010 - 10:22

Записав Universal-USB-Installer-1.7.9.8 как 10.04 зависает после первого же экрана со строчкой

SYSLINUX 3.86 2010-04-01 EBIOS Copyright (C) 199402010 H. Peter Anvin et al

Попробую поискать еще что-то...

0
knuckles - 23 Сентябрь, 2010 - 10:33
Изображение пользователя knuckles.

Что еще за Universal-USB-Installer-1.7.9.8? :-)
Делай лучше, как Каноникал говорит:
1. Идешь сюда и качаешь нужный ISO-образ.
2. Идешь сюда и записываешь скачанный образ на флэшку, как там написано (инструкция как сделать это в Винде даже есть!).

0
Agat - 23 Сентябрь, 2010 - 10:49

Universal-USB-Installer-1.7.9.8 - это "стандартное средство от ubuntu" (2 пост), а unetbootin я пользовался в самом начале, в нем тоже есть деление на версии и при попытке установить с него ему требуется доступ к интернету (по крайней мере с 10.04 так было), о чем я писал в самом первом посте. Сейчас пробую UltraISO 9.3.2 в режиме USB-HDD+ (без понятия, правда, чем он отличается от USB-HDD и еще двух других :) )

Upd. А, еще образ я брал отсюда http://cdimage.ubuntu.com/kubuntu/daily-live/current/ . Там обновление 22 сентября, если это имеет значение...

0
knuckles - 23 Сентябрь, 2010 - 10:59
Изображение пользователя knuckles.

Понятно :-)
Я из-под Винды этого никогда не делал, поэтому и не в курсе...

UPD: сам предпочитаю ставить систему с варианта alternate. Имхо, надежнее)

0
Agat - 23 Сентябрь, 2010 - 11:07

UltraISO - та же фигня, только у него SYSLINUX 3.84 2009-12-18 - более старый. Попробую alternate CD и unetbootin. В описании alternate написано, что установка без нэта - как особенность релиза. Может сработает... но всеравно как 10.04 ставить придется :(

0
knuckles - 23 Сентябрь, 2010 - 11:13
Изображение пользователя knuckles.

А CD-ROM есть? Может, лучше с балванки?

0
Agat - 23 Сентябрь, 2010 - 11:14

Не, CD-ROM нет, иначе бы уже давно так сделал :(

0
Agat - 23 Сентябрь, 2010 - 11:13

А может его попытатся записать как Daily CD Images? Там выбор версий
# Ubuntu (and official derivatives)

* 6.06 LTS
* 6.10
* 7.04
* 7.10
* 8.04 LTS
* 8.10
* 9.04
* 9.10
* 10.04
* Daily CD Images

Это как раз инсталяция для дорелизной версии?

0
knuckles - 23 Сентябрь, 2010 - 11:44
Изображение пользователя knuckles.

Это как раз инсталяция для дорелизной версии?
Ага)

0
Mike - 23 Сентябрь, 2010 - 14:27
Изображение пользователя Mike.

unetbootin я пользовался в самом начале, в нем тоже есть деление на версии и при попытке установить с него ему требуется доступ к интернету (по крайней мере с 10.04 так было)
Мущщина, не надо грязи! доступа к инету ему не надо, да и вообще ему похер на то, что ты через него заливаешь. Скачивай образ нужной бунты, в унетбутине ставишь точку во втором пункте (образ диска), скармливаешь образ, жмешь на ОК, и ВСЁЁЁ! больше ничего не надо!

Если в процессе установки с флешки возникнут проблемы, типа не находится CD-ROM, пользуешься поиском по форуму, без проблем находишь вот эту тему, делаешь все по инструкции и ставишься.

0
Agat - 24 Сентябрь, 2010 - 11:15

Да, Вы хорошо предугадали, вторая проблема как раз воззникла :) Только что значит "в строке с параметром ядра"? Там во втором пункте только адрес образа диска указать можно. А "во время" записи образа вообще никакие функции не доступны. Как к нему прописать еще и какие либо параметры к ядру?

0
Mike - 24 Сентябрь, 2010 - 11:44
Изображение пользователя Mike.

а после "записи" открыть содержимое флешки и ручками поправить нужный файл - нэ?

0
Agat - 24 Сентябрь, 2010 - 13:09

во время записи образа на флешку посредством программы unetbootin в строку с параметром ядра прописать:
cdrom-detect/try-usb=true

-это как сделать? Если в готовом образе править, то какой файл?

Upd. Дописывание во время выбора установки kubuntu через Tab строки cdrom-detect/try-usb=true ничего не изменило :(

0
Mike - 24 Сентябрь, 2010 - 15:46
Изображение пользователя Mike.

для особо альтернативно одаренных объясняю еще раз и пошагово:
1) запускаешь унетбутин
2) скармливаешь ему образ кубунты
3) нажимаешь на ОК
4) Ждешь
5) по окончании закрываешь унетбутин
6) открываешь флешку любым доступным файловым менеджером
7) находишь на флешке файл syslinux.cfg
8) открываешь этот файл любым достумным текстовым редактором
9) ищешь внутрях пункт label unetbootindefault
10) ищешь чуть ниже append initrd=...
11) в этом пункте дописываешь, чтобы получилось: append initrd=/ubninit vga=normal cdrom-detect/try-usb=true -- quiet
12) сохраняешь
13) грузишься с флешки
14) в меню загрузчика выбираешь пункт default
15) если по какой-то причине установщик не хочеть и дальше принимать флешку за сидюк, попробовать подправить какой-нибудь другой пункт и загрузиться потом с него.

0
Agat - 25 Сентябрь, 2010 - 14:29

Вообщем добавление этих параметров и вкривь и вкось ничего не меняют: всравно не может найти сидиром. Может еще как-то можно на это повлиять?

0
Mike - 25 Сентябрь, 2010 - 15:37
Изображение пользователя Mike.

увы, если и это не помогло, то боюсь, что медицина тут уже бессильна :(
когда у меня были проблемы с установкой с флешки, помог именно этот метод.

0
Agat - 25 Сентябрь, 2010 - 18:53

Всеравно спасибо. Значит подожду 10.10

0
kolodyazhnyj - 24 Сентябрь, 2010 - 22:02

Мда... долгая тема получилась... И ведь все это гуглится за 5 минут...

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры