не работает микрафон

Здравствуйте.
[email protected]:~$ uname -a
Linux main 2.6.32-25-generic #45-Ubuntu SMP Sat Oct 16 19:52:42 UTC 2010 x86_64 GNU/Linux

Установлен и настроен PulseAudio. Где искать решение?

0
Vlad_W_1999 - 2 Ноябрь, 2010 - 17:14

Брат! Та же самая железка и те же проблемы. Стало быть, так. Есть такая штука, которую зовут alsamixer. Ставишь, если у тебя её нету. Запускаешь её в консоли. Интерфейс там очевиден, да и подсказки на русском есть. Ведёшь стрелкой вправо до надписи (она может быть за границей экрана -- не стесняйся, консоль просто не может показать слишком много по горизонтали, так что если не увидишь на экране, то смело продолжай нажимать стрелку вправо и тебе откроются новые пункты) над ней будет написано 2ch. Стрелкой вверх (появится 4ch и раздастся щелчок в динамиках). Стрелку вниз, что бы опять было 2ch. После этого у меня микрофон заводится.

Но вообще это не дело и необходимо поиграться с корректным определением твоей аудиокарточки. С этим в поиск. Могу сказать только, что ключевыми словами для поиска есть snd-hda-intel. Честно скажу -- у меня воспитать мою железку не получилось. Если получится у тебя, то отпишись как и что ты сделал.

0
Vlad_W_1999 - 2 Ноябрь, 2010 - 17:16

Да, вывод lspci под кат спрячь. Кнопочка "CL" над окном редактирования. Там, думаю, сам разберёшься.

0
GHopper - 2 Ноябрь, 2010 - 17:35

alsamixer тыкал, но безрезультатно. После этого поставил PulseAudio, а с ним alsamixer уже бесполезен. Сейчас поковыряю, да может назад откачу на alsa.
Спасибо за советы )

+1
Vlad_W_1999 - 2 Ноябрь, 2010 - 17:38

Не скажи! У меня PulseAudio установлен, но alsamixer вполне заводится и делает то, что я описал. Так что пробуй! И в любом случае отпишись -- получилось, или нет.

0
GHopper - 2 Ноябрь, 2010 - 17:56

Ага. В alsamixer выбрал звуковое устройство HDA Nvidia и все эти настройки появились. Только вот при изменении Channel щелчка не раздается и микрофон не заводится (

0
Pavel Belg - 3 Ноябрь, 2010 - 00:17
Изображение пользователя Pavel Belg.

Как ни странно но Вы не в одиночестве.

Как решил эту проблему я?
Всё просто: sudo apt-get install aumix-gtk
И покрутите там. Там наверняка найдётся PCM2 который надо будет потянуть вверх....
Удачи!

0
ka99 - 3 Ноябрь, 2010 - 03:39

Попробуйте установить пакет pavucontrol и там включить микрофон

0
GHopper - 3 Ноябрь, 2010 - 06:11

aumix-gtk поковырял - безрезультатно. PCM2 есть.

Микрофон включен. Сигнала нет.

0
dyug - 3 Ноябрь, 2010 - 13:32

Микрофон встроенный?
Не эта грабля?
Проверьте, вдруг?

Сам был в шоке, когда заработало. :-(

0
GHopper - 4 Ноябрь, 2010 - 17:21

У меня десктоп. Микрофон втыкаю в разъем на задней панели. Само собой все рабочее.

Систему ставил года четыре назад. Раньше, когда еще увлекался линуксом, эту граблю решал установкой PulseAudio и кручением чего-то там (не помню уже). Побаловался скайпом и забросил. Вот теперь снова возникла необходимость. Пробовал сносить PulseAudio, ставил заново, бегунки и галочки тыкать - не помогло. Тыкался-мыкался и забил. Ну, думаю, нафига мне этот линукс, когда я кроме как броузер ничего не юзаю. Поставил пинду, завел скайп, тру по вечерам с разъехавшимися друзьями... но не покидает чувство неполноценности! Привык блин к линухе. К рабочим столом, к переключению раскладки по капсу, к красивым визуальным эффектам, к софту... Вот ведь как бывает! Вернулся в кубунту ))

0
ka99 - 5 Ноябрь, 2010 - 03:15

У меня с переходом на 10.10 была проблема с микрофоном, оказывается в окошке pavucontrol микрофоны были отключены, нажал нужную кнопочку(скриншот прилагаю) и микрофон ожил.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры