Камера на asus k52jr

Всем привет)))возникла тут проблема небольшая,вебкой пользуюсь не часто но приходится....проблема в том что изображение перевернуто,изгуглил все ни одно решение не помогло(вебка нажна для скайпа)...может кто поможет

[email protected]:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 13d3:5094 IMC Networks
Bus 001 Device 004: ID 0b05:1751 ASUSTek Computer, Inc. BT-253 Bluetooth Adapter
Bus 002 Device 003: ID 09da:000e A4 Tech Co., Ltd

uname -a
Linux kvert-K52 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

да и много тем видел что делается сдедующие:

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so mplayer tv://
но получаем вот что
ERROR: ld.so: object '/usr/lib32/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.

и еще заметил странность не существует библиотеки в lib/libv4l,только в /lib32/libv4l/
как это поправить,как я понимаю в системе стоят только 32х разрядные библиотеки,а мне 64 нуно....
при sudo apt-get install libv4l-0 установка идет...по идеии система автоматом должна загрузить библиотеки для 64х но почему то lib/libv4l не появляется

0
gThumb - 22 Ноябрь, 2011 - 15:50
Изображение пользователя gThumb.

Один к одному твоя ситуация и камера точно такая, бук правда ASUS P81IJ.
На прошлых системах / ядрах все гуд было, в смысле:
LD_PRELOAD=/opt/lib32/usr/lib/libv4l/v4l1compat.so skype
работало без проблем.
Похоже дело в выключенных модулях ядра...
Вот тут http://www.calculate-linux.org/boards/16/topics/5803 я нашел такое:
Вопрос, есть ли смысл пересобрать ядро,с новыми параметрами(ведь камера работает и в других приложениях даже правильно работает) добавив # CONFIG_VIDEO_ALLOW_V4L1 is not set, если есть смысл то как лучше включить Y или M ?
Если я правильно понимаяю - ядро пересобирать с собственными параметрами надо чтоб skype включить....

Но это пол беды, у тебя светодиод камеры при старте системы или при подключении USB устройств автоматом не запускается? У меня загорается и горит в пол накала....
Эта проблема затронута тут http://forum.ubuntu.ru/index.php?topic=163313.0, и пока без ответа....

0
Kverter007 - 23 Ноябрь, 2011 - 19:29

Привет,мне кажется вся трабла в libv4l,потому что 32х используется а 64х почему то нету....

0
gThumb - 26 Ноябрь, 2011 - 17:32
Изображение пользователя gThumb.

~$ uname -a
Linux P81IJ 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:34:47 UTC 2011 i686 i686 i386 GNU/Linux

т.е. как бы 32х, а беда та же....

А еще. Ты название темы поменять можешь?
Для поисковиков правильнее было бы назвать страничку "Проблемы с веб-камерой (ID 13d3:5094) на asus k52jr в Kubuntu 11.10".
Больше посетителей - больше надежды на правильное решения проблемы.

0
gThumb - 13 Декабрь, 2011 - 18:42
Изображение пользователя gThumb.

В Kubuntu 11.10 (32х разрядная) я запустил skype через команду:
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

Для 64х разрядной я думаю надо поискать v4l1compat.so в соответствующих директориях.

Отправить комментарий

CAPTCHA на основе изображений
Введите цифры