Появился первый Daily Build Kubuntu 17.04 (Zesty Zapus)

Как обычно на традиционном месте.

Завтра там уже будет второй, и так далее, поэтому для истории зафиксируем дату и время:
zesty-desktop-amd64.iso       26-Oct-2016 05:51  1.5G  Desktop image for 64-bit PC (AMD64) computers (standard download)
zesty-desktop-i386.iso        26-Oct-2016 05:53  1.5G  Desktop image for 32-bit PC (i386) computers (standard download)

Интересно, найдутся у кого-либо предположения почему именно сегодня, а не 14-16 октября?

+1
Fogma - 26 Октябрь, 2016 - 16:02
Изображение пользователя Fogma.

Жесть какое название дистра

0
Гость - 26 Октябрь, 2016 - 17:20

Мышь под соусом?

0
kot040188 - 26 Октябрь, 2016 - 19:11
Изображение пользователя kot040188.

Последний…

0
denkin - 26 Октябрь, 2016 - 19:28
Изображение пользователя denkin.

потому что разрабы всегда отдыхают неделю-две после релиза
собственно пока репозиторий zesty не что иное, как "синхрон" пакетной базы для 16.10
активная стадия разработки начнется, по традиции, аж после рождества.

0
AlexBKost - 26 Октябрь, 2016 - 22:26

Неделю-две говорите? Да нет, предыдущий опыт этого не подтверждает (равно как и более ранние). После релиза Kubuntu 16.04 21 апреля первый Daily Build Kubuntu 16.10 появился 24 апреля. Отгадка таится в другом, дадим шанс другим посетителям им воспользоваться.

0
AlexBKost - 27 Октябрь, 2016 - 13:22

На этот раз решил обновиться консольно из 16.10:
sudo sed -i 's/yakkety/zesty/g' /etc/apt/sources.list
sudo apt update
sudo apt dist-upgrade

Всё, нет у меня больше 16.10, НЕТУ. Зато 17.04 уже имеется:

чего и всем желаю.

+1
lord_i - 27 Октябрь, 2016 - 18:56
Изображение пользователя lord_i.

16.10 кишит глюками ... А это наверное для совсем отважных :)

0
AlexBKost - 27 Октябрь, 2016 - 23:06

Глюки? Например...

0
lord_i - 28 Октябрь, 2016 - 00:00
Изображение пользователя lord_i.

Буквально вчера столкнулся - панель задач перестает показывать все что на ней есть если в момент манипуляций с сетевыми подключениями пропадает интернет. В моем случае был вынут патчкорд. И все... Пока его не вставишь (пока не появится интернет) панель задач пустая...
Или вот - окна гостевой системы виртуалбокса в режиме интеграции экрана принудительно выводятся поверх окон хоста - невозможно работать с окном хоста пока не свернешь все окна гостевой...

0
AlexBKost - 28 Октябрь, 2016 - 00:57

Ну, вы уже знаете, что с 16.10 я простился навсегда, а на 17.04 ваши глюки мне воспроизвести не удается.

0
kot040188 - 27 Октябрь, 2016 - 19:00
Изображение пользователя kot040188.

чего и всем желаю.
За что вы так нас ненавидите?

0
AlexBKost - 27 Октябрь, 2016 - 23:05

Почему? Наоборот, я вас всех нежно, по-товарищески люблю.

0
kot040188 - 27 Октябрь, 2016 - 23:26
Изображение пользователя kot040188.

Где-то очень глубоко в душе…

0
Гость - 27 Октябрь, 2016 - 13:55
0
kot040188 - 27 Октябрь, 2016 - 23:27
Изображение пользователя kot040188.

Печально…

0
AlexBKost - 27 Октябрь, 2016 - 23:28

Если эта фотка собственная, тогда примите соболезнования.

+2
AlexBKost - 21 Декабрь, 2016 - 03:35

Plasma 5.8.4 из основного репозитория. Обратите внимание на версию ядра, кого это беспокоит.

0
Slavyanin - 21 Декабрь, 2016 - 12:34

Не, не верю. Юмор.

+2
AlexBKost - 21 Декабрь, 2016 - 19:32

От чего же?

Вы не в церкви, вас не обманут (С)

0
AlexBKost - 30 Декабрь, 2016 - 02:38

Начала заходить Plasma 5.8.5, что интересно - с тех же пакетов (полного соответствия, конечно, нет но очень похоже), что и 5.8.4, которая заходила в период 08.12-21.12.2016. Посмотрим, как быстро с новой управятся.

PS: Большой привет всем сидящим на Kubuntu 16.04.1 с плазмой из неона.

0
MacLeod - 30 Декабрь, 2016 - 11:07
Изображение пользователя MacLeod.

Ага, сидящим на никем не поддерживаемой альфе - тоже большой превед =)

0
dyug - 30 Декабрь, 2016 - 11:46

Спасибо за привет, но уже 5.8.5 вчера пришла. Во всяком случае, мне пришла точно. :-)
[email protected]:~$ kwin --version
kwin 5.8.5

cat /var/log/apt/history.log

0
AlexBKost - 30 Декабрь, 2016 - 15:41

И у меня тоже дошла - управились за два захода, но в одни сутки:

Только, вы же понимаете в чем разница между нашими плазмами, моя из основного репозитория, который MacLeod выше обозвал никем не поддерживаемым.

0
dyug - 30 Декабрь, 2016 - 17:00

Ну понимаешь, формально то он прав, это может быть сломано минимум до апреля 17 года и не один раз. И никто не обещает, что будет работать. :-)

Нет, я не понимаю, в чем разница этих плазм.
учитывая, что я не знаю, кто собирает, и на каких условиях плазму для "основного репозитория"

0
AlexBKost - 30 Декабрь, 2016 - 19:16

это может быть сломано минимум до апреля 17 года и не один раз. Если сломается, я сообщу в этой же теме, мне покрывать кого-то нет никакого резона.

+4
MacLeod - 6 Январь, 2017 - 06:00
Изображение пользователя MacLeod.

У меня есть сомнения, что данный пост вытащит вас из бронепоезда, в котором вы забаррикадировались, но, как минимум, он поможет остальным понять, где вы вводите их в заблуждение.

Допустим, я беру и пишу простейший код с использованием Qt:
#include <QDebug>

int main(int argc, char *argv[])
{
    qDebug() << "привет, мир!" << endl;

    return 0;
}

Далее делаю коммит (простым языком - закачиваю исходник) в пустой Git репозиторий, называю его "начальный коммит".

Дописываю еще одну строчку, получаю:
#include <QDebug>

int main(int argc, char *argv[])
{
    qDebug() << "привет, мир!" << endl;
    qDebug() << "теперь я - плазма 5.8.5" << endl;

    return 0;
}

Делаю коммит с комментарием "плазма версия 5.8.5", называю ветку "версия 5.8.5", создаю новую ветку с названием "версия 5.9" и продолжаю добавлять новые фичи туда. Неважно сколько и неважно как, ветка "версия 5.8.5" остается нетронутой.

Теперь я буду запускать эту свою "плазму" на различных дистрибутивах. Очевидно, что моя "плазма" использует Qt, поэтому перед сборкой первой мне нужно установить Qt и его dev-файлы.

Для 14.04 - я ставлю штатный Qt 5.2.1, скачиваю свою "плазму" ветку "версия 5.8.5" (получаю исходник, указанный выше), собираю, запускаю.

Для 16.04 - я ставлю штатный Qt 5.5.1, скачиваю свою "плазму" ветку "версия 5.8.5" (получаю исходник, указанный выше), собираю, запускаю.

Для набора deb-пакетов под кодовым названием 17.04 - я ставлю штатный Qt 5.6.1, скачиваю свою "плазму" ветку "версия 5.8.5" (получаю исходник, указанный выше), собираю, запускаю.

На любом нахрен другом дистрибутиве - я ставлю версию Qt 5.x.x, скачиваю свою "плазму" ветку "версия 5.8.5" (получаю исходник, указанный выше), собираю, запускаю.

Для особо одаренных повторюсь: во всех случаях я собирал следующий код "плазмы":
#include <QDebug>

int main(int argc, char *argv[])
{
    qDebug() << "привет, мир!" << endl;
    qDebug() << "теперь я - плазма 5.8.5" << endl;

    return 0;
}

"Плазма" с ветки "версия 5.8.5", собираемая на 14.04, ровно такая же "плазма", как на 16.04. Байт в байт. Ровно этот же исходник я использую, если решу собрать бинарики и положить их в репозиторий, который назову backports, neon или даже my_super_puper_plasma.

Реальная плазма на kde.org версионируется схожим образом. Если любой Вася или Петя решит собрать себе или опакетить плазму, выкачав определенную версию исходников, он получит ровно тот функционал, который накодили в ветке с указанной версией. Байт в байт.

основного репозитория, который MacLeod выше обозвал никем не поддерживаемым
Основного репозитория пока еще несуществующего дистрибутива, который реально еще никем не поддерживается. Что фактически означает: производители стороннего софта не собирают пакеты и не делают репозитории/ppa для данной версии.
Одно дело - сидеть и фапать на циферки версий плазмы и как туда что-то "заходит", другое - использовать его для работы/выполнения своих задач.

+1
Slavyanin - 6 Январь, 2017 - 08:22

Кармы нет, но плюс ставлю.

0
AlexBKost - 6 Январь, 2017 - 18:10

И вам плюс, только возможности мои не безграничны для вашей кармы.

0
Slavyanin - 7 Январь, 2017 - 09:59

Так плюс то уважаемому MacLeod , а не Вам.

0
AlexBKost - 7 Январь, 2017 - 16:16

Я вижу, что щедрости ему не хватило, надеюсь только пока.

0
AlexBKost - 6 Январь, 2017 - 17:58

У меня есть сомнения, что данный пост вытащит вас из бронепоезда, в котором вы забаррикадировались, но, как минимум, он поможет остальным понять, где вы вводите их в заблуждение. Если мне удалось кого-то ввести в заблуждение, то прошу простить милосердно, в том числе и вас, ув. MacLeod, ибо я себя в бронепоезде не ощущаю - исключительно в литерном поезде, из которого у меня нет потребностей приветствовать мир, как, впрочем, и приветствий от мира я не жду. Вот если-бы вы назвал меня сидящим в танке, тогда ... День танкиста мой любимый праздник, после Нового Года.

производители стороннего софта не собирают пакеты и не делают репозитории/ppa для данной версии. Я и сам хотел бы узнать откуда тогда берутся пакеты новых версий в "не поддерживаемом репозитории 17.04", как, например, Kaffeine.

Одно дело - сидеть и фапать на циферки версий плазмы и как туда что-то "заходит", другое - использовать его для работы/выполнения своих задач. Тут у всех разные задачи и работа разная. И я тоже просто рассказываю читающим о происходящем, типа "привет, мир!". Не ходя далеко, ещё приведу пример из ссылки про Kaffeine. В той теме также упоминался XawTV - попробуйте попользоваться XawTV из стабильного репозитория 16.04 и не поддерживаемого 17.04 - прочувствуете разницу.

Теперь о плюсах. Вы мне когда-то уже сообщали, что на форуме народ на плюсы не жадный (сейчас лень искать ту точную фразу). Я сегодня тоже проявлю щедрость по-максимуму, особенно для нуждающихся в поднятии кармы, лишний раз проверю эту щедрость ...

0
MacLeod - 7 Январь, 2017 - 07:07
Изображение пользователя MacLeod.

Я и сам хотел бы узнать откуда тогда берутся пакеты новых версий в "не поддерживаемом репозитории 17.04", как, например, Kaffeine.
Кто же вас так по-балабольски цитировать учил? Не говорите, что советская школа, не поверю... Дистрибутив неподдерживаемый, со всеми вытекающими.
К слову, репозиторий тоже лишь на этапе разработки. Для него сейчас корректируются правила Jenkins (сервера сборки) и идут итеративные попытки сборки новых версий софта. Будет релиз - будет полноценный дистрибутив. Но сейчас заниматься сравнением неподдерживаемого продукта, находящегося в разработке, с рабочими версиями, на которые установлены свежие бинарики плазмы, собранные на стороне, но из тех же исходников - какой-то адский маразм.

Если нужен какой-то софт предельно свежей версии - вот пример сборки Kaffeine под NEON из исходников, потратил две минуты на сборку и в три раза больше на описание (это к тому, что если не заниматься разной ерундой - можно быстро получить результат).

+1
Slavyanin - 30 Декабрь, 2016 - 06:58

Как интересно! Т. е. смешно.

0
AlexBKost - 6 Январь, 2017 - 17:57

Смейтесь на здоровье, продлевает жизнь.

+4
AlexBKost - 29 Январь, 2017 - 02:10

Второй альфа-выпуск Ubuntu 17.04

Началось тестирование второй альфа-версии дистрибутива Ubuntu 17.04 "Zesty Zapus" (первый альфа-выпуск был пропущен и публично не анонсировался. В процессе альфа-тестирования отдельные сборки не формируются, вместо них предлагается использовать ежедневные экспериментальные сборки. Готовые тестовые образы созданы только для Kubuntu, Lubuntu, Ubuntu Budgie, Ubuntu GNOME, Ubuntu Kylin, Ubuntu MATE. Релиз Ubuntu 17.04 запланирован на 13 апреля.

Рабочий стол Kubuntu обновлён до KDE Plasma 5.8.5, набор приложений до KDE Applications 16.12.1.;
KDE Frameworks 5.28.0; Qt 5.7.1. Текущая версия ядра 4.9.0-15-generic; XServer 1.18.4; LibreOffice 5.2.2; Firefox 50.1.0; Thunderbird 45.3.0; Synaptic 0.84.1; и т.д.

0
zarmon - 31 Январь, 2017 - 11:48

О спасибо как то пропустил)))

+2
AlexBKost - 5 Февраль, 2017 - 19:58

Произошли очередные улучшения.
На сегодня имеем: рабочий стол KDE Plasma 5.9.0, набор приложений до KDE Applications 16.12.1.;
KDE Frameworks 5.30.0; Qt 5.7.1. Текущая версия ядра 4.9.0-16-generic; Firefox 51.0.1; Thunderbird 45.7.0; Wicd 1.7.4 и т.д.

0
AlexBKost - 14 Февраль, 2017 - 22:52

Вчера состоялся Релиз Mesa 17.0.0 , а сегодня Mesa 17.0.0 уже на Kubuntu 17.04.

+1
AlexBKost - 16 Февраль, 2017 - 17:37

Вчера обновилось ядро на 4.10, а сегодня еще и Plasma 5.9.1 подтянулась:

0
kot040188 - 16 Февраль, 2017 - 17:38
Изображение пользователя kot040188.

Жить можно?

0
AlexBKost - 16 Февраль, 2017 - 17:57

Спрашиваешь. Я же живу. А если бы были проблемы, все узнали бы от меня первыми в этой теме.
Еще обновился libreoffice до 5.3.0~rc3-0ubuntu2.

0
AlexBKost - 20 Февраль, 2017 - 23:22

Опять плазма обновилась - теперь Plasma 5.9.2.

0
alex286 - 22 Февраль, 2017 - 23:07
Изображение пользователя alex286.

упс..

+4
AlexBKost - 24 Февраль, 2017 - 13:33

Бета-выпуск Ubuntu 17.04

Представлен бета-выпуск дистрибутива Ubuntu 17.04 "Zesty Zapus", который ознаменовал переход к первой стадии заморозки пакетной базы и смещение вектора разработки от развития новых возможностей к тестированию и исправлению ошибок. В соответствии с планом разработки для тестирования предлагается использовать ежедневные экспериментальные сборки. Готовые тестовые образы созданы только для Kubuntu, Lubuntu, Xubuntu, Ubuntu Budgie, Ubuntu GNOME, Ubuntu Kylin, Ubuntu MATE и Ubuntu Studio. Релиз Ubuntu 17.04 запланирован на 13 апреля.

Рабочий стол Kubuntu обновлён до KDE Plasma 5.9.2, набор приложений до KDE Applications 16.12.1.; KDE Frameworks 5.31.0; Qt 5.7.1. Текущая версия ядра 4.10.0-9-generic; XServer 1.18.4; Mesa 17.0.0; LibreOffice 5.3.0; Firefox 51.0.1; Thunderbird 45.7.0; Krusader 2.5.0 и т.д.

0
AlexBKost - 2 Март, 2017 - 21:10

За сегодня в два захода обновилась Plasma - 5.9.3. Еще ядро - 4.10.0-11-generic, и SMPlayer - 17.2.0.

ЗЫ: Никаких проблем с plasma-pa не было.

+2
AlexBKost - 24 Март, 2017 - 23:43

Финальный бета-выпуск Kubuntu 17.04

Сформирован финальный бета-выпуск дистрибутива Kubuntu 17.04 "Zesty Zapus". Релиз запланирован на 13 апреля.

Рабочий стол Kubuntu обновлён до KDE Plasma 5.9.4, набор приложений до KDE Applications 16.12.3.; KDE Frameworks 5.31.0; Qt 5.7.1. Текущая версия ядра 4.10.0-14-generic; XServer 1.18.4; Mesa 17.0.2; LibreOffice 5.3.1; Firefox 52.0.1; Thunderbird 45.7.0 и т.д.

0
kot040188 - 24 Март, 2017 - 23:38
Изображение пользователя kot040188.

Придётся перепродать.

+2
AlexBKost - 24 Март, 2017 - 23:56

Лучше подари нуждающемуся.

0
kot040188 - 25 Март, 2017 - 14:26
Изображение пользователя kot040188.

Блин, я так и не вспомнил какое слово я писал, но долбанное T9 жжёт! Придётся перебираться.

0
Priestone - 27 Март, 2017 - 09:17
Изображение пользователя Priestone.

А wacom как не работал адекватно, так и не работает... откачусь на 14.04.5, потому как важнее работать, чем играть в компьютер

0
AlexBKost - 3 Апрель, 2017 - 23:11

На 17.04 обновился Xserver до 1.19.3, соответственно и драйвер wacom обновился. Попробуйте еще раз, больше не знаю, чем вас утешить.

UPD: Случайно обратил внимание, что на 14.04 и 17.04 конфиг-файлы на wacom в папке /usr/share/X11/xorg.conf.d/ серьезно отличаются. Может здесь собака порылась (С)?

0
Priestone - 13 Апрель, 2017 - 13:49
Изображение пользователя Priestone.

Не... воз и ныне там. Стабильнее стало, правда. При подключении wacom-а уже не сразу зависает, а если не пером, а мышью или хоткеем графический редактор запустить, то иногда и порисовать даёт, правда часто без учёта нажима на перо (мышь-мышью).

Ноутбук уже сдауншифтил до 14.04.5, настольник на очереди. От бобра добра не ищут.

0
Aleksandru71 - 29 Март, 2017 - 20:36
Изображение пользователя Aleksandru71.

Мда, пятые я смотрю все ещё не допилены, а четвертые загибаются.
Установил 14.04 обновился до 14.04.5 каша какая то в пакетной базе.
Viber установился без ошибок но запускаться не хочет,
тоже самое с Vidiot.
Пытаешься установить то чего не хватает этим прогам, полсистемы хочет снестись.

0
werkty - 29 Март, 2017 - 22:03

Вам нужно просто взять и решиться :) И перейти на пятые.

+1
Aleksandru71 - 29 Март, 2017 - 22:32
Изображение пользователя Aleksandru71.

Предлагаете поменять один геморрой на другой?

0
AlexBKost - 29 Март, 2017 - 23:18

Мда, пятые я смотрю все ещё не допилены, а четвертые загибаются. Я только могу предположить, что с Viber и Vidiot вы сделали что-то не так. Только каким боком в этой теме 14.04, даже обновленная до 14.04.5?

0
Aleksandru71 - 30 Март, 2017 - 08:14
Изображение пользователя Aleksandru71.

Я просто обновил свеже установленную систему до 14.04.5 а потом стал устанавливать Viber и Vidiot.
А боком таким. Что хочешь не хочешь, а все же придется переходить на пятые кеды.

0
dyug - 30 Март, 2017 - 17:20

с вибером скорее всего sni чего-то там...
оно не отображалось в трее...

+2
AlexBKost - 12 Апрель, 2017 - 12:10

В заключение нужно что-нибудь написать, как-никак сегодня ещё День космонавтики, и мы тоже уже взлетели, ибо lsb_release -a говорит
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 17.04
Release:        17.04
Codename:       zesty


Счастливого всем полета на 17.04 Zesty Zapus!